DevHeads.net

Dependency Freeze for 4.10 in two weeks

Dependency freeze for 4.10 releases is in two weeks (November 1st), please be
sure you update all the needed dependencies before that date.

Notorious dependencies we might want to discuss:
* kdelibs depends on Qt 4.7
* kde-runtime depends on kdelibs 4.8.0
* kde-baseapps depends on kdelibs 4.8.0
* kde-workspace depends on kdelibs 4.8.1

Cheers,
Albert

Comments

Re: Dependency Freeze for 4.10 in two weeks

By David Faure at 10/21/2012 - 04:53

On Thursday 18 October 2012 22:32:12 Albert Astals Cid wrote:
Is anyone still testing kdelibs -- or the rest of KDE SC master -- with
Qt-4.7?

Qt-4.8 was released quite a long time ago, I would think we could raise the
dependency.

Re: Dependency Freeze for 4.10 in two weeks

By Laszlo Papp at 10/22/2012 - 03:35

Ok from Harmattan side as I do not work on it anymore. I am not aware
of anybody doing so either. L.

On 10/21/12, David Faure < ... at kde dot org> wrote:

Re: Dependency Freeze for 4.10 in two weeks

By Albert Astals Cid at 10/21/2012 - 11:48

El Diumenge, 21 d'octubre de 2012, a les 11:53:49, David Faure va escriure:
You know what file to update :-)

Cheers,
Albert

Re: Dependency Freeze for 4.10 in two weeks

By Dawit A at 10/18/2012 - 18:19

Actually kde-baseapps master requires kdelibs 4.10 to work correctly.
Otherwise, the new changes to the cookie settings dialog won't function
properly. I posted a request asking to update the required dependency, but
no one responded. See
<a href="http://lists.kde.org/?l=kde-core-devel&amp;m=134946200123794&amp;w=2" title="http://lists.kde.org/?l=kde-core-devel&amp;m=134946200123794&amp;w=2">http://lists.kde.org/?l=kde-core-devel&amp;m=134946200123794&amp;w=2</a>

Personally, I think for 4.10 release the kdelibs dependency should be
synchronized and updated to 4.10 for all the kdebase modules so that it
does not create any confusion.

Re: Dependency Freeze for 4.10 in two weeks

By Frank Reininghaus at 10/19/2012 - 06:44

Hi Dawit,

2012/10/19 Dawit A:
You asked if there are any objections, and apparently, there we none.
So I'd say that you can go ahead and update the required kdelibs
version in kde-baseapps.

Best regards,
Frank