DevHeads.net

Review Request 109814: bump workspace to require Qt 4.8.0

Review request for kde-workspace.

Description
<a href="http://git.reviewboard.kde.org/r/109784/" title="http://git.reviewboard.kde.org/r/109784/">http://git.reviewboard.kde.org/r/109784/</a> requires a Qt 4.8 feature and kdelibs/CMakeLists.txt already has

set (QT_MIN_VERSION "4.8.0")

so there's implicit requirement for it in kde-workspace as well, really no point in not bumping and just honest to do so.

I'll intend to push this into master (for 4.11) next Sunday - so if you've concerns or think someone else needs to be added to the request, please yell until then.

(inb4: "No, it's not an April fool")

Diffs
CMakeLists.txt 06b779b

Diff: <a href="http://git.reviewboard.kde.org/r/109814/diff/" title="http://git.reviewboard.kde.org/r/109814/diff/">http://git.reviewboard.kde.org/r/109814/diff/</a>

Testing

Thanks,

Thomas Lübking

Comments

Re: Review Request 109814: bump workspace to require Qt 4.8.0

By =?utf-8?Q?Thoma... at 04/01/2013 - 14:41

(Updated April 1, 2013, 6:41 p.m.)

Review request for kde-workspace.

Changes
updated description to newly discovered condition.

Description (updated)
<a href="http://git.reviewboard.kde.org/r/109784/" title="http://git.reviewboard.kde.org/r/109784/">http://git.reviewboard.kde.org/r/109784/</a> requires a Qt 4.8 feature

Though kdelibs/CMakeLists.txt in 4.10 already has >>set (QT_MIN_VERSION "4.8.0")<< kde-workspace atm. requires 4.9.4 which does have that requirement.

So this boils down to the question whether
a) kde-workspace 4.11 (or just git master) on kdelibs 4.9.x is actually a concern.
b) this would expose any downstream version gap (ie. shipping Qt 4.7 and KDE 4.9 but you want to compile workspace master)
eg. debian stable has Qt 4.6 (not supported, we already require 4.7) while testing has 4.8 - so there's no issue.
Ubuntu ships KDE 4.8 on Precise and 4.9 on Quantal (latter alongside Qt 4.8)

Diffs
CMakeLists.txt 06b779b

Diff: <a href="http://git.reviewboard.kde.org/r/109814/diff/" title="http://git.reviewboard.kde.org/r/109814/diff/">http://git.reviewboard.kde.org/r/109814/diff/</a>

Testing

Thanks,

Thomas Lübking

Re: Review Request 109814: bump workspace to require Qt 4.8.0

By Albert Astals Cid at 04/01/2013 - 18:18

Qt 4.8 seems like it was released 1.5 years ago, if we need it for a feature I don't see why we should not increase the requirement

- Albert Astals Cid

On April 1, 2013, 6:41 p.m., Thomas Lübking wrote:

Re: Review Request 109814: bump workspace to require Qt 4.8.0

By =?utf-8?Q?Thoma... at 04/02/2013 - 16:50

The argument in the Jan/2012 thread seemed "care about ppl. using older stock distro packages to work on"
While that's probably a valid reason I couldn't find some Qt 4.7 / KDE 4.9.4 combination (rather the opposite, eg. Qt 4.8 and KDE 4.8.4 on SuSE 12.2)
And yes, Qt 4.8 now exists for a looong time.

- Thomas

On April 1, 2013, 6:41 p.m., Thomas Lübking wrote:

Re: Review Request 109814: bump workspace to require Qt 4.8.0

By Michael Pyne at 04/01/2013 - 22:01

I agree. Even RHEL 6.2 seems to be able to build Qt 4.8, so it doesn't seem like a severe requirement for KDE 4.11.

- Michael

On April 1, 2013, 6:41 p.m., Thomas Lübking wrote:

Re: Review Request 109814: bump workspace to require Qt 4.8.0

By John Layt at 04/01/2013 - 14:12

All changes in requirements should be discussed on the k-c-d mailing list first.

- John Layt

On April 1, 2013, 5:47 p.m., Thomas Lübking wrote:

Re: Review Request 109814: bump workspace to require Qt 4.8.0

By =?utf-8?Q?Thoma... at 04/01/2013 - 14:29

What we just do (k-c-d is CC'd as group on the RR)

Though I just noticed that the dated kdelibs version required in master (4.9.4) does not have the Qt 4.8.0 requirement, so this is not just a technical thing and indeed means it has to be resolved whether kde-workspace 4.11 on kdelibs 4.9.x is indeed a valid case.

I'm not gonna push this until that aspect is sufficiently resolved.

- Thomas

On April 1, 2013, 5:47 p.m., Thomas Lübking wrote: