DevHeads.net

Windows

KStars now available on MS Store

Hello everyone,

KStars is now available on the Microsoft Store:
<a href="http://knro.blogspot.com/2018/09/kstars-on-microsoft-store.html" title="http://knro.blogspot.com/2018/09/kstars-on-microsoft-store.html">http://knro.blogspot.com/2018/09/kstars-on-microsoft-store.html</a>

Thanks to everyone who made this release possible include the KDE Windows
team especially Hannah Van Reth who made this possible.

Let your friends and family members who use a Windows PC know about this
release! Submitting reviews and feedback for the app is greatly appreciated!

Binary-Factory and download links

Hi,

if we e.g. want to link to the lastest produced binary packages
from the binary factory for Kate (nightly and release), what is the right
way to do that?

Is there some download.kde.org place were the last sucessfull builds are kept
some days for public consumption? I assume one should not link the latest successful
build pages like

<a href="https://binary-factory.kde.org/view/Windows%2064-bit/job/Kate_Release_win64/" title="https://binary-factory.kde.org/view/Windows%2064-bit/job/Kate_Release_win64/">https://binary-factory.kde.org/view/Windows%2064-bit/job/Kate_Release_wi...</a>

to the user, or?

Greetings
Christoph

New: Make gpgmepp available on MSVC build too

<a href="https://bugs.kde.org/show_bug.cgi?id=397494" title="https://bugs.kde.org/show_bug.cgi?id=397494">https://bugs.kde.org/show_bug.cgi?id=397494</a>

Bug ID: 397494
Summary: Make gpgmepp available on MSVC build too
Product: Craft
Version: unspecified
Platform: unspecified
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:lukasz. ... at gmail dot com">lukasz. ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Why is libgpgmepp.dll.a not available under MSVC?

Installing script under "libs/_

CI results for kxmlgui

Why is there no output from kxmlgui_unittest in
<a href="https://build.kde.org/view/Frameworks/job/Frameworks%20kxmlgui%20kf5-qt5%20WindowsMSVCQt5.10/21/console" title="https://build.kde.org/view/Frameworks/job/Frameworks%20kxmlgui%20kf5-qt5%20WindowsMSVCQt5.10/21/console">https://build.kde.org/view/Frameworks/job/Frameworks%20kxmlgui%20kf5-qt5...</a>
?

New: Cannot load any of the sample puzzles

<a href="https://bugs.kde.org/show_bug.cgi?id=396804" title="https://bugs.kde.org/show_bug.cgi?id=396804">https://bugs.kde.org/show_bug.cgi?id=396804</a>

Bug ID: 396804
Summary: Cannot load any of the sample puzzles
Product: kde-windows
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: major
Priority: NOR
Component: other
Assignee: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
Target Milestone: ---

I have KDE Palapeli sample puzzles nor create a new one. I had this same
problem many years ago on XP and reported it.

Build error for boost-regex on Mac

Hi Hannah and KDE windows,

I’m getting this build error when I try to install boost-regex using the standard blueprints in craft on Mac,

fatal error: 'cstddef' file not found"
/Users/rlancaste/AstroRoot/kstars-craft/bin/bjam: b'# include <cstddef>'
/Users/rlancaste/AstroRoot/kstars-craft/bin/bjam: b' ^~~~~~~~~'
/Users/rlancaste/AstroRoot/kstars-craft/bin/bjam: b'1 error generated.'

I’m fairly sure that this file is already on my system, so I think it is a linking or blueprint error with craft.

Any ideas,

Thanks,

Rob

rpath issues

Hi Hannah,

I was working for a long time today with getting Qt to build in craft on my Mac and getting everything required for KStars to build properly on top of that since you told me I shouldn’t be using ~/Qt/5.11.1. The issue really comes down to one thing: @rpath.

Phonon not building in craft now

Hi Hannah,

I’m not sure what happened, but there seems to be an issue with the phonon installation in craft now. Without phonon, Kf5nofitications cannot build. From the log it looks like a path issue that results in a file not found error. Your thoughts?

Thanks,

Rob

New: "craft kde" fails due to "CraftRoot/build/libs/glib/work/glib-2.49.4/glib/gconvert.c:59:2: error: #error GNU libiconv not in use but included iconv.h is from libiconv"

<a href="https://bugs.kde.org/show_bug.cgi?id=396033" title="https://bugs.kde.org/show_bug.cgi?id=396033">https://bugs.kde.org/show_bug.cgi?id=396033</a>

Bug ID: 396033
Summary: "craft kde" fails due to
"CraftRoot/build/libs/glib/work/glib-2.49.4/glib/gconv
ert.c:59:2: error: #error GNU libiconv not in use but
included iconv.h is from libiconv"
Product: Craft
Version: unspecified
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter:

New: "echo 0 | python3.6 CraftSetup.py --prefix ~/CraftRoot" fails due to "TypeError: join() argument must be str or bytes, not 'NoneType'"

<a href="https://bugs.kde.org/show_bug.cgi?id=396032" title="https://bugs.kde.org/show_bug.cgi?id=396032">https://bugs.kde.org/show_bug.cgi?id=396032</a>

Bug ID: 396032
Summary: "echo 0 | python3.6 CraftSetup.py --prefix
~/CraftRoot" fails due to "TypeError: join() argument
must be str or bytes, not 'NoneType'"
Product: Craft
Version: unspecified
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at aol dot de"> ... at aol dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>

New: Add option to specify compiler on command line to CraftBootstrap.py

<a href="https://bugs.kde.org/show_bug.cgi?id=396030" title="https://bugs.kde.org/show_bug.cgi?id=396030">https://bugs.kde.org/show_bug.cgi?id=396030</a>

Bug ID: 396030
Summary: Add option to specify compiler on command line to
CraftBootstrap.py
Product: Craft
Version: unspecified
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at aol dot de"> ... at aol dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Adding an option like `--compiler` would avoid the prompt

Libraw failing

Hi Hannah,

Libraw seems to be failing to build sometimes with a bunch of errors. But then other times it says it succeeded. Any ideas what I am doing wrong?

Thanks,

Rob

Craft KDE Connect install

Hi!

I'm attempting to install kdeconnect via craft on a Windows computer and so
I did
​:​

craft --add-blueprint-repository <a href="https://github.com/KDE/kdeconnect-kde.git" title="https://github.com/KDE/kdeconnect-kde.git">https://github.com/KDE/kdeconnect-kde.git</a>
craft kdeconnect

which results in a message like
​:​

Found an dead branch in
C:/CraftRoot/etc/blueprints/locations/kdeconnect-kde/app/qml. ...
nautilus-extension failed: Recipes must match the name of the directory:
C:\CraftRoot\etc\blueprints\locations\kdeconnect-kde\nautilus-extension\kdeconnect-share.py

Is this something you could help me with?

New: craft gwenhyfar Debug build fails

<a href="https://bugs.kde.org/show_bug.cgi?id=395585" title="https://bugs.kde.org/show_bug.cgi?id=395585">https://bugs.kde.org/show_bug.cgi?id=395585</a>

Bug ID: 395585
Summary: craft gwenhyfar Debug build fails
Product: Craft
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:jeffjl. ... at outlook dot com">jeffjl. ... at outlook dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

When it tests for Qt installation, it looks for non-debug versions of the Qt
libraries and fails

New: craft libarchive Debug build fails

<a href="https://bugs.kde.org/show_bug.cgi?id=395577" title="https://bugs.kde.org/show_bug.cgi?id=395577">https://bugs.kde.org/show_bug.cgi?id=395577</a>

Bug ID: 395577
Summary: craft libarchive Debug build fails
Product: Craft
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:jeffjl. ... at outlook dot com">jeffjl. ... at outlook dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Created attachment 113413
--> <a href="https://bugs.kde.org/attachment.cgi?id=113413&amp;action=edit" title="https://bugs.kde.org/attachment.cgi?id=113413&amp;action=edit">https://bugs.kde.org/attachment.cgi?id=113413&amp;action=edit</a>
adds

craft not finding installed utilities

For example, I know craft has grep and ninja installed, if nothing else
by looking at the output of "craft --print-installed" but invoking
either of them on the command line fails with a "the term is not
recognized..." error. I'm pretty sure things were working fine the
last time I did anything a few weeks ago. Today I tried "craft
kmymoney" and it upgraded numerous packages, and then failed on one,
claiming it couldn't find Ninja.

Has something changed recently requiring some change to my
configuration?

Craft kde/frameworks

Hi,

I'm trying to compile frameworks using craft, but I've encountered some
interesting situation, see this picture:


I get the same message if I try to compile separately
python-modules/doxyqml. I have Python2.7 set in
CraftRoot/etc/CraftSettings.ini

If you've already encountered this issue please share your thoughts on this.

Kind regards,

Fabian Kristof

is windows-mingw_64-clang valid for ABI?

The craftsettings.ini example file seems to say that windows-mingw_64-clang
should be valid for ABI, but "craft ninja" fails with "'clang' is not
recognized as an internal or external command, operable program or batch
file.warning: A compatible version of re2c (>= 0.11.3) was not found;
changes to src/*.in.cc will not affect your build." Is it not really
valid, is there a bug somewhere, or do I need to change some configuration?

The only packages installed so far are cacert, craft-blueprint-kde,
craft-core, 7zip, craft-startment-entry, git, mingw-w64, shimgen, wget, and
runtime.

Thanks.

I

New: Craft installation fails to download python

<a href="https://bugs.kde.org/show_bug.cgi?id=394644" title="https://bugs.kde.org/show_bug.cgi?id=394644">https://bugs.kde.org/show_bug.cgi?id=394644</a>

Bug ID: 394644
Summary: Craft installation fails to download python
Product: Craft
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

When doing a clean craft installation, it fails to grab Python 3.6.2 from the
server with the fol

New: Problem looking up libexec binaries in .DMG bundled apps on Mac

<a href="https://bugs.kde.org/show_bug.cgi?id=393946" title="https://bugs.kde.org/show_bug.cgi?id=393946">https://bugs.kde.org/show_bug.cgi?id=393946</a>

Bug ID: 393946
Summary: Problem looking up libexec binaries in .DMG bundled
apps on Mac
Product: Craft
Version: master
Platform: Mac OS X Disk Images
OS: OS X
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:thomas.friedrichsmeier@ruhr-uni-bochum.de">thomas.friedrichsmeier@ruhr-uni-bochum.de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

A tester has run into the followin

New: Can't install Amarok on Windows 10

<a href="https://bugs.kde.org/show_bug.cgi?id=393848" title="https://bugs.kde.org/show_bug.cgi?id=393848">https://bugs.kde.org/show_bug.cgi?id=393848</a>

Bug ID: 393848
Summary: Can't install Amarok on Windows 10
Product: Craft
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Hi, I run PowerShell as admin and then

C:\CraftRoot\craft\craftenv.ps1

Craft : C:\CraftRoo

New: Installation: don't require admin rights or abort if not provided

<a href="https://bugs.kde.org/show_bug.cgi?id=393810" title="https://bugs.kde.org/show_bug.cgi?id=393810">https://bugs.kde.org/show_bug.cgi?id=393810</a>

Bug ID: 393810
Summary: Installation: don't require admin rights or abort if
not provided
Product: Craft
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

I was not able to install Craft in PowerShell without a

New: ERROR: cannot verify files.kde.org's certificate, issued by `/C=GB/ST=Greater Manchester/L=Salford/O=COMODO CA Limited/CN=COMODO RSA Domain Validation Secure Server CA': Unable to locally verify the issuer's authority.

<a href="https://bugs.kde.org/show_bug.cgi?id=393809" title="https://bugs.kde.org/show_bug.cgi?id=393809">https://bugs.kde.org/show_bug.cgi?id=393809</a>

Bug ID: 393809
Summary: ERROR: cannot verify files.kde.org's certificate,
issued by `/C=GB/ST=Greater
Manchester/L=Salford/O=COMODO CA Limited/CN=COMODO RSA
Domain Validation Secure Server CA': Unable to locally
verify the issuer's authority.
Product: Craft
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR

New: klipper copy from windows 10 not working

<a href="https://bugs.kde.org/show_bug.cgi?id=393020" title="https://bugs.kde.org/show_bug.cgi?id=393020">https://bugs.kde.org/show_bug.cgi?id=393020</a>

Bug ID: 393020
Summary: klipper copy from windows 10 not working
Product: kde-windows
Version: unspecified
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: general
Assignee: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Reporter: <a href="mailto:paula.m. ... at gmail dot com">paula.m. ... at gmail dot com</a>
Target Milestone: ---

I am not able to cut and paste from windows 10 to klipper. I can cut and paste
from klipper to windows 10

Craft Error

Hi Hannah,

I got two new craft errors on OS X. It has been about a couple of weeks since I built KStars using craft, so I don’t know when the problems would have appeared. The first one was that it needed XML::Parser, so I tried

cpanm XML::Parser

And that seemed to fix that problem. I’m not sure if this needs to be stated as a requirement someplace, but I didn’t have to run that command before.

The other error is related to intltool. It says that my intltool is too old, but I believe it is included as a part of craft and if I am not mistaken, it is newer than 0.35.

digiKam Software Collection 5.9.0 is out...

Dear all digiKam fans and users,

The digiKam development team is proud to release digiKam
Software Collection 5.9.0. For more details, see announcement on
digikam.org:

<a href="https://www.digikam.org/news/2018-03-25-5.9.0_release_announcement/" title="https://www.digikam.org/news/2018-03-25-5.9.0_release_announcement/">https://www.digikam.org/news/2018-03-25-5.9.0_release_announcement/</a>

Best

Gilles Caulier

New: qt-libs/poppler: error C2535: 'QChar::QChar(ushort) noexcept': member function already defined or declared

<a href="https://bugs.kde.org/show_bug.cgi?id=391829" title="https://bugs.kde.org/show_bug.cgi?id=391829">https://bugs.kde.org/show_bug.cgi?id=391829</a>

Bug ID: 391829
Summary: qt-libs/poppler: error C2535: 'QChar::QChar(ushort)
noexcept': member function already defined or declared
Product: Craft
Version: master
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:fischer@unix-ag.uni-kl.de">fischer@unix-ag.uni-kl.de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Craft'ing qt-li

New: Skrooge requires sqlcipher, but not found

<a href="https://bugs.kde.org/show_bug.cgi?id=391690" title="https://bugs.kde.org/show_bug.cgi?id=391690">https://bugs.kde.org/show_bug.cgi?id=391690</a>

Bug ID: 391690
Summary: Skrooge requires sqlcipher, but not found
Product: Craft
Version: unspecified
Platform: Windows CE
OS: Windows CE
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

I try to install Skrooge on Windows 10.

New: libjpeg craft package should depend on libtiff

<a href="https://bugs.kde.org/show_bug.cgi?id=391031" title="https://bugs.kde.org/show_bug.cgi?id=391031">https://bugs.kde.org/show_bug.cgi?id=391031</a>

Bug ID: 391031
Summary: libjpeg craft package should depend on libtiff
Product: kde-windows
Version: unspecified
Platform: Other
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: buildsystem
Assignee: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
Target Milestone: ---

the libjpeg craft package does not automatically require libtiff, despite
libjpeg's configure script itself requiring libt

Dolphin on windows?

Hello!

"craft dolphin" still seems to require kdelibs4support. When attempting to
build on windows using Visual Studio 2017's compiler, I encountered error
messages relating to the use of functions not available in windows. In
particular:

kdeui/kapplication_win.cpp (kill should probably be TerminateProcess)
kdecore/kkernel_win.cpp (strlcpy/strlcat are still strncpy/strncat on
windows)

Is building this library on windows with the visual studio compiler
supported? Is it supposed to be?

thanks (and sorry for inundating you guys!)

~matthew

Konsole on windows?

Hi everyone,

I think the answer to this is "no", but is it in principle possible to
build konsole on windows? Naively using craft to build konsole results in
"Could NOT find KF5 (missing: Pty)".

My investigation so far suggests that I already have kpty installed at
version 5.43.0, which is surprising since psuedo-terminals are such a
nix-specific item.

Branching 2018.03

Hi everyone,

Today I created the branch 2018.03 of the blueprints.

This will be the next and last stable branch based on Qt 5.9

The branching is most relevant for the use of the binary cache, as the
the cache on master
will now be based on Qt 5.10 and OpenSSL 1.1.0g.

If you have important changes, please commit them to 2018.03 and they
will be merged to master.

Updates of libraries, besides updates to frameworks should only go to
master.

Have a nice weekend!

Cheers,

Hannah

Cannot open include file: 'stddef.h': No such file or directory

Hello all,

When trying to build icu with craft, I receive the error:

R:\build\win32libs\icu\work\icu\source\common\unicode/ptypes.h(43): fatal
error C1083: Cannot open include file: 'stddef.h': No such file or
directory [R:\build\win32libs\icu\work\icu\source\stubdata\stubdata.vcxproj]

I am using VisualStudio 2017's compiler , and I have verified that Windows
10 and Windows 8.1 SDK are both installed.

New: desktop grid cause system halt

<a href="https://bugs.kde.org/show_bug.cgi?id=390743" title="https://bugs.kde.org/show_bug.cgi?id=390743">https://bugs.kde.org/show_bug.cgi?id=390743</a>

Bug ID: 390743
Summary: desktop grid cause system halt
Product: kde-windows
Version: unspecified
Platform: openSUSE RPMs
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: general
Assignee: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Reporter: <a href="mailto:marcel. ... at gmail dot com">marcel. ... at gmail dot com</a>
Target Milestone: ---

The system does not response and halt for quite a while if the desktop grid is
triggered using shortcut.

System details:
Opensuse Tum

New: win32libs/openssl build error

<a href="https://bugs.kde.org/show_bug.cgi?id=390649" title="https://bugs.kde.org/show_bug.cgi?id=390649">https://bugs.kde.org/show_bug.cgi?id=390649</a>

Bug ID: 390649
Summary: win32libs/openssl build error
Product: Craft
Version: stable
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

(vs2017 64bit)

Type:

craft win32libs/openssl

.\crypto\srp\srp_vfy.c(104): warning C4244: '=': conversion fro

New: Building qtsvg fails on msvc

<a href="https://bugs.kde.org/show_bug.cgi?id=390600" title="https://bugs.kde.org/show_bug.cgi?id=390600">https://bugs.kde.org/show_bug.cgi?id=390600</a>

Bug ID: 390600
Summary: Building qtsvg fails on msvc
Product: Craft
Version: master
Platform: Other
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:lukasz. ... at gmail dot com">lukasz. ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Steps to reproduce:
1) start craftenv.ps1
2) craft qtsvg

Result:
Compilation fails because it cannot fin

New: Building ninja on MSVC 15.5.6 fails

<a href="https://bugs.kde.org/show_bug.cgi?id=390564" title="https://bugs.kde.org/show_bug.cgi?id=390564">https://bugs.kde.org/show_bug.cgi?id=390564</a>

Bug ID: 390564
Summary: Building ninja on MSVC 15.5.6 fails
Product: Craft
Version: master
Platform: Other
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:lukasz. ... at gmail dot com">lukasz. ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Created attachment 110720
--> <a href="https://bugs.kde.org/attachment.cgi?id=110720&amp;action=edit" title="https://bugs.kde.org/attachment.cgi?id=110720&amp;action=edit">https://bugs.kde.org/attachment.cgi?id=110720&amp;action=edit</a>
powershell out

Is the kde on windows project alife

i use the kdeonwindows install 1.1.0 install,bug it go wrong with this:
download remote config file from QUrl( "http://download.kde.org/Attic/stable/4.14.3/config.txt" ) to "C:/Users/xxx/AppData/Local/Temp/KDE/config.txt" ... failure
i see the size:http://download.kde.org/Attic/stable/4.14.3/,it only have the "src" directory,and no config.txt exist。

New: Undefined reference to gcrypt while trying to compile xmlsec1

<a href="https://bugs.kde.org/show_bug.cgi?id=389817" title="https://bugs.kde.org/show_bug.cgi?id=389817">https://bugs.kde.org/show_bug.cgi?id=389817</a>

Bug ID: 389817
Summary: Undefined reference to gcrypt while trying to compile
xmlsec1
Product: Craft
Version: master
Platform: Compiled Sources
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Blueprints
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto:lukasz. ... at gmail dot com">lukasz. ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Created attachment 110314
--> <a href="https://b" title="https://b">https://b</a>

New: craft nsis fails

<a href="https://bugs.kde.org/show_bug.cgi?id=389799" title="https://bugs.kde.org/show_bug.cgi?id=389799">https://bugs.kde.org/show_bug.cgi?id=389799</a>

Bug ID: 389799
Summary: craft nsis fails
Product: Craft
Version: stable
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Actual result: Installer creation advertises 'craft nsis' installation but this
fails.

Expected: 'craft nsis' installs.

Is is good idea to

New: Craft fails are bootstrap, and then on 'craft craft'

<a href="https://bugs.kde.org/show_bug.cgi?id=389779" title="https://bugs.kde.org/show_bug.cgi?id=389779">https://bugs.kde.org/show_bug.cgi?id=389779</a>

Bug ID: 389779
Summary: Craft fails are bootstrap, and then on 'craft craft'
Product: Craft
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Issue 1. Bootstrap.

A new tier1 for icontheme.rcc handling

Hi everyone.

Only some few of you will be aware of KIconThemes ability to load binary
icon themes automagically.

<a href="https://cgit.kde.org/kiconthemes.git/tree/src/kicontheme.cpp#n48" title="https://cgit.kde.org/kiconthemes.git/tree/src/kicontheme.cpp#n48">https://cgit.kde.org/kiconthemes.git/tree/src/kicontheme.cpp#n48</a>

The code looks for a icontheme.rcc and sets it as default theme.

On Windows and Mac we rely on that code as it is more feasible to
install that one
file with an single application installer.

digiKam Software Collection 5.8.0 is out...

Dear all digiKam fans and users,

The digiKam development team is proud to release digiKam
Software Collection 5.8.0. For more details, see announcement on
digikam.org:

<a href="https://www.digikam.org/news/2018-01-14-5.8.0_release_announcement/" title="https://www.digikam.org/news/2018-01-14-5.8.0_release_announcement/">https://www.digikam.org/news/2018-01-14-5.8.0_release_announcement/</a>

Have an happy new year 2018 with digiKam...
Gilles Caulier

Qt Data Visualization?

Hello,

Is it possible to include Qt Data Visualization in Craft for Windows? It is
used by KStars now and we would like to utilize it.

New: KDE installer on Windows 7: Mirror list could not be downloaded

<a href="https://bugs.kde.org/show_bug.cgi?id=388452" title="https://bugs.kde.org/show_bug.cgi?id=388452">https://bugs.kde.org/show_bug.cgi?id=388452</a>

Bug ID: 388452
Summary: KDE installer on Windows 7: Mirror list could not be
downloaded
Product: kde-windows
Version: unspecified
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: critical
Priority: NOR
Component: installer
Assignee: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Reporter: <a href="mailto:lukas- ... at gmx dot de">lukas- ... at gmx dot de</a>
Target Milestone: ---

Created attachment 109624
--> <a href="https://bugs.kde.org/attachment.cgi?id=10962" title="https://bugs.kde.org/attachment.cgi?id=10962">https://bugs.kde.org/attachment.cgi?id=10962</a>

New: QFileDialog::getExistingDirectoryUrl hangs on 'this pc' (binary factory build)

<a href="https://bugs.kde.org/show_bug.cgi?id=388280" title="https://bugs.kde.org/show_bug.cgi?id=388280">https://bugs.kde.org/show_bug.cgi?id=388280</a>

Bug ID: 388280
Summary: QFileDialog::getExistingDirectoryUrl hangs on 'this
pc' (binary factory build)
Product: kde-windows
Version: unspecified
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: porting
Assignee: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Reporter: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Target Milestone: ---

- download filelight from factory
- install
- start
- click 'open'
- dir open dial

New: Problems installing in w$ 10

<a href="https://bugs.kde.org/show_bug.cgi?id=388110" title="https://bugs.kde.org/show_bug.cgi?id=388110">https://bugs.kde.org/show_bug.cgi?id=388110</a>

Bug ID: 388110
Summary: Problems installing in w$ 10
Product: Craft
Version: master
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

The shell version is:
PS C:\> $PSVersionTable.PSVersion

Major Minor Build Revision
----- ----- ----- --------

New: install updated version of libofx

<a href="https://bugs.kde.org/show_bug.cgi?id=386879" title="https://bugs.kde.org/show_bug.cgi?id=386879">https://bugs.kde.org/show_bug.cgi?id=386879</a>

Bug ID: 386879
Summary: install updated version of libofx
Product: Craft
Version: master
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

craft libofx

installs version 0.9.10 of libofx. This version was released more than 3 years
ago.

New: install updated version of libfftw

<a href="https://bugs.kde.org/show_bug.cgi?id=386878" title="https://bugs.kde.org/show_bug.cgi?id=386878">https://bugs.kde.org/show_bug.cgi?id=386878</a>

Bug ID: 386878
Summary: install updated version of libfftw
Product: Craft
Version: master
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

craft libfftw

installs version 3.2.2 of FFTW.

New: installing libfftw via craft fails

<a href="https://bugs.kde.org/show_bug.cgi?id=386788" title="https://bugs.kde.org/show_bug.cgi?id=386788">https://bugs.kde.org/show_bug.cgi?id=386788</a>

Bug ID: 386788
Summary: installing libfftw via craft fails
Product: Craft
Version: master
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

Executing

craft libfftw

downloads and compiles libfftw but it fails with make cmd:

plan-many-dft.c.obj : warn

New: outdated version of liblzma

<a href="https://bugs.kde.org/show_bug.cgi?id=386778" title="https://bugs.kde.org/show_bug.cgi?id=386778">https://bugs.kde.org/show_bug.cgi?id=386778</a>

Bug ID: 386778
Summary: outdated version of liblzma
Product: Craft
Version: master
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

On a fresh Craft installation I want to get the KDE framework.

New: using QtSDK doesn't work on Windows

<a href="https://bugs.kde.org/show_bug.cgi?id=386776" title="https://bugs.kde.org/show_bug.cgi?id=386776">https://bugs.kde.org/show_bug.cgi?id=386776</a>

Bug ID: 386776
Summary: using QtSDK doesn't work on Windows
Product: Craft
Version: master
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

I set up Craft from scratch following the guidelines in
<a href="https://community.kde.org/Guidelines_and_HOWTOs/Build_f" title="https://community.kde.org/Guidelines_and_HOWTOs/Build_f">https://community.kde.org/Guidelines_and_HOWTOs/Build_f</a>

New: Wrong default compiler in craftsettings.ini under QtSDK

<a href="https://bugs.kde.org/show_bug.cgi?id=386761" title="https://bugs.kde.org/show_bug.cgi?id=386761">https://bugs.kde.org/show_bug.cgi?id=386761</a>

Bug ID: 386761
Summary: Wrong default compiler in craftsettings.ini under
QtSDK
Product: Craft
Version: stable
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

I setup craft from scratch as described in
<a href="https://community.kde.org/Gu" title="https://community.kde.org/Gu">https://community.kde.org/Gu</a>

New: Python error with craftenv.ps1

<a href="https://bugs.kde.org/show_bug.cgi?id=386757" title="https://bugs.kde.org/show_bug.cgi?id=386757">https://bugs.kde.org/show_bug.cgi?id=386757</a>

Bug ID: 386757
Summary: Python error with craftenv.ps1
Product: Craft
Version: stable
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

I installed the latest craft following these guidelines:
<a href="https://community.kde.org/Guidelines_and_HOWTOs/Build_from_" title="https://community.kde.org/Guidelines_and_HOWTOs/Build_from_">https://community.kde.org/Guidelines_and_HOWTOs/Build_from_</a>

New: configuring craft to use snore doesn't work

<a href="https://bugs.kde.org/show_bug.cgi?id=386051" title="https://bugs.kde.org/show_bug.cgi?id=386051">https://bugs.kde.org/show_bug.cgi?id=386051</a>

Bug ID: 386051
Summary: configuring craft to use snore doesn't work
Product: Craft
Version: unspecified
Platform: Other
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

the CraftSettings.ini config file says it is required to configure craft for
using snore notification

iconv.dll not found

Hi All,
I am using Microsoft Windows 10, kde-windows installer 1.1.0.
When I run bovo, its says “iconv.dll not found”
I then delete bovo and install bovo via the above mentioned installer.
When I then run bovo, it still says “iconv.dll not found.
What am I doing wrong?
How do I get inconv.dll installed again?
Yours Sincerely
Stephen Grant Brown

FYI: Beware of packaging bug wrt qtwebengine

Heya,

I've just applied some fixes to the qtwebengine recipe which move some files
to the "correct" location after qtwebengine has been installed. It looks like
this worked fine without my patch when you ran the executable on the same
machine (I assume some hardcoded paths internally in QtWE), but it does *not*
when you run the executable on a different machine.

If the files are not in their resp. location, anything using QtWebEngine to
show a page will just crash (somewhere in WebEngineContext::current() in
Qt5WebEngineCore).

Error crafting mysql

I'm seeing this error when building the mysql blueprint:

PS C:\kde> craft mysql
=============================================================================================================================================================================================================================================
*** Handling package: binary/mysql, action: all ***
*** Action: fetch for binary/mysql ***
*** Action: unpack for binary/mysql ***
Digests for 5.7.18:
(['bcd89314c51bc920d2351976bb34de10f1081b52501fe9b0eb598826227ef224'],
CraftHash.HashAlgorithm.SHA256)
executing command: C:\kde\d

Build #33 missing qca-qt5.dll

I download and installe latest stable Konversation from:

<a href="https://binary-factory.kde.org/job/konversation-stable-win32" title="https://binary-factory.kde.org/job/konversation-stable-win32">https://binary-factory.kde.org/job/konversation-stable-win32</a> (Build #33)

But could not use it, because qca-qt5.dll missing.

digiKam Software Collection 5.7.0 is out...

Dear all digiKam fans and users,

The digiKam development team is proud to release digiKam
Software Collection 5.7.0. For more details, see announcement on
digikam.org:

<a href="https://www.digikam.org/news/2017-09-11-5.7.0_release_announcement/" title="https://www.digikam.org/news/2017-09-11-5.7.0_release_announcement/">https://www.digikam.org/news/2017-09-11-5.7.0_release_announcement/</a>

Have good moments with digiKam...

Gilles Caulier

Syndicate content