DevHeads.net

New: Python error with craftenv.ps1

<a href="https://bugs.kde.org/show_bug.cgi?id=386757" title="https://bugs.kde.org/show_bug.cgi?id=386757">https://bugs.kde.org/show_bug.cgi?id=386757</a>

Bug ID: 386757
Summary: Python error with craftenv.ps1
Product: Craft
Version: stable
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Core
Assignee: <a href="mailto: ... at kde dot org"> ... at kde dot org</a>
Reporter: <a href="mailto: ... at web dot de"> ... at web dot de</a>
CC: <a href="mailto:kde- ... at kde dot org">kde- ... at kde dot org</a>
Target Milestone: ---

I installed the latest craft following these guidelines:
<a href="https://community.kde.org/Guidelines_and_HOWTOs/Build_from_source/Windows" title="https://community.kde.org/Guidelines_and_HOWTOs/Build_from_source/Windows">https://community.kde.org/Guidelines_and_HOWTOs/Build_from_source/Windows</a>

At first there is a bug in the desription because
craftenv.ps1
is not under
C:\KDEROOT\craft\
but under
C:\CraftRoot\craft

I use CMake 3.9.5, Python 3.6.3, Qt 5.9.2 and ECM 5.39.0

I run now a powershell and entered

C:\CraftRoot\craft\craftenv.ps1

then I get a Python error:

python.exe : Craft Root : C:\CraftRoot
At C:\CraftRoot\craft\craftenv.ps1:80 char:2
+ (& $env:CRAFT_PYTHON ([IO.PATH]::COMBINE("$env:CraftRoot", "bin", "Cr ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (Craft Root : C:\CraftRoot
:String) [], RemoteException
+ FullyQualifiedErrorId : NativeCommandError

Craft : R:\
Version : master
ABI : windows-msvc2015_64-cl
Svn directory : C:\CraftRoot\download\svn
Git directory : Q:\
Download directory : C:\CraftRoot\download

In my CraftSettings.ini I read
Python = C:\Program Files (x86)\Python36-32
so Python was correctly detected.