I'm trying to build a Debian package for Ruby, but checkinstall is freezing during "make install"


I have a question about compiling and packaging Ruby.

I'm compiling Ruby 2.5.5 with jemalloc in a Docker container, and I'm
trying to build a Debian package with checkinstall
This tool runs "make install", records a list of changed files, and then
saves all of these files into a deb package. However, checkinstall is
getting stuck after this line: "generating x86_64-linux-fake.rb". If I run
"make install" by itself, then everything works as normal.

I have prepared a gist that contains my Dockerfile and build script:
<a href="" title=""></a>

Steps to reproduce:

# Requirements: Docker, curl

mkdir -p /tmp/docker-ruby
cd docker-ruby
curl -sfLO <a href="" title=""></a>
curl -sfLO <a href="" title=""></a>
chmod +x

You should see that "checkinstall" gets permanently stuck on Step 14/15.

Unfortunately there is no output or error messages, and I couldn't see
anything in the Makefile that might be causing it (but I don't have too
much relevant experience in this area.)

A few questions:

- Is there a checkinstall flag that I could use to solve this problem?
- Is there a way that I could wrap or modify the "make install" command
to avoid getting stuck? (I tried bash -c "make install", but that didn't
- Is there a different tool I should be using to prepare the deb package?

Thanks very much for your time!

Best Regards,
Nathan Broadbent

P.S. I have also asked this same question on the Unix StackExchange site:
<a href="" title=""></a>