DevHeads.net

An issue with a Technical Meritocracy

As we talk about "Nice" and "Tk" I saw an issue in the traditional
Open Source meritocracy pattern.

We promote, through "cred" (credibility), those who show strong
technical merit. They become "leaders". Yet "leading", and "organizing
a group who can contribute to a project", are very different skills
from "coding ability" and "technical savvy".

I thought through Marvin Gülker's comments about people contributing
to revive Tk. Mixed that with Andy's reply and Nicola's support, and
realized that a team could be formed but the organizer would need to
be able to do Ruby, C, and leadership. Maybe not a guru in the first
two but as Andy says; we all have competing demands on our time and
mental energy.

So yes, I've given thought to the Tk idea. There seems to be
possibilities but one of the first challenges would be to support the
team members at the level they can participate at. "Encouraging
People" seems to be different than "Optimizing Code". :)

Leam

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

Comments

Re: An issue with a Technical Meritocracy

By John W Higgins at 08/07/2018 - 13:18

I'd like to point out that not a single actual issue has been raised that
shows any issue with the current Tk gem.

The best I've seen is an attempt at "gem install tk" that failed - not a
single line of error - nor any attempt to ascertain what the error was -
nor any mention of whether or not Tk was even installed on said machine.

Ruby Tk most certainly, at least under conditions that I can validate,
works under Tk 8.6.8 - from a fresh linux system I installed Ruby - Tk -
and then gem install tk worked without issue.

I make no assertions other than any statement that "Ruby Tk relies on an
outdated version of Tk" is not correct. That does not imply nor assert that
the installation process is smooth - easy - or anything else (although in
my scenario it certainly was anything but painful).

Absent actual bug reports of issues that stem from someone at least
attempting to read the instructions provided in the repo[1] then I think it
is rather rude to call a project dead or whatever other terms have been
used over the last few days. Claiming that people are not nice while
trashing the work of others as not working seems rather counter productive.

It is great to be passionate about something - but one needs to temper
passion with respect for those that actually do the work - nothing is
gained by typing "gem install tk" having it not work and then claiming the
project is dead because of that.

John W Higgins

[1] - <a href="https://github.com/ruby/tk" title="https://github.com/ruby/tk">https://github.com/ruby/tk</a>

P.S. Also planning what appears to be an attempted takeover of a project
that merged a pull request as late as May of this year also seems very
unfriendly and not very "nice", again, in terms of respecting those people
that have gotten things where they are today. I again point out that not a
single issue has been raised in the repo.

Re: An issue with a Technical Meritocracy

By Nicola Mingotti at 08/08/2018 - 18:21

Hi,

I tried 2 things

1] run "gem install tk" in my Mac, (I don't use that for dev. usually)
and i installed
without any errors. But, on the Mac i have already installed a few
versions of TclTk.

2] I prepared a fresh new virtual machine with FreeBSD 11.1, only X and
wmaker installed.

I install ruby from package (2.4.4), install "gem", then i try to
#> gem install tk
I know it will fail, there is no TclTk installed, the message i get is this
-] I install package for Tk8.6
-] #> gem install tk
=> same message as before.

So, my first conclusion is that, if RubyTk is ready for Tk 8.6, the
warning message is misleading.
People would not even try to compile for Tk8.6.

My second conclusion is: I will prepare a port/package for rubytk in
FreeBSD as soon as possible.

bye
nico

On 08/07/18 19:18, John W Higgins wrote:

Re: An issue with a Technical Meritocracy

By botp at 08/09/2018 - 00:08

many thanks and many regards,
--botp

Re: An issue with a Technical Meritocracy

By Varro at 08/08/2018 - 21:11

On Tuesday, 7 Aug 2018 1:18 PM -0400, John W Higgins wrote:
Oh dear. I think you may be referring to a post that *I* made.

In my earlier post, I did include (I will admit) a quite abbreviated
error message. If you really want the whole, rather long, output I
*can* include it, but the most salient lines are:

Warning:: cannot find Tcl library. tcltklib will not be compiled (tcltklib is disabled on your Ruby. That is, Ruby/Tk will not work). Please check configure options.

--8<---------------cut here---------------start------------->8---
Can't find proper Tcl/Tk libraries. So, can't make tcltklib.so which is required by Ruby/Tk.
If you have Tcl/Tk libraries on your environment, you may be able to use them with configure options (see ext/tk/README.tcltklib).
At present, Tcl/Tk8.6 is not supported. Although you can try to use Tcl/Tk8.6 with configure options, it will not work correctly. I recommend you to use Tcl/Tk8.5 or 8.4.
--8<---------------cut here---------------end--------------->8---

Looking at the log
/usr/local/lib/ruby/gems/2.4/extensions/amd64-freebsd-10/2.4/tk-0.2.0/mkmf.logI
see the following:

--8<---------------cut here---------------start------------->8---
"cc -o conftest -I/usr/local/include/ruby-2.4//amd64-freebsd10 -I/usr/local/include/ruby-2.4//ruby/backward -I/usr/local/include/ruby-2.4/ -I. -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local -I/usr/local/include -isystem /usr/local/include -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing -fPIC conftest.c -L. -L/usr/local/lib -L/usr/local/lib -L. -fstack-protector -rdynamic -lX11 -lm -lruby24 -L/usr/local/lib -ltcl86 -lX11 -lm -lunwind -lexecinfo -lprocstat -lthr -lcrypt -lm -lpthread -L/usr/local/lib -L/usr/local/lib -lc"
conftest.c:3:10: fatal error: 'tcl.h' file not found
#include <tcl.h>
--8<---------------cut here---------------end--------------->8---

So, *is* there a tcl.h installed? Of course there is:

# find /usr/local -name tcl.h
/usr/local/include/tcl8.6/generic/tcl.h
/usr/local/include/tcl8.6/tcl.h

But of course, this is the *current* version, not an obsolete version.

I don't run any version of Linux for production work.

First of all, I don't think that I *ever* claimed that people are not
nice, nor have I *trashed* the work of others. Claiming that the
current state of affairs is not working is not "trashing" the work that
has already gone into this, but it stating the fact that that work has
(as far as I can see) stopped.

I (like I imagine most people) rely on the what is it packaged for
one's own particular platform. I have no desire (like I imagine most
people) to debug problems for a package that I don't actually use
(though I might use if I had some reasonable assurance that it would
actually work).

If I have given the impression that I do not respect the work that
other people have devoted to it, the I *do* apologise. I do not want
to denigrate the efforts of others, but only to express my frustration
that the state of GUI support is now so poor in Ruby.

Re: An issue with a Technical Meritocracy

By leam hall at 08/07/2018 - 13:26

On Tue, Aug 7, 2018 at 1:18 PM, John W Higgins < ... at gmail dot com> wrote:

Hey John, I think it's more "enthusiasm" than "attempted takeover". :)

Marvin's URL's provided the report from Nagai, who also commented on
one of the threads yesterday. When I looked at the Ruby/Tk github
repo, it did seem to be very quiet. Maybe not totally dead and
forgotten, but I'm not sure how much activity constitutes "life".

Part of my recommedation on leadership assumed time spent figuring out
what the current state is, what the group would like it to be, and
what the gaps are. Sorry if I didn't make that more explicit; perhaps
there are no issues and Ruby/Tk can be built with the latest Tk as is?

Leam

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

Re: An issue with a Technical Meritocracy

By Nicola Mingotti at 08/07/2018 - 13:53

In regard to John message i would like to share with you
my notes on installing Tk in ruby as a Gem in FreeBSD and Debian. It was
not immediate.
That is the reason why i took notes !

Notes are in italian, sorry ... but you can watch only code lines.

Besides that, at the cost of sounding repetitive as an old decrepit man,
the point for which i raised the topic of Tk is not its non triviality
in installing for developers, we can fight, ask, write, modify, try,
retry ... untill we get it !

 == It is because for normal users it is (almost) impossible to have a
ruby script with GUI working ==

------- Debian Stable (about 1.2 years ago) [not the latest stable,
probably] ------------------------------------
Odissea installazione Tk.-] Su Debian 8.9 il Ruby piu' recente e' il
2.1, troppo vecchio-] Installo da Sorgente il Ruby 2.4.2-] Mi assicuro
che lanciando irb da "p" e da "root" la versione che viene presa di
default e' la 2.4.2. Questo per essere sicuri che anche il comando "gem"
operi sulla giusta versione di Ruby. Quella nuova.-] Tk nel nuovo Ruby
va installato come gem-] Non usare la versione di Tk fornita con Debian,
ci sono un sacco di problemi.-] Scaricare da sorgente la versione di Tcl
e Tk 8.5.9-] Compilare e installare Tcl-] Compilare e installare Tk-] Da
root dare li comando:#> gem install tk -- --with-tcltkversion=8.5,8.5
---------------------------------FreeBSD 11.1 (about 5 months ago)
1.

-] Installare TclTk 8.5 da ports con … *] Installare la
documentazione e gli esempi*] Viene chiesto di installare anche Tcl,
ovviamente la riposta da dare e' si. #> cd
/usr/ports/x11-toolkits/tk85#> make install clean-] Installare la
gemma Tk per Ruby con -] questo fallisce, non trova la libreria tk
#> gem install tk -- --with-tcltkversion=8.5,8.5
\          --with-tk-include=/usr/local/include/tk8.5 \
          --with-tcl-include=/usr/local/include/tcl8.5

On 08/07/18 19:26, leam hall wrote:

Re: An issue with a Technical Meritocracy

By Nicola Mingotti at 08/07/2018 - 11:40

Lem, here is how I can seriously propose to be of help:

1] I can test the code is working on a 2-3 day frequency basis.
I can test it in FreeBSD and Mac (OSX 10.11.6).

2]  I could fix the "tkruby" port/package in FreeBSD wich at the moment
is missing.
This is not the objective, but in a transition time it can be usuful for
other Tk Ruby users.
[i never made ports, but i guess i can make it in reasonable time] .

3] I will go to live in the San Francisco area from about 15 September,
If members of the team are in that area i can organize
pizza+beers meetings at regular frequency.

4] if some kind of croudfounding is needed i would be the first contributor

bye
n.

On 08/07/18 15:54, leam hall wrote:

Re: An issue with a Technical Meritocracy

By Don Wilde at 08/07/2018 - 12:30

Nicola, thanks for the offer, and I appreciate that level of cozy
support... for those in San Francisco. :)

I am not the world's best anything, but I have extensive experience
with Ruby, C, Linux, FreeBSD and coding in general. I've been at this
a long time! I have not personally been a FOSS contributor, more an
application and systems coder... and FOSS user!

Learn's suggestion that leadership is a skill-set that is different
from coding. I agree. I have a degree in sociology and psychology and
I have had many leadership trainings and leadership positions during
my career. I was once hired by Bob Bruce as an advocacy coordinator
for the FreeBSD Project and I coordinated the three-way press
conference at which Darwin was announced. If the group decides to
allow me to contribute in this way, I would be honored to coordinate
the global effort. Local efforts like Nicola's are to be commended,
though we can't let this become an inter-group competitive thing. I
see that it is important to welcome international contribution and
participation.

As I see it, my role will be saying "oh, wow, cool!", at appropriate
places, and, more importantly, "It's time to vote."

If you all agree, I appreciate the honor.

I have set up ' ... at gmail dot com' as an initial account. We do need
a listserv; can somebody take that on? I believe ZOOM.us is an
excellent collaboration tool. It' not perfect, but it's a start. Those
of you who do not have native clients available have the option of
installing a FireFox plug-in. Phone clients are available as well as
PC Doze, Linux and browser.

On 8/7/18, Nicola Mingotti < ... at gmail dot com> wrote:

Re: An issue with a Technical Meritocracy

By Marvin =?UTF-8?... at 08/07/2018 - 13:31

Am 07. August 2018 um 09:30 Uhr -0700 schrieb Donald Wilde:
If you need a mailinglist, try freelists.org. I've only ever had good
experiences with their services.

However, please listen to John's concerns.

Marvin

Re: An issue with a Technical Meritocracy

By Don Wilde at 08/07/2018 - 13:37

Yes, and I agree with them. My offer is open, if Tk requires more than
patches to ensure installation, I'm here.

Re: An issue with a Technical Meritocracy

By Marvin =?UTF-8?... at 08/07/2018 - 11:07

Am 07. August 2018 um 09:54 Uhr -0400 schrieb leam hall:
I was involved a little in a project that was aimed at providing Ruby
with bindings for wxWidgets 3, rwx[1], which were intended to replace
the deceased wxRuby. Sadly, I have no experience with Tcl/Tk and not
much time available to develop such experience. My main OSS project[2]
takes the focus when I work on OSS. My Ruby GUI work today I do with
Ruby's Gtk+ bindings. I fear that it'd be difficult for me to engage in
such a project thus.

Marvin

[1]: <a href="https://github.com/Hanmac/rwx" title="https://github.com/Hanmac/rwx">https://github.com/Hanmac/rwx</a>
[2]: <a href="https://github.com/Secretchronicles/TSC" title="https://github.com/Secretchronicles/TSC">https://github.com/Secretchronicles/TSC</a>