DevHeads.net

nokogiri v1.10.0 released

Nokogiri version v1.10.0 has been released.

This is a maintenance update focused on Ruby version support and updating
vendored CRuby libraries.

Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser. Among Nokogiri's
many features is the ability to search documents via XPath or CSS3
selectors.

* Documentation: <a href="http://nokogiri.org" title="http://nokogiri.org">http://nokogiri.org</a>
* Installation Help: <a href="http://nokogiri.org/tutorials/installing_nokogiri.html" title="http://nokogiri.org/tutorials/installing_nokogiri.html">http://nokogiri.org/tutorials/installing_nokogiri.html</a>
* GitHub: <a href="https://github.com/sparklemotion/nokogiri" title="https://github.com/sparklemotion/nokogiri">https://github.com/sparklemotion/nokogiri</a>

1.10.0 / 2019-01-04Features

- [MRI] Cross-built Windows gems now support Ruby 2.6 [#1842
<https://github.com/sparklemotion/nokogiri/issues/1842>, #1850
<https://github.com/sparklemotion/nokogiri/pull/1850>]

Backwards incompatibilities

This release ends support for:

- Ruby 2.2, for which official support ended on 2018-03-31
<https://www.ruby-lang.org/en/news/2018/06/20/support-of-ruby-2-2-has-ended/>
[#1841 <https://github.com/sparklemotion/nokogiri/issues/1841>]
- JRuby 1.7, for which official support ended on 2017-11-21
<https://github.com/jruby/jruby/issues/4112> [#1741
<https://github.com/sparklemotion/nokogiri/issues/1741>]

Dependencies

- [MRI] libxml2 is updated from 2.9.8 to 2.9.9
- [MRI] libxslt is updated from 1.1.32 to 1.1.33