DevHeads.net

7.5 -> 7.6 problems

To all,

I started the process of updating some of our systems from 7.5 to 7.6.
Most of the servers had no problems, but several of the desktops had
some difficulties. I was required to perform several yum commands to
update as much as possible in the format of yum update a* then b* etc.

Then after I got everything updated that would update in this manner
and after the use of "rpm -Va --nofiles --nodigest" and with the use of
yum update --skip-broken I am getting the following that would not
update :

Packages skipped because of dependency problems:
libvirt-bash-completion-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-client-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-config-network-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-config-nwfilter-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-interface-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-lxc-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-network-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-nodedev-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-nwfilter-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-qemu-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-secret-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-storage-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-storage-core-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-storage-disk-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-storage-gluster-4.5.0-10.el7_6.3.x86_64 from upd
libvirt-daemon-driver-storage-iscsi-4.5.0-10.el7_6.3.x86_64 from upd
libvirt-daemon-driver-storage-logical-4.5.0-10.el7_6.3.x86_64 from upd
libvirt-daemon-driver-storage-mpath-4.5.0-10.el7_6.3.x86_64 from upd
libvirt-daemon-driver-storage-rbd-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-driver-storage-scsi-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-daemon-kvm-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-devel-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-libs-4.5.0-10.el7.x86_64 from base
libvirt-libs-4.5.0-10.el7_6.2.x86_64 from updates
libvirt-libs-4.5.0-10.el7_6.3.x86_64 from updates
libvirt-python-4.5.0-1.el7.x86_64 from base

Is there something I can do to finish this process or is this just
related to a repository problem.

Comments

Re: 7.5 -> 7.6 problems

By Stephen John Smoogen at 12/05/2018 - 13:36

On Wed, 5 Dec 2018 at 10:17, Gregory P. Ennis < ... at pomec dot net> wrote:
Can you post what they are missing? Without that info it is not clear
what the problem is (I seem to have several of them installed on an
upgrade so I am not sure what blocked you).

Re: 7.5 -> 7.6 problems

By Gregory P. Ennis at 12/05/2018 - 13:58

Can you post what they are missing? Without that info it is not clear
what the problem is (I seem to have several of them installed on an
upgrade so I am not sure what blocked you).

Stephen,

Here is the full result. Part of the problem I am having is that this
was a development lab testing machine, and I have some repositories on
it that I normally do not enable.

virtualbox.repo
epel.repo
CentOS-Xen-dependencies.repo
CentOS-Xen.repo

I have turned these off for now, and the list below is after the above
repositories were disabled.

Greg

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirror.dal10.us.leaseweb.net
* centosplus: mirror.dal10.us.leaseweb.net
* extras: mirror.dal10.us.leaseweb.net
* nux-dextop: li.nux.ro
* updates: mirror.dal10.us.leaseweb.net
Resolving Dependencies
--> Running transaction check
---> Package libvirt-bash-completion.x86_64 0:4.1.0-2.xen48.el7 will be
updated
---> Package libvirt-bash-completion.x86_64 0:4.5.0-10.el7_6.3 will be
an update
---> Package libvirt-client.x86_64 0:4.1.0-2.xen48.el7 will be updated
---> Package libvirt-client.x86_64 0:4.5.0-10.el7_6.3 will be an update
---> Package libvirt-daemon.x86_64 0:4.1.0-2.xen48.el7 will be updated
--> Processing Dependency: libvirt-daemon = 4.1.0-2.xen48.el7 for
package: libvirt-daemon-driver-xen-4.1.0-2.xen48.el7.x86_64
--> Processing Dependency: libvirt-daemon = 4.1.0-2.xen48.el7 for
package: libvirt-daemon-driver-libxl-4.1.0-2.xen48.el7.x86_64
---> Package libvirt-daemon.x86_64 0:4.5.0-10.el7_6.3 will be an update
---> Package libvirt-daemon-config-network.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-config-network.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-config-nwfilter.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-config-nwfilter.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-driver-interface.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-driver-interface.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-driver-lxc.x86_64 0:4.1.0-2.xen48.el7 will
be updated
---> Package libvirt-daemon-driver-lxc.x86_64 0:4.5.0-10.el7_6.3 will
be an update
---> Package libvirt-daemon-driver-network.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-driver-network.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-driver-nodedev.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-driver-nodedev.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-driver-nwfilter.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-driver-nwfilter.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-driver-qemu.x86_64 0:4.1.0-2.xen48.el7 will
be updated
---> Package libvirt-daemon-driver-qemu.x86_64 0:4.5.0-10.el7_6.3 will
be an update
---> Package libvirt-daemon-driver-secret.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-driver-secret.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-driver-storage.x86_64 0:4.1.0-2.xen48.el7
will be updated
---> Package libvirt-daemon-driver-storage.x86_64 0:4.5.0-10.el7_6.3
will be an update
---> Package libvirt-daemon-driver-storage-core.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-core.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-driver-storage-disk.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-disk.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-driver-storage-gluster.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-gluster.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-driver-storage-iscsi.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-iscsi.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-driver-storage-logical.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-logical.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-driver-storage-mpath.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-mpath.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-driver-storage-rbd.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-rbd.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-driver-storage-scsi.x86_64 0:4.1.0-
2.xen48.el7 will be updated
---> Package libvirt-daemon-driver-storage-scsi.x86_64 0:4.5.0-
10.el7_6.3 will be an update
---> Package libvirt-daemon-kvm.x86_64 0:4.1.0-2.xen48.el7 will be
updated
---> Package libvirt-daemon-kvm.x86_64 0:4.5.0-10.el7_6.3 will be an
update
---> Package libvirt-devel.x86_64 0:4.1.0-2.xen48.el7 will be updated
---> Package libvirt-devel.x86_64 0:4.5.0-10.el7_6.3 will be an update
---> Package libvirt-libs.x86_64 0:4.1.0-2.xen48.el7 will be updated
--> Processing Dependency: libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
for package: libvirt-daemon-driver-xen-4.1.0-2.xen48.el7.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
for package: libvirt-daemon-driver-libxl-4.1.0-2.xen48.el7.x86_64
---> Package libvirt-libs.x86_64 0:4.5.0-10.el7_6.3 will be an update
---> Package libvirt-python.x86_64 0:3.9.0-1.el7 will be updated
---> Package libvirt-python.x86_64 0:4.5.0-1.el7 will be an update
---> Package postfix.x86_64 2:2.10.1-7.el7 will be updated
---> Package postfix.x86_64 2:2.10.1-7.0.1.el7.centos will be an update
---> Package postfix-perl-scripts.x86_64 2:2.10.1-7.el7 will be updated
---> Package postfix-perl-scripts.x86_64 2:2.10.1-7.0.1.el7.centos will
be an update
---> Package python-perf.x86_64 0:3.10.0-957.1.3.el7 will be updated
---> Package python-perf.x86_64 0:3.10.0-957.1.3.el7.centos.plus will
be an update
--> Finished Dependency Resolution
Error: Package: libvirt-daemon-driver-xen-4.1.0-2.xen48.el7.x86_64
(@centos-virt-xen-48)
Requires: libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
Removing: libvirt-libs-4.1.0-2.xen48.el7.x86_64 (@centos-
virt-xen-48)
libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
Updated By: libvirt-libs-4.5.0-10.el7_6.3.x86_64 (updates)
~libvirt.so.0(LIBVIRT_PRIVATE_4.5.0)(64bit)
Error: Package: libvirt-daemon-driver-libxl-4.1.0-2.xen48.el7.x86_64
(@centos-virt-xen-48)
Requires: libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
Removing: libvirt-libs-4.1.0-2.xen48.el7.x86_64 (@centos-
virt-xen-48)
libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
Updated By: libvirt-libs-4.5.0-10.el7_6.3.x86_64 (updates)
~libvirt.so.0(LIBVIRT_PRIVATE_4.5.0)(64bit)
Error: Package: libvirt-daemon-driver-xen-4.1.0-2.xen48.el7.x86_64
(@centos-virt-xen-48)
Requires: libvirt-daemon = 4.1.0-2.xen48.el7
Removing: libvirt-daemon-4.1.0-2.xen48.el7.x86_64 (@centos-
virt-xen-48)
libvirt-daemon = 4.1.0-2.xen48.el7
Updated By: libvirt-daemon-4.5.0-10.el7_6.3.x86_64 (updates)
libvirt-daemon = 4.5.0-10.el7_6.3
Available: libvirt-daemon-4.5.0-10.el7.x86_64 (base)
libvirt-daemon = 4.5.0-10.el7
Available: libvirt-daemon-4.5.0-10.el7_6.2.x86_64 (updates)
libvirt-daemon = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-driver-libxl-4.1.0-2.xen48.el7.x86_64
(@centos-virt-xen-48)
Requires: libvirt-daemon = 4.1.0-2.xen48.el7
Removing: libvirt-daemon-4.1.0-2.xen48.el7.x86_64 (@centos-
virt-xen-48)
libvirt-daemon = 4.1.0-2.xen48.el7
Updated By: libvirt-daemon-4.5.0-10.el7_6.3.x86_64 (updates)
libvirt-daemon = 4.5.0-10.el7_6.3
Available: libvirt-daemon-4.5.0-10.el7.x86_64 (base)
libvirt-daemon = 4.5.0-10.el7
Available: libvirt-daemon-4.5.0-10.el7_6.2.x86_64 (updates)
libvirt-daemon = 4.5.0-10.el7_6.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: 7.5 -> 7.6 problems

By Stephen John Smoogen at 12/05/2018 - 14:44

On Wed, 5 Dec 2018 at 13:00, Gregory P. Ennis < ... at pomec dot net> wrote:
So the problem is because of those missing repositories. You have
things which are from them which either need a rebuild or removal. The
core problem looks to be:

Error: Package: libvirt-daemon-driver-xen-4.1.0-2.xen48.el7.x86_64
(@centos-virt-xen-48)

That is what stops the rest from updating.