DevHeads.net

Centos installer not detecting hard drive

Hi,

I have a new labtop and i want to install CentOS 7.6 on it.
My labtop has two hard drives :
- A 256Go SSD
- A standard 1 To hard drive
None of the two hard drives are detected by the Centos installer
consequently i can't proceed with the installation.

If i try with a Fedora server distro, then the standard hard drive is
detected, the SSD one is still not detected.

I do prefer to install Centos as is is the closed Linux version from RHEL,
so what can i do to solve the issue ?

Regards,

Faird

Comments

Centos installer not detecting hard drive

By Leroy Tennison at 03/12/2019 - 17:34

This may be a remote possibility because it happened to me long ago but, were these disks used for something else previously? I had a situation where something "special" a program did on the disk caused Linux to not recognize the drive. In that case I was able to use the manufacturer's "restore the drive to its original condition" program to remove the problem. I've also seen other situations where using dd to write zeros to the first 10K or so of the drive got around problems (if the drive is even recognized...). If this is your situation and the manufacturer doesn't offer a "restore..." program you might try other distros' "leading edge" Live CDs to hopefully detect the drive and do something with it then install CentOS.

Leroy Tennison
Network Information/Cyber Security Specialist
E: <a href="mailto: ... at datavoiceint dot com"> ... at datavoiceint dot com</a>
2220 Bush Dr
McKinney, Texas
75070
<a href="http://www.datavoiceint.com" title="www.datavoiceint.com">www.datavoiceint.com</a>
This message has been sent on behalf
of a company that is part of the Harris Operating Group of
Constellation Software Inc. These companies are listed
here
.
If you prefer not to be contacted by Harris
Operating Group
please notify us
.
This message is intended exclusively for the
individual or entity to which it is addressed. This communication
may contain information that is proprietary, privileged or
confidential or otherwise legally exempt from disclosure. If you are
not the named addressee, you are not authorized to read, print,
retain, copy or disseminate this message or any part of it. If you
have received this message in error, please notify the sender
immediately by e-mail and delete all copies of the
message.

Hi,

I have a new labtop and i want to install CentOS 7.6 on it.
My labtop has two hard drives :
- A 256Go SSD
- A standard 1 To hard drive
None of the two hard drives are detected by the Centos installer
consequently i can't proceed with the installation.

If i try with a Fedora server distro, then the standard hard drive is
detected, the SSD one is still not detected.

I do prefer to install Centos as is is the closed Linux version from RHEL,
so what can i do to solve the issue ?

Regards,

Faird