DevHeads.net

Latest kernel crashes X and gnome

Hi,

Anyone else having problems with kernel 3.10.0-957.5.1.el7.x86_64?

After my yum update today a reboot hung. A quick look at the Xorg.0.log
shows two of my graphics cards appear to be working okay but the third
one (I have two nvidia cards with a monitor each and then use the
inbuilt intel one for the third monitor) gives:

<cut>

[    14.246] (II) Loading sub module "fb"
[    14.246] (II) LoadModule: "fb"
[    14.247] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    14.247] (II) Module fb: vendor="X.Org Foundation"
[    14.247]     compiled for 1.20.1, module version = 1.0.0
[    14.247]     ABI class: X.Org ANSI C Emulation, version 0.4
[    14.247] (II) UnloadModule: "vesa"
[    14.247] (II) Unloading vesa
[    14.247] (EE) modeset(G0): drmSetMaster failed: Invalid argument
[    14.247] (EE)
Fatal server error:
[    14.247] (EE) AddScreen/ScreenInit failed for gpu driver 0 -1
[    14.247] (EE)
[    14.247] (EE)
Please consult the The X.Org Foundation support
     at <a href="http://wiki.x.org" title="http://wiki.x.org">http://wiki.x.org</a>
 for help.
[    14.247] (EE) Please also check the log file at
"/var/log/Xorg.0.log" for additional information.
[    14.247] (EE)
[    14.257] (EE) Server terminated with error (1). Closing log file.
</end>

So a reboot to kernel 3.10.0-957.1.3.el7.x86_64 and all is well.

I note that the update also updated :

    Updated xorg-x11-drv-ati-18.0.1-1.el7.x86_64 @base
    Update 18.1.0-1.el7_6.x86_64                        @updates
    Updated xorg-x11-server-Xorg-1.20.1-5.1.el7.x86_64 @updates
    Update 1.20.1-5.2.el7_6.x86_64                  @updates
    Updated xorg-x11-server-common-1.20.1-5.1.el7.x86_64 @updates
    Update 1.20.1-5.2.el7_6.x86_64                @updates

Before I start trying to solve this by myself, just wanted to see if
anyone else has had issues.

TIA

Rob