DevHeads.net

MATE 1.20 test build for CentOS 7 available

Hi everyone,

There's been discussions in the past about updating MATE RPMs in EPEL-7:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1436260" title="https://bugzilla.redhat.com/show_bug.cgi?id=1436260">https://bugzilla.redhat.com/show_bug.cgi?id=1436260</a>
<a href="https://lists.centos.org/pipermail/centos/2019-August/173154.html" title="https://lists.centos.org/pipermail/centos/2019-August/173154.html">https://lists.centos.org/pipermail/centos/2019-August/173154.html</a>
(and lots of others...)

As a proof-of-concept, I've written some scripts that clone specific
commits from the Fedora master branches, and then runs a tool to
re-apply RPM scriptlets that are required by EL7 but removed from the
Fedora .spec files.

The scripts are available at:
<a href="https://github.com/gebailey/mate-rpms/tree/master/1.20/el7" title="https://github.com/gebailey/mate-rpms/tree/master/1.20/el7">https://github.com/gebailey/mate-rpms/tree/master/1.20/el7</a>

There's also instructions there if you want to try upgrading to MATE
1.20 w/o rebuilding them yourself.

If these packages work for others, perhaps we can revisit the idea of
updating the epel7 branches of the Fedora git repos and submitting an
official update.

There's nothing here (yet) about building MATE 1.22 (which might require
a newer gcc for EL7), or building anything on CentOS 8, but thought the
CentOS 7 users might find this helpful.

-Greg

Comments

Re: MATE 1.20 test build for CentOS 7 available

By isdtor at 10/07/2019 - 12:11

Greg Bailey writes:
I've had 1.20 running on CentOS7 for a while, based on my own updates to the 1.16 rpms from EPEL.

Not so lucky for mate 1.22. Updating my own rpms to 1.22 as well as a rebuild of the Fedora 30 rpms do not create functional rpms. Some components work, some don't.