DevHeads.net

odd messages at boot time

I'm getting these messages during boot:

error: failure reading sector 0xfc from 'hd4'
error: failure reading sector 0xe0 from 'hd4'
error: failure reading sector 0x0 from 'hd4'
error: failure reading sector 0xfc from 'hd5'
error: failure reading sector 0xe0 from 'hd5'
error: failure reading sector 0x0 from 'hd5'

they pop up soon after the Grub menu with a message to press ENTER to
continue, and it times out in a few seconds if I don't press ENTER. These
messages have been appearing for a long time, at least a couple of years
and I've been too lethargic to investigate til now.

I see no bad side-effects at runtime.

I just did badblocks (read-only) on both sda and sdb (RAID-1 pair)
which found no errors.

I see nothing obviously related in dmesg, or /var/log/messages.

I also have an external box (Venus DS3R Pro-2) with two drives, also
RAID-1, that I use for backups. It is seen (after boot) as /dev/sdc.

I'd have to pull the drives out of it and connect them to the SATA bus
to run badblocks on them, as badblocks won't run on /dev/sdc.

the nightly backups on to this box appear to run without issue.

Anybody got any ideas on what this might be about?

thanks in advance!

Fred

Comments

Re: odd messages at boot time

By Fred Roller at 02/18/2019 - 15:31

On Mon, Feb 18, 2019, 11:24 AM Fred Smith < ... at fcshome dot stoneham.ma.us
wrote:

Normally, as you have deduced, it seems to be just bad blocks. But given
that the addresses are identical on both drives I wonder if this is your
mirror? If so could it just be corrupted data?

-- Fred