DevHeads.net

Autoconf help: missing X11 dependency

Hello,

my package "workrave" won't build with Rawhide, configure script complains:

checking for X... no
configure: error: X11 required on Unix platform

However it keeps complaining even when I add BuildRequires: libX11-devel. I don't understang which particular (sub)library it needs, generated configure is a bit unreadable (really!) and even debugging it with +x is not really helpful as it is a storm of tests. Any idea how to debug this? What X11 library am I missing? Any recent changes in the X11 libraries? This is a regression, it was working fine.

Thanks.

Comments

Re: Autoconf help: missing X11 dependency

By Daniel P. Berrange at 04/11/2019 - 10:18

On Thu, Apr 11, 2019 at 02:11:14PM -0000, Lukas Zapletal wrote:
configure generates a config.log file that often has more information
about the specific check that failed. eg a program that failed to
compile. Just beware that the useful info is usually *not* at the
end of config.log. Usually have to scan up past a huge dump of
variables to find the interesting failure message.

Regards,
Daniel

Re: Autoconf help: missing X11 dependency

By Lukas Zapletal at 04/11/2019 - 10:47

Thanks all, this config.log is really useful. Had no idea.

Now fighting with python2 vs python3 but that's another story. TY

Re: Autoconf help: missing X11 dependency

By Tomasz Torcz at 04/11/2019 - 10:18

On Thu, Apr 11, 2019 at 02:11:14PM -0000, Lukas Zapletal wrote:
Looking at
<a href="https://sourceforge.net/p/workrave/code/HEAD/tree/workrave/branches/branch_v1_9/configure.ac" title="https://sourceforge.net/p/workrave/code/HEAD/tree/workrave/branches/branch_v1_9/configure.ac">https://sourceforge.net/p/workrave/code/HEAD/tree/workrave/branches/bran...</a>
the check is fo Xmu header:
AC_CHECK_HEADER("X11/Xmu/Xmu.h",,)

which comes from libXmu-devel package. Although the configure.ac I've
found is from decade ago, something may have changed during the years.

Re: Autoconf help: missing X11 dependency

By Jerry James at 04/11/2019 - 10:16

On Thu, Apr 11, 2019 at 8:11 AM Lukas Zapletal < ... at fedoraproject dot org> wrote:

There should be a file named config.log in the directory where you ran
configure. Look in there for the string "checking for X". Right
after that, you should see a report about the actual check, and how it
failed.

Re: Autoconf help: missing X11 dependency

By Lukas Zapletal at 04/11/2019 - 10:28

This was helpful, thank. It's missing c++ compiler when it tries to compile the "test program". I guess I need to add that.

Re: Autoconf help: missing X11 dependency

By Lukas Zapletal at 04/11/2019 - 10:14

Just in case there is somebody with autotools-X-ray glasses, here is the autoconf bit:

<a href="https://paste.fedoraproject.org/paste/6KSdRXVFSSVb1PfENZf3JA" title="https://paste.fedoraproject.org/paste/6KSdRXVFSSVb1PfENZf3JA">https://paste.fedoraproject.org/paste/6KSdRXVFSSVb1PfENZf3JA</a>

And the current build requires:

# adding this does not help there must be more
BuildRequires: libX11-devel

BuildRequires: libXtst-devel
BuildRequires: libXScrnSaver-devel
BuildRequires: pkgconfig(ice)
BuildRequires: pkgconfig(sm)
BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
BuildRequires: pkgconfig(gio-2.0) >= 2.26.0
BuildRequires: pkgconfig(gtk+-3.0) >= 3.0.0
BuildRequires: pkgconfig(sigc++-2.0) >= 2.2.4.2
BuildRequires: pkgconfig(glibmm-2.4) >= 2.28.0
BuildRequires: pkgconfig(gtkmm-3.0) >= 3.0.0
BuildRequires: gobject-introspection-devel >= 0.6.7
BuildRequires: pkgconfig(indicator3-0.4) >= 0.3.19
BuildRequires: pkgconfig(dbusmenu-glib-0.4) >= 0.1.1
BuildRequires: pkgconfig(dbusmenu-gtk3-0.4) >= 0.3.95
BuildRequires: python-cheetah
BuildRequires: pkgconfig(gstreamer-1.0)
BuildRequires: pkgconfig(libpulse) >= 0.9.15
BuildRequires: pkgconfig(libpulse-mainloop-glib) >= 0.9.15
BuildRequires: gettext
BuildRequires: intltool
BuildRequires: autoconf, automake, libtool, autoconf-archive
BuildRequires: desktop-file-utils
%if 0%{?gnome_flashback}
BuildRequires: pkgconfig(libpanel-applet)
%endif
%if 0%{?xfce} || 0%{?mate}
BuildRequires: pkgconfig(gtk+-2.0) >= 2.6.0
%endif
%if 0%{?xfce}
BuildRequires: pkgconfig(libxfce4panel-1.0) >= 4.4
%endif
%if 0%{?mate}
BuildRequires: pkgconfig(libmatepanelapplet-4.0)
%endif

Thanks for help.