DevHeads.net

can't install rpm file due failed dependencies

Hi,

If I want to install glmixer compiled with [1] I get the following dependencies error:

[root@fc29 tmp]# rpm -ivh /home/martin/rpmbuild/RPMS/x86_64/glmixer-1.7.1835-1.fc29.x86_64.rpm
error: Failed dependencies:
libFreeFrameGL.so()(64bit) is needed by glmixer-1.7.1835-1.fc29.x86_64
libOSCPack.so()(64bit) is needed by glmixer-1.7.1835-1.fc29.x86_64
libQtColorPicker.so()(64bit) is needed by glmixer-1.7.1835-1.fc29.x86_64
libQtProperty.so()(64bit) is needed by glmixer-1.7.1835-1.fc29.x86_64

[1] <a href="https://martinkg.fedorapeople.org/Packages/glmixer/glmixer.spec" title="https://martinkg.fedorapeople.org/Packages/glmixer/glmixer.spec">https://martinkg.fedorapeople.org/Packages/glmixer/glmixer.spec</a>
[3] <a href="https://martinkg.fedorapeople.org/Packages/glmixer/GLMixer-1.7.1835-Source.tar.gz" title="https://martinkg.fedorapeople.org/Packages/glmixer/GLMixer-1.7.1835-Source.tar.gz">https://martinkg.fedorapeople.org/Packages/glmixer/GLMixer-1.7.1835-Sour...</a>
[4] <a href="https://martinkg.fedorapeople.org/Packages/glmixer/glmixer-glew-sys.patch" title="https://martinkg.fedorapeople.org/Packages/glmixer/glmixer-glew-sys.patch">https://martinkg.fedorapeople.org/Packages/glmixer/glmixer-glew-sys.patch</a>

Is there any solution ?

Comments

Re: can't install rpm file due failed dependencies

By Samuel Sieb at 12/08/2018 - 18:50

On 12/8/18 6:49 AM, Martin Gansser wrote:
You should be using dnf to install it, otherwise you have to do the
dependency handling yourself.

Re: can't install rpm file due failed dependencies

By Rex Dieter at 12/08/2018 - 11:31

2 things.

1. %cmake macro may be getting in the way here,
$ rpm --eval %cmake | grep SHARED
-DBUILD_SHARED_LIBS:BOOL=ON

in that those may be bundled libraried intended to build/link statically.

2. unrelated to this particular problem, but I see in the .spec:
BuildRequires: pkgconfig(Qt)
BuildRequires: pkgconfig(QtWebKit)

those are qt4-based dependencies, mixed with

BuildRequires: qt5-linguist

is that intentional? Usually applications use qt4 *or* qt5, but not both, I
recommend you double-check those.

-- Rex

Re: can't install rpm file due failed dependencies

By Martin Gansser at 12/08/2018 - 12:11

ok, I have now with glmixer
-DBUILD_SHARED_LIBS: BOOL = OFF
compiled, then I can also install the rpm package.

my fault, already corrected.

Many thanks Martin

Re: can't install rpm file due failed dependencies

By Antonio Trande at 12/08/2018 - 11:15

Look all libraries bundled inside glmixer code:
<a href="https://sourceforge.net/p/glmixer/Source/HEAD/tree/trunk/" title="https://sourceforge.net/p/glmixer/Source/HEAD/tree/trunk/">https://sourceforge.net/p/glmixer/Source/HEAD/tree/trunk/</a>

On 08/12/18 15:49, Martin Gansser wrote:

Re: can't install rpm file due failed dependencies

By Martin Gansser at 12/08/2018 - 11:37

[martin@fc29 x86_64-redhat-linux-gnu]$ ll lib*/*.so libFreeFrameGL/*/*.so
-rwxr-xr-x. 1 martin martin 116072 8. Dez 15:32 libFreeFrameGL/FFGL-SDK-1.6/libFreeFrameGL.so
-rwxr-xr-x. 1 martin martin 289360 8. Dez 15:32 libOSCPack/libOSCPack.so
-rwxr-xr-x. 1 martin martin 763936 8. Dez 15:32 libQtColorPicker/libQtColorPicker.so
-rwxr-xr-x. 1 martin martin 11525200 8. Dez 15:32 libQtProperty/libQtProperty.so

Re: can't install rpm file due failed dependencies

By Antonio Trande at 12/08/2018 - 11:50

Usually are compiled and installed inside a private library path.
A build log could be useful.

On 08/12/18 16:37, Martin Gansser wrote: