DevHeads.net

couldn't compile vdr-epg-daemon-1.1.147 on rawhide - python: Command not found

Hi,

the package vdr-epg-daemon-1.1.147 doesn't compile on rawhide see build.log [1]

In the file Make.config the python 3 conditions already included.

I'm not sure if python 3.8 is the problem.
How can i solve this issue ?

[1] <a href="https://kojipkgs.fedoraproject.org//work/tasks/7397/39387397/build.log" title="https://kojipkgs.fedoraproject.org//work/tasks/7397/39387397/build.log">https://kojipkgs.fedoraproject.org//work/tasks/7397/39387397/build.log</a>

Regards
Martin

Comments

Re: couldn't compile vdr-epg-daemon-1.1.147 on rawhide - python:

By Artur Iwicki at 11/29/2019 - 06:44

You'll need to either edit the Makefile so it explicitly calls python3, or add a BuildRequires: for "python-unversioned-command".