DevHeads.net

dcmtk upgrade on rawhide

Hi all.

I prepared a dcmtk-3.6.4 rpm for upgrading this package on f30/rawhide.
Its dependencies are:

$ dnf repoquery --release rawhide --enablerepo=*-source
--disablerepo=rpmfusion* --disablerepo=*modular* --whatrequires dcmtk-devel
Last metadata expiration check: 3:27:58 ago on sab 02 mar 2019 12:40:33 CET.
OpenImageIO-0:2.0.5-1.fc30.src
aeskulap-0:0.2.2-0.37.beta2.fc30.src
ctk-0:0.1-0.10.20171224git71799c2.fc29.src
gtatool-0:2.2.0-11.fc28.src
orthanc-0:1.5.4-1.fc30.src
vxl-0:1.17.0-29.fc30.src

dcmtk and related deps have been rebuilt on a dedicated Copr space:
<a href="https://copr.fedorainfracloud.org/coprs/sagitter/ForTesting/builds/" title="https://copr.fedorainfracloud.org/coprs/sagitter/ForTesting/builds/">https://copr.fedorainfracloud.org/coprs/sagitter/ForTesting/builds/</a>

OpenImageIO is OK

aeskulap-0:0.2.2 does not built for a known bug
(<a href="https://github.com/jenslody/aeskulap/issues/14" title="https://github.com/jenslody/aeskulap/issues/14">https://github.com/jenslody/aeskulap/issues/14</a>)

ctk updated si OK

gtatool-2.2.2 compile but some tests are failing (upstream informed)

orthanc is OK

vxl is OK

Comments

Re: dcmtk upgrade on rawhide

By Peter Lemenkov at 03/02/2019 - 14:33

No objections here - go on with it.

сб, 2 мар. 2019 г., 20:31 Antonio Trande <anto. ... at gmail dot com>: