DevHeads.net

EPEL 7 is broken for python3 related builds

My build (qpid-proton package) cannot find pythin36-devel package, I also
tried python3-devel (also not found). It appears python36 was removed from
EPEL 7 recently.
Is this still relevant:
<a href="https://fedoraproject.org/wiki/User:Bkabrda/EPEL7_Python3" title="https://fedoraproject.org/wiki/User:Bkabrda/EPEL7_Python3">https://fedoraproject.org/wiki/User:Bkabrda/EPEL7_Python3</a>?
Is this a temporary issue with getting python3 into Fedora/EPEL 7 or change
in how we package python RPMs?

Comments

Re: EPEL 7 is broken for python3 related builds

By =?ISO-8859-1?Q?... at 10/08/2019 - 13:41

Now python 3.6 is shipped by RHEL 7.7 or Centos 7.7, the rules
of [1] still valid so you should (or must ) use [2]
[2]BuildRequires: python%{python3_pkgversion}-devel
[1] <a href="https://fedoraproject.org/wiki/User:Bkabrda/EPEL7_Python3" title="https://fedoraproject.org/wiki/User:Bkabrda/EPEL7_Python3">https://fedoraproject.org/wiki/User:Bkabrda/EPEL7_Python3</a>
On Tue, 2019-10-08 at 12:48 -0400, Irina Boverman wrote: