DevHeads.net

F19 locale issue?

Hi,

I don't have any idea how this happened:

$ locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC=\'\'
LC_TIME=\'\'
LC_COLLATE="en_US.utf8"
LC_MONETARY=\'\'
LC_MESSAGES="en_US.utf8"
LC_PAPER=\'\'
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT=\'\'
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

I have LANG=en_US.UTF-8 on kernel cmdline and in /etc/locale.conf.

Any clues?

Best regards,
Jan Dvorak

Comments

Re: F19 locale issue?

By Michael Schwendt at 06/16/2013 - 14:50

Are all user accounts affected?
Are also freshly created user accounts affected?
Which run-level is affected?
Is it reproducible when logging in on a virtual console?
Which desktop environment do you use?

Re: F19 locale issue?

By Michael Schwendt at 06/16/2013 - 14:52

Mails should move to "test" list, btw, which is the list about F19.
"devel" is for more general development topics.

Re: F19 locale issue?

By Michael Scherer at 06/16/2013 - 10:17

Le dimanche 16 juin 2013 à 13:36 +0200, Jan Dvořák a écrit :
Yep :
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=974778" title="https://bugzilla.redhat.com/show_bug.cgi?id=974778">https://bugzilla.redhat.com/show_bug.cgi?id=974778</a>

In short, fix /usr/libexec/gnome-settings-daemon-localeexec to remove
"'", not ','.

Re: F19 locale issue?

By Kalev Lember at 06/16/2013 - 15:25

2013-06-16 17:17, Michael Scherer skrev:
Can you give a try to gnome-settings-daemon-3.8.3-3.fc19 ? This should
fix up the issue with the extra quotes.

<a href="https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.8.3-3.fc19" title="https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.8.3-3.fc19">https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.8.3-3.fc19</a>

Re: F19 locale issue?

By Jan =?UTF-8?B?R... at 06/17/2013 - 16:11

On Sun, 16 Jun 2013 22:25:50 +0200 Kalev Lember < ... at gmail dot com> wrote:
Solved. Thanks a lot!

Re: F19 locale issue?

By =?ISO-8859-1?Q?... at 06/16/2013 - 06:47

Am Sonntag, den 16.06.2013, 13:36 +0200 schrieb Jan Dvořák:
Hi Jan!

What's the output of `grep -R -e "\.utf8" /etc`?

Cheers,
Björn

Re: F19 locale issue?

By Jan =?UTF-8?B?R... at 06/16/2013 - 09:25

On Sun, 16 Jun 2013 13:47:36 +0200 Björn Esser <bjoern. ... at gmail dot com> wrote:
Nothing in particular, profile.d scripts that check $LANG?

Best regards,
Jan Dvorak

Re: F19 locale issue?

By =?ISO-8859-1?Q?... at 06/16/2013 - 10:02

Am Sonntag, den 16.06.2013, 16:25 +0200 schrieb Jan Dvořák:
you might want to check:

/etc/profile.d/lang.sh
/etc/profile.d/lang.csh