DevHeads.net

FreeCAD required updates (PySide2 & Coin4)

I am in the midst of updating the freecad package in two major ways:

Qt4 -> Qt5 (via PySide -> PySide2, which also facilitates moving from
Python 2 to 3)
and
Coin3 -> Coin4 (Which requires several other packages move to Coin4)

I have been working with the Coin2/3, SoQt, & SIMVoleon maintainer Ralf but
I stopped getting responses. The last response by email being September
13th.

I have even submitted pull requests so my requested changes can be easily
evaluated.

<a href="https://src.fedoraproject.org/rpms/SoQt/pull-request/2" title="https://src.fedoraproject.org/rpms/SoQt/pull-request/2">https://src.fedoraproject.org/rpms/SoQt/pull-request/2</a>
<a href="https://src.fedoraproject.org/rpms/OpenSceneGraph/pull-request/2" title="https://src.fedoraproject.org/rpms/OpenSceneGraph/pull-request/2">https://src.fedoraproject.org/rpms/OpenSceneGraph/pull-request/2</a>
<a href="https://src.fedoraproject.org/rpms/SIMVoleon/pull-request/1" title="https://src.fedoraproject.org/rpms/SIMVoleon/pull-request/1">https://src.fedoraproject.org/rpms/SIMVoleon/pull-request/1</a>
<https://src.fedoraproject.org/rpms/SIMVoleon/pull-request/1#request_diff>

Updating to Coin4 is required to take care of a longstanding bug[1]

So I'm trying to be nice but I don't think it's doing any good to wait for
a reply that may never come meanwhile the users could easily get the idea
that I (or Fedora) don't care about fixing bugs.

Am I just being impatient?

Thanks,
Richard

Comments

Re: FreeCAD required updates (PySide2 & Coin4)

By Scott Talbert at 10/07/2019 - 16:34

I also submitted a pull request to OpenSceneGraph that never got a
response from him. I had to request a provenpackager merge it. So,
you're probably not being impatient. :)

Scott