DevHeads.net

hdf5, netcdf, and vtk updates coming to Rawhide today

I'm updating:

hdf5 to 1.10.5
netcdf to 4.6.3
vtk to 8.2

in Rawhide starting today. All are soname updates so I'll be rebuilding
all dependent packages as well. Some of these packages (notably vtk)
take a long time to build so there may be broken deps for a couple of days.

- Orion

Comments

Re: hdf5, netcdf, and vtk updates coming to Rawhide today

By Richard Shaw at 03/18/2019 - 11:28

I'm assuming that's the cause of my failed FreeCAD build...

DEBUG util.py:554: BUILDSTDERR: - conflicting requests
DEBUG util.py:554: BUILDSTDERR: - nothing provides
libhdf5.so.10()(64bit) needed by vtk-8.1.1-3.fc30.x86_64
DEBUG util.py:554: BUILDSTDERR: - nothing provides
libnetcdf.so.11()(64bit) needed by vtk-8.1.1-3.fc30.x86_64
DEBUG util.py:554: BUILDSTDERR: - nothing provides hdf5 = 1.8.20 needed
by vtk-8.1.1-3.fc30.x86_64

Let me know when those are taken care of an I'll kick off a new build.

Thanks,
Richard

Re: hdf5, netcdf, and vtk updates coming to Rawhide today

By Orion Poplawski at 03/18/2019 - 15:46

On 3/18/19 9:28 AM, Richard Shaw wrote:
Correct. The vtk build just completed and is the buildroot, so you should be
good to go now.