DevHeads.net

HEADS UP: yaml-cpp 0.6.0 coming to rawhide

I may wait a few days for all the build problems with gcc 8 and there are
still several packages that haven't been properly rebuilt against boost
1.66, but I plan to build yaml-cpp 0.6.0 and rebuild its dependencies in
the near future:

$ repoquery --repoid=rawhide --source --whatrequires
"libyaml-cpp.so.0.5()(64bit)"
Last metadata expiration check: 0:01:30 ago on Sun 11 Feb 2018 01:21:13 PM
CST.
OpenColorIO-1.1.0-1.fc28.src.rpm
calamares-3.1.8-6.fc28.src.rpm
facter-3.9.3-1.fc28.src.rpm
fawkes-1.0.1-13.fc28.src.rpm
librime-1.2-19.fc28.src.rpm
mongodb-3.6.2-1.fc28.src.rpm
pdns-4.1.0-2.fc28.src.rpm

Thanks,
Richard
FAS: hobbes1069

Comments

Re: HEADS UP: yaml-cpp 0.6.0 coming to rawhide

By Richard Shaw at 02/14/2018 - 17:56

Looks like arch dependent failures for ppc64le and s390x. I don't know if
they are yaml-cpp related or not.

<a href="http://koji.fedoraproject.org/koji/buildinfo?buildID=1044717" title="http://koji.fedoraproject.org/koji/buildinfo?buildID=1044717">http://koji.fedoraproject.org/koji/buildinfo?buildID=1044717</a>

Thanks,
Richard

Re: HEADS UP: yaml-cpp 0.6.0 coming to rawhide

By Richard Shaw at 02/14/2018 - 12:52

Circular dependency problem with OpenImageIO and yaml-cpp, my package so
I'm fixing.

DEBUG util.py:439: Error:
DEBUG util.py:439: Problem: package
qt5-qtwebengine-devel-5.10.0-3.fc28.x86_64 requires
libQt5WebEngineCore.so.5()(64bit), but none of the providers can be
installed
DEBUG util.py:439: - conflicting requests
DEBUG util.py:439: - nothing provides
libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit) needed by
qt5-qtwebengine-5.10.0-3.fc28.x86_64

DEBUG util.py:439: Error:
DEBUG util.py:439: Problem: package cpp-hocon-devel-0.1.6-3.fc28.x86_64
requires libcpp-hocon.so.0.1.6()(64bit), but none of the providers can be
installed
DEBUG util.py:439: - conflicting requests
DEBUG util.py:439: - nothing provides libboost_system.so.1.64.0()(64bit)
needed by cpp-hocon-0.1.6-3.fc28.x86_64

fawkes-1.0.1-13.fc28.src.rpm
DEBUG util.py:439: Error:
DEBUG util.py:439: Problem 1: package player-devel-3.1.0-4.fc27.x86_64
requires libplayercommon.so.3.1()(64bit), but none of the providers can be
installed
DEBUG util.py:439: - conflicting requests
DEBUG util.py:439: - nothing provides libboost_system.so.1.64.0()(64bit)
needed by player-3.1.0-4.fc27.x86_64
DEBUG util.py:439: Problem 2: package pcl-devel-1.8.0-13.fc28.x86_64
requires libpcl_common.so.1.8()(64bit), but none of the providers can be
installed
DEBUG util.py:439: - conflicting requests
DEBUG util.py:439: - nothing provides libboost_system.so.1.64.0()(64bit)
needed by pcl-1.8.0-13.fc28.x86_64
DEBUG util.py:439: Problem 3: package
gazebo-ode-devel-8.1.1-4.fc28.x86_64 requires libgazebo_ode.so.8()(64bit),
but none of the providers can be installed
DEBUG util.py:439: - conflicting requests
DEBUG util.py:439: - nothing provides libboost_system.so.1.64.0()(64bit)
needed by gazebo-ode-8.1.1-4.fc28.x86_64
DEBUG util.py:439: Problem 4: package gazebo-devel-8.1.1-4.fc28.x86_64
requires libgazebo_ode.so.8()(64bit), but none of the providers can be
installed
DEBUG util.py:439: - conflicting requests
DEBUG util.py:439: - nothing provides libboost_system.so.1.64.0()(64bit)
needed by gazebo-ode-8.1.1-4.fc28.x86_64
DEBUG util.py:439: Problem 5: package gazebo-media-8.1.1-4.fc28.noarch
requires gazebo = 8.1.1-4.fc28, but none of the providers can be installed
DEBUG util.py:439: - conflicting requests
DEBUG util.py:439: - nothing provides libboost_system.so.1.64.0()(64bit)
needed by gazebo-8.1.1-4.fc28.x86_64

librime-1.2-19.fc28.src.rpm
Done.

Takes forever to build. Will follow up.

Never seen this one before:
/bin/sh ../../libtool --tag=CXX --mode=link g++ -fPIE -DPIE
-U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 --param ssp-buffer-size=4
-fstack-protector -O2 -g -pipe -Wall -Werror=format-security
-Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions
-fstack-protector-strong -grecord-gcc-switches
-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1
-specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic
-fasynchronous-unwind-tables -fstack-clash-protection -mcet -fcf-protection
-module -avoid-version -Wl,-z -Wl,relro -Wl,-z -Wl,now -Wl,-z,relro
-specs=/usr/lib/rpm/redhat/redhat-hardened-ld -o libgeoipbackend.la -rpath
/usr/lib64/pdns geoipbackend.lo -Llib64 -lyaml-cpp -lGeoIP
make[3]: Leaving directory
'/builddir/build/BUILD/pdns-4.1.0/modules/geoipbackend'
../../libtool: line 6000: cd: lib64: No such file or directory
libtool: link: cannot determine absolute directory name of `lib64'

Thanks,
Richard