DevHeads.net

hwloc update with so-bump and mpich rebuild

Hi,

I made a minor mess in the mpich world and instead of upgrading to
3.3.1 from 3.2.1., I built 3.1.1. I was a bit surprised when I got
a bug [1] that mpich in Fedora is from 2014 :(

I'd like to update to 3.3.1, but that needs newer hwloc which has an
so-bump.

There's a number of users of hwloc:

mpich
pmix
openmpi
pocl
slurm
hpx
legion
aircrack-ng
gromacs

They all build fine with hwloc 2.0.4, except from legion.
Legion is incompatible.
I came up with a patch to partially disable hwloc use [2],
and after reporting the issue upstream, I got the feedback
that this is the correct approach [3].

[1] <a href="https://bugzilla.redhat.com/show_bug.cgi?id=1745252" title="https://bugzilla.redhat.com/show_bug.cgi?id=1745252">https://bugzilla.redhat.com/show_bug.cgi?id=1745252</a>
[2] <a href="https://src.fedoraproject.org/rpms/legion/pull-request/1" title="https://src.fedoraproject.org/rpms/legion/pull-request/1">https://src.fedoraproject.org/rpms/legion/pull-request/1</a>
[3] <a href="https://github.com/StanfordLegion/legion/issues/575" title="https://github.com/StanfordLegion/legion/issues/575">https://github.com/StanfordLegion/legion/issues/575</a>

As a stop-gap measure, I rebuilt mpich-3.2.1 again today in
rawhide and F31. I'd like to do the update though.

I plan to build hwloc-2.0 and the packages listed above, incl. legion
with the patch on Wednesday.

Zbyszek