DevHeads.net

librpm.so.7, deltarpm-3.6.{21,22} and building ceph on rawhide

After a successful scratch build[1] on fc27/i686 of ceph-2.1.2-2 to test
a fix for a 32-bit issue I immediately fired off a full fedpkg build,
which failed thusly [2]:

...
DEBUG util.py:439: Error: nothing provides librpm.so.7()(64bit) needed
by deltarpm-3.6-22.fc27.x86_64
DEBUG util.py:439: (try to add '--allowerasing' to command line to
replace conflicting packages)
...

the scratch build had rpm-4.13.0.1-41.fc27 and deltarpm-3.6-21.fc27

The fedpkg builds got rpm-4.13.90-0.git14002.1.fc27 and
deltarpm-3.6-22.fc27 (x86_64 at least, I didn't look at the others)

Did I just catch things in an temporarily inconsistent state? I only
noticed the warning that rpm-4.14 is coming soon.

Thanks,

Comments

Re: librpm.so.7, deltarpm-3.6.{21,22} and building ceph on rawhi

By Kevin Fenzi at 08/10/2017 - 17:09

On 08/10/2017 02:15 PM, Kaleb S. KEITHLEY wrote:
Yep. :)

The affected rebuilt packages against the new rpm are being signed now.

kevin