DevHeads.net

libupnp ABI change notice

Hi,

I plan to update libupnp to 1.8.3 which comes with an ABI bump.
The libthreadutil library is also dropped in this new release.

I will rebuild the dependent applications

f29 scratch build
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=26339066" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=26339066">https://koji.fedoraproject.org/koji/taskinfo?taskID=26339066</a>

On a side note, I've also updated the current branches to the latest
1.6.25 bugfix release.
Please report any issue in the related bodhi tickets

Comments

Re: libupnp ABI change notice

By Zamir SUN at 04/15/2018 - 03:29

On 04/13/2018 04:25 PM, Nicolas Chauvet wrote:
Hi,

I am getting gmediarender into Fedora and now it only builds against
libupnp 1.6.*. Upstream tend not to update for now[1] due to some issue
with libupnp 1.8.*.

I tried to get gmediarender build against older libupnp with

BuildRequires: pkgconfig(libupnp) < 1.8

But this do not work.

So do you have any suggestions how can I bundle an old version to
temporary get this in?

Thanks!

[1] <a href="https://github.com/hzeller/gmrender-resurrect/issues/148" title="https://github.com/hzeller/gmrender-resurrect/issues/148">https://github.com/hzeller/gmrender-resurrect/issues/148</a>