DevHeads.net

Mass rebuild - emacs broken

emacs isn't installable at the moment, so any package that needs emacs
fails to build, eg:

<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=32380321" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=32380321">https://koji.fedoraproject.org/koji/taskinfo?taskID=32380321</a>

Rich.

Comments

Re: Mass rebuild - emacs broken

By Jan Synacek at 02/01/2019 - 06:21

On Thu, Jan 31, 2019 at 11:19 PM Richard W.M. Jones < ... at redhat dot com>
wrote:

DEBUG util.py:490: BUILDSTDERR: Error:
DEBUG util.py:490: BUILDSTDERR: Problem: package emacs-1:26.1-7.fc30.x86_64
requires libMagickCore-6.Q16.so.6()(64bit), but none of the providers can
be installed
DEBUG util.py:490: BUILDSTDERR: - package emacs-1:26.1-7.fc30.x86_64
requires libMagickWand-6.Q16.so.6()(64bit), but none of the providers can
be installed
DEBUG util.py:490: BUILDSTDERR: - conflicting requests
DEBUG util.py:490: BUILDSTDERR: - nothing provides
libwmflite-0.2.so.7()(64bit) needed by
ImageMagick-libs-1:6.9.10.23-1.fc30.x86_64

Looks like a broken ImageMagick to me.

Re: Mass rebuild - emacs broken

By =?UTF-8?Q?Bj=c3... at 02/01/2019 - 08:15

Am Freitag, den 01.02.2019, 12:21 +0100 schrieb Jan Synacek:

It was due to an unannoced soname bump in libwmf. This should be fixed
already by ImageMagick-6.9.10.23-3.fc30.

I'd suggest to rebuild the failing packages into the f30-rebuild tag
using:

fedpkg build --nowait --target f30-rebuild

in their recent checkout of the corresponding master branch.

Cheers,
Björn

Re: Mass rebuild - emacs broken

By =?UTF-8?Q?Bj=c3... at 02/01/2019 - 08:39

Am Freitag, den 01.02.2019, 14:15 +0100 schrieb Björn 'besser82' Esser:

I've just resubmitted builds to the f30-rebuild tag for all emacs*
packages that failed because of this.

Re: Mass rebuild - emacs broken

By Kevin Fenzi at 02/01/2019 - 10:49

Note that for fixing mass rebuild issues, you can just bump the release
and do a normal rawhide build. When the mass rebuild side tag is merged
back it checks if there is a newer build already and if so doesn't merge
in the mass rebuild one.

And thanks for fixing things! It's appreciated...

kevin

Re: Mass rebuild - emacs broken

By Zdenek Dohnal at 02/01/2019 - 07:30

On 2/1/19 12:21 PM, Jan Synacek wrote:

Re: Mass rebuild - emacs broken

By =?UTF-8?Q?Bj=c3... at 02/01/2019 - 08:37

Am Freitag, den 01.02.2019, 13:30 +0100 schrieb Zdenek Dohnal:

I've untagged the buildroot-override for libwmf in f29. Your build
should be fine again in about 15 minutes or so.

Re: Mass rebuild - emacs broken

By Zdenek Dohnal at 02/01/2019 - 08:40

On 2/1/19 2:37 PM, Björn 'besser82' Esser wrote: