DevHeads.net

Modular packages requiring Python 3.7

The following Fedora 30 modular packages require python(abi) = 3.7:

$ repoquery --repo=updates-modular --whatrequires 'python(abi) = 3.7'
meson-0:0.50.1-1.module_f30+3966+49c83da1.noarch
python3-aexpect-0:1.5.1-5.module_f30+4307+91f2a6b8.noarch
python3-pygit2-0:0.27.4-1.module_f30+2959+693db98d.x86_64
stratis-cli-0:1.0.2-1.module_f30+4065+aaaad0b9.x86_64

$ repoquery --repo=updates-modular --whatrequires 'python(abi) = 3.7' --source
meson-0.50.0-1.module_f30+3586+7354b37a.src.rpm
python-aexpect-1.5.1-4.module_f30+2883+7f6a800a.src.rpm
python-pygit2-0.27.4-1.module_f30+2959+693db98d.src.rpm
stratis-cli-1.0.2-1.module_f30+3525+55cfb91a.src.rpm

It seems I cannot query Modular Rawhide at all:

$ repoquery --repo=rawhide-modular -a
(nothing here)

Who can help me with the following three problems:

- how do I know what module is this in?
- how do I query rawhide?
- how do I rebuild the modules against a side tag?

Comments

Re: Modular packages requiring Python 3.7

By Kevin Fenzi at 08/26/2019 - 13:00

On 8/21/19 8:59 AM, Miro HronĨok wrote:
But thats fine right, python 3.7 is still in f30?

This is likely due to it needing a mass module rebuild. Hopefully mohan
will get that in the next few days.

The only one I can help with is the middle one, and I think you are
doing it right, there is just not very many modules there yet.

kevin