DevHeads.net

Problem: package fwupdate-libs-10-6.fc28.x86_64 requires shim

Hello,

I've getting the following error when I try to update from f27 to f28:

# dnf system-upgrade download --refresh --releasever=28
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora 28 - x86_64 - Updates 4.1 kB/s | 257 B 00:00
Fedora 28 - x86_64 2.0 MB/s | 60 MB 00:30
Last metadata expiration check: 0:00:00 ago on Sat 10 Mar 2018 01:30:36 PM EST.
Error:
Problem: package fwupdate-libs-10-6.fc28.x86_64 requires shim, but none of the providers can be installed
- problem with installed package fwupdate-libs-10-1.fc27.x86_64
- shim-x64-13-0.7.x86_64 does not belong to a distupgrade repository
- fwupdate-libs-10-1.fc27.x86_64 does not belong to a distupgrade repository

Looking at the koji builds there is no shim-x64... but there is a shim-13

Any ideas?

tia,

steved.

Comments

Re: Problem: package fwupdate-libs-10-6.fc28.x86_64 requires shi

By Adam Williamson at 03/10/2018 - 18:12

On Sat, 2018-03-10 at 13:57 -0500, Steve Dickson wrote:
It's known, is a blocker bug, and is being dealt with.

<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1552910" title="https://bugzilla.redhat.com/show_bug.cgi?id=1552910">https://bugzilla.redhat.com/show_bug.cgi?id=1552910</a>

Via <a href="https://bugzilla.redhat.com/show_bug.cgi?id=1553807" title="https://bugzilla.redhat.com/show_bug.cgi?id=1553807">https://bugzilla.redhat.com/show_bug.cgi?id=1553807</a> , in fact, it's
a blocker bug for another reason!

If you enable updates-testing, it should work, because of this update:

<a href="https://bodhi.fedoraproject.org/updates/FEDORA-2018-9877df9844" title="https://bodhi.fedoraproject.org/updates/FEDORA-2018-9877df9844">https://bodhi.fedoraproject.org/updates/FEDORA-2018-9877df9844</a>

We need to get karma on that update and get it pushed stable (and then
get composes working so it actually shows up in a compose that gets
synced out).

Re: Problem: package fwupdate-libs-10-6.fc28.x86_64 requires shi

By Alessio Ciregia at 03/10/2018 - 15:30

Same issue here:

<
<a href="https://lists.fedoraproject.org/archives/list/ ... at lists dot fedoraproject.org/thread/EM64662HQ6UKKU7NECZO2C2LFD2Z6EUP/" title="https://lists.fedoraproject.org/archives/list/ ... at lists dot fedoraproject.org/thread/EM64662HQ6UKKU7NECZO2C2LFD2Z6EUP/">https://lists.fedoraproject.org/archives/list/ ... at lists dot fedoraproject.o...</a>
Ciao,
A.