DevHeads.net

Rawhide build fails because pulling in F29 depedency instead of F30 dependency

<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=32577327" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=32577327">https://koji.fedoraproject.org/koji/taskinfo?taskID=32577327</a>

This says it's failing because:

DEBUG util.py:490: BUILDSTDERR: - nothing provides ocaml(Migrate_parsetree_driver) = 296ee343a6c2118db57c2ee01f0e5e88 needed by ocaml-ppx-tools-versioned-5.2-1.fc29.x86_64

But that's because it's using the wrong package. The latest
ocaml-ppx-tools-versioned builds are from F30:

ocaml-ppx-tools-versioned-5.2-3.fc30 rjones 2019-02-06 14:15:44
ocaml-ppx-tools-versioned-5.2-2.fc30 releng 2019-02-02 19:42:08
ocaml-ppx-tools-versioned-5.2-1.fc29 andyli 2018-08-12 16:18:18

<a href="https://koji.fedoraproject.org/koji/packageinfo?packageID=26150" title="https://koji.fedoraproject.org/koji/packageinfo?packageID=26150">https://koji.fedoraproject.org/koji/packageinfo?packageID=26150</a>

Why is it trying to install the F29 package?

Rich.

Comments

Re: Rawhide build fails because pulling in F29 depedency instead

By Tom Hughes at 02/06/2019 - 09:54

On 06/02/2019 14:45, Richard W.M. Jones wrote:
Because the f30 builds are still stuck in the seemingly
endless signing queue post rebuild.

Tom

Re: Rawhide build fails because pulling in F29 depedency instead

By Richard W.M. Jones at 02/06/2019 - 09:53

On Wed, Feb 06, 2019 at 02:45:54PM +0000, Richard W.M. Jones wrote:
OK I guess it's because the tag is wrong: The releng package above is
still tagged with ‘f30-pending’. I see earlier messages on this list
about delays signing packages.

Rich.