DevHeads.net

rawhide protobuf update with new soname

I prepared a protobuf upgrade from 3.6 to 3.11 in rawhide. It comes with
a soname update and requires its dependencies to be rebuilt.

I tested it all in copr and most of the packages are rebuilding except
for the following packages:

* dynafed - compile error:
In file included from /builddir/build/BUILD/dynafed-1.5.1/src/UgrMemcached.pb.h:23,
from /builddir/build/BUILD/dynafed-1.5.1/src/LocationInfo.cc:21:
/usr/include/google/protobuf/io/coded_stream.h:842:16: error: macro
"Error" requires 2 arguments, but only 1 given
842 | uint8* Error() {
| ^

* community-mysql:
there is a simple upstream patch to fix the compile error but the test
fails in copr with:
Failed to connect to systemd notification socket named /run/systemd/nspawn/notify. Error: 'Permission denied'

Does not sound like it is related to the protobuf update

* mumble - compile error:
In file included from BanEditor.cpp:36:
Global.h:142:11: error: expected ',' or '...' before '(' token
142 | #define g (*Global::g_global_struct)
| ^
Global.h:142:11: error: expected ',' or '...' before '(' token
142 | #define g (*Global::g_global_struct)
| ^
Global.h:142:11: error: expected ',' or '...' before '(' token
142 | #define g (*Global::g_global_struct)
|

* paraview - cmake failure:
CMake Error at CommandLineExecutables/CMakeLists.txt:77 (get_property):
get_property could not find TARGET pthread. Perhaps it has not yet been created.

* fts: No matching package to install: 'activemq-cpp-devel'

* kismet: error: Invalid version (double separator '-'): 2019-08-GIT: pkgconfig(kismet) = 2019-08-GIT

Most of the errors do not sound protobuf related.

I want to do the protobuf upgrade in rawhide on Monday, 2019-12-09, just
after the rawhide compose has finished to be able to rebuild all
dependencies before the next compose.

Please let me know if you want to rebuild your package yourself or if
you see other problems with the protobuf upgrade.

Adrian