DevHeads.net

Retiring python-slimit in Rawhide

Upstream is dead (website is gone), it hasn't seen a release in over three years
and nothing in Fedora relies on it anymore.

Comments

Re: Retiring python-slimit in Rawhide

By Jonathan Underwood at 10/01/2016 - 15:32

On 20 July 2016 at 15:40, Stephen Gallagher < ... at redhat dot com> wrote:
Actually, the package js-web-socket-js depended on this during build.
Yeah, I only just noticed - just a heads up to check BuildRequires as
well as Requires when retiring.

Cheers,
Jonathan.

Re: Retiring python-slimit in Rawhide

By Jonathan Underwood at 10/01/2016 - 15:58

On 1 October 2016 at 21:32, Jonathan Underwood
<jonathan. ... at gmail dot com> wrote:
And.. python-slimit was previously the recommended minifier to use for
minimization during packaging. I've updated this page to advocate the
use of uglifyjs instead:

<a href="https://fedoraproject.org/wiki/JavaScript/Minification_Issues#jsmin" title="https://fedoraproject.org/wiki/JavaScript/Minification_Issues#jsmin">https://fedoraproject.org/wiki/JavaScript/Minification_Issues#jsmin</a>

But there may be a preferred tool to uglifyjs, so someone more
knowledegable may want to edit that if so.

Cheers,
Jonathan