DevHeads.net

roundup of failing images for 2019-07-07

So, what better way to relax on a sunday than to look at image compose
failures? :)

1. The armv7 workstation compose:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106518" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106518">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106518</a>

This is failing because it cannot find 'epiphany'.
This is because it's using the Workstation repo instead of the
"Everything" repo to compose from. So, we either need to fix that or
remove epiphany from it's kickstart. Who "owns" this image? The arm SIG?
Workstation sig?

2. Fedora Astronomy KDE live:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106442" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106442">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106442</a>

DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:23:27,932: - nothing
provides python3.7dist(mimeparse) needed by
python3-pyvo-0.9.3-1.fc31.noarch.

This is because python3-mimeparse provides 'python-mimeparse' and not
'mimeparse'. So, one or the other of those two packages need fixing. I
am not sure which.

3. Fedora Scientific KDE live:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106457" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106457">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106457</a>

This is due to the jula package not being installable.
I tried a few obvious fixes (update to 1.1.1, fixing the python2 test
that tried to use 'python', etc), but then it fails in a test:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36117288" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36117288">https://koji.fedoraproject.org/koji/taskinfo?taskID=36117288</a>

4. Fedora Security Live:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106476" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106476">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106476</a>

openvas broken deps.

5. Fedora jam kde live:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106491" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106491">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106491</a>

DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,238: missing
packages: ladspa-swh-plugins.

I guess that needs bringing back or removing from kickstart/comps?

6. Fedora robotics live:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106496" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106496">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106496</a>

Bunch of broken deps:
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,817: Non
interactive installation failed:
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,817: Problem 1:
conflicting requests
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,817: - nothing
provides fawkes-plugin-clips-webview needed by fawkes-1.2.0-5.fc31.x86_64
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,817: - nothing
provides fawkes-plugin-pcl-db needed by fawkes-1.2.0-5.fc31.x86_64
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,818: - nothing
provides fawkes-plugin-rrdweb needed by fawkes-1.2.0-5.fc31.x86_64
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,818: Problem 2:
conflicting requests
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,818: - package
sane-backends-drivers-scanners-1.0.27-23.fc31.i686 requires
sane-backends = 1.0.27-23.fc31, but none of the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,818: - package
sane-backends-drivers-scanners-1.0.27-23.fc31.x86_64 requires
sane-backends = 1.0.27-23.fc31, but none of the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,818: - package
sane-backends-1.0.27-23.fc31.x86_64 is excluded
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,818: Problem 3:
conflicting requests
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,818: - package
libsane-hpaio-3.18.12-13.fc31.i686 requires sane-backends, but none of
the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,819: - package
libsane-hpaio-3.18.12-13.fc31.x86_64 requires sane-backends, but none of
the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,819: - package
sane-backends-1.0.27-23.fc31.x86_64 is excluded
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,819: Problem 4:
conflicting requests
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,819: - package
gnome-getting-started-docs-3.32.1-1.fc30.noarch requires
gnome-user-docs, but none of the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,819: - package
gnome-user-docs-3.32.2-1.fc31.noarch is excluded
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,819: Problem 5:
conflicting requests
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,819: - package
fawkes-doc-1.2.0-5.fc31.noarch requires fawkes = 1.2.0-5.fc31, but none
of the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,820: - nothing
provides fawkes-plugin-clips-webview needed by fawkes-1.2.0-5.fc31.x86_64
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,820: - nothing
provides fawkes-plugin-pcl-db needed by fawkes-1.2.0-5.fc31.x86_64
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,820: - nothing
provides fawkes-plugin-rrdweb needed by fawkes-1.2.0-5.fc31.x86_64
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,820: Problem 6:
conflicting requests
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,820: - package
gnome-boxes-3.33.1-2.fc31.x86_64 requires libvirt-daemon-kvm, but none
of the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,820: - package
libvirt-daemon-kvm-5.5.0-1.fc31.x86_64 requires
libvirt-daemon-driver-storage = 5.5.0-1.fc31, but none of the providers
can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,821: - package
libvirt-daemon-driver-storage-5.5.0-1.fc31.x86_64 requires
libvirt-daemon-driver-storage-core = 5.5.0-1.fc31, but none of the
providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,821: - package
libvirt-daemon-driver-storage-core-5.5.0-1.fc31.x86_64 requires
nfs-utils, but none of the providers can be installed
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:15,821: - package
nfs-utils-1:2.4.1-0.fc31.x86_64 is excluded.

7. Fedora python classroom live:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106499" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106499">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106499</a>

Broken deps:

DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:37,439: Problem:
conflicting requests
DEBUG util.py:585: BUILDSTDERR: 2019-07-07 15:24:37,439: - nothing
provides python3.7dist(qtconsole) < 4.4 needed by mu-1.0.2-1.fc31.noarch.

8. Fedora Scientific Vagrant
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106477" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106477">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106477</a>

julia deps.

9. Fedora container minimal base:
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106487" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=36106487">https://koji.fedoraproject.org/koji/taskinfo?taskID=36106487</a>

Some odd anaconda traceback in dbus?

Full list (including images that just failed on some arches) at:
<a href="https://pagure.io/dusty/failed-composes/issue/2087" title="https://pagure.io/dusty/failed-composes/issue/2087">https://pagure.io/dusty/failed-composes/issue/2087</a>

Fixes welcome.

kevin

9.