DevHeads.net

rpmlib(X-CheckUnifiedSystemdir) is needed by filesystem-3-2.fc17.x86_64

I know I got what I deserved by attempting to "fix" by hand the move
from / to /usr, just did need to boot from the fedora16 dvd, mount lvm
root and finish my "fix"; brain fart, and cyclic dep on moving /lib64
to /usr/lib64 and then a symlink, leaving it with all binaries failing
due to missing /lib64/ld-linux-x86-64.so.2.
After that, while it is finishing updating to rawhide right now, I did
go search for documentation, but still find that
<a href="https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_16_-.3E_Fedora_17" title="https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_16_-.3E_Fedora_17">https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_16_-.3E...</a>
is not much clear about it. Maybe should strongly advise installing
busybox and/or have a step by step procedure. Or even better, to somehow
have it done automatically, by some statically linked program.

This should have been already discussed to death, but I found worth to
post a note about it as I am somewhat of a newcomer to fedora...

Paulo

Comments

Re: rpmlib(X-CheckUnifiedSystemdir) is needed by filesystem-3-2.

By Adam Williamson at 05/15/2012 - 21:56

On Tue, 2012-05-15 at 23:47 -0300, Paulo César Pereira de Andrade wrote:
It, um, does have a step by step procedure. Do what it says there, and
it works. I upgraded five boxes.

This is already done if you use any supported upgrade method -
preupgrade or netinst / DVD upgrade.

Re: rpmlib(X-CheckUnifiedSystemdir) is needed by filesystem-3-2.

By =?ISO-8859-1?Q?... at 05/15/2012 - 22:10

2012/5/15 Adam Williamson < ... at redhat dot com>:
Yes, it was me trying to be too smart :-)

What I did was to install fedora-release-rawhide, disable all
repositories in /etc/yum.repos.d and enable rawhide ones, and then
attempt a few times yum distro-sync until I removed all unresolvable
updates, most due to several review requests and/or requests for
enhancement that I will rebuild...

Not a criticism, just reporting my hacker instinct of only reading
documentation when everything else fails :-)

Paulo

Re: rpmlib(X-CheckUnifiedSystemdir) is needed by filesystem-3-2.

By Adam Williamson at 05/16/2012 - 00:16

On Wed, 2012-05-16 at 00:10 -0300, Paulo César Pereira de Andrade wrote:
Yeah, the reason we have the yum upgrade instructions page is that it's
simply not always possible to ensure a straightforward 'switch repos and
yum upgrade' (or, better, 'yum --releasever=XX distro-sync') will
completely work. That's also why yum isn't an officially supported
upgrade method. /usr move is a good example, really. It would be
impossible, really, to handle it through RPM scripts/triggers alone.