DevHeads.net

Unable to bring new package to bodhi

For some odd reasons, I am unable to update via bodhi even though the
package is already built[1].

Is it a bug from the infrastructure as the database failed to list new
package [2]?

Reference

[1]
<a href="http://koji.fedoraproject.org/koji/search?type=package&amp;match=glob&amp;terms=gimp-luminosity-masks" title="http://koji.fedoraproject.org/koji/search?type=package&amp;match=glob&amp;terms=gimp-luminosity-masks">http://koji.fedoraproject.org/koji/search?type=package&amp;match=glob&amp;terms=...</a>

[2] <a href="https://src.fedoraproject.org/rpms/gimp-luminosity-masks" title="https://src.fedoraproject.org/rpms/gimp-luminosity-masks">https://src.fedoraproject.org/rpms/gimp-luminosity-masks</a>

Comments

Re: Unable to bring new package to bodhi

By Andrew Toskin at 08/13/2017 - 00:45

If you're talking specifically about the Bodhi web UI, then I think I'm having the same problem: After I logged in, I clicked on Create > New Update, tried to search for my package, and got the message "unable to find any packages that match the current query".

I had to start my updates from the bodhi command line tool instead.

~ Andrew Toskin

Re: Unable to bring new package to bodhi

By Zbigniew =?utf-... at 08/13/2017 - 11:02

On Sun, Aug 13, 2017 at 04:45:57AM -0000, Andrew Toskin wrote:
There's a bug open for that, I saw the link posted recently.
You can paste the full nevr string into the "candidate builds" field, and
that works.

Zbyszek

Re: Unable to bring new package to bodhi

By Luya Tshimbalanga at 08/14/2017 - 13:36

On 13/08/17 08:02 AM, Zbigniew Jędrzejewski-Szmek wrote:
I just tested it and confirm the workaround.

Re: Unable to bring new package to bodhi

By Randy Barlow at 08/13/2017 - 17:26

On 08/13/2017 11:02 AM, Zbigniew Jędrzejewski-Szmek wrote:
Indeed: <a href="https://github.com/fedora-infra/bodhi/issues/1731" title="https://github.com/fedora-infra/bodhi/issues/1731">https://github.com/fedora-infra/bodhi/issues/1731</a>

This is planned to be fixed in the upcoming 2.10.0 release.