DevHeads.net

What pulls in weak dependencies?

Hi,

Running `dnf update`, it tries to install:

~~~

... snip ...

Installing weak dependencies:
 mkpasswd                        x86_64 5.4.1-3.fc31           
rawhide                 39 k

... snip ...

~~~

Trying to query for weak dependencies, nothing requires it:

~~~

$ sudo dnf repoquery --whatrecommends mkpasswd
Last metadata expiration check: 0:07:13 ago on Fri Mar  8 23:51:51 2019.

$ sudo dnf repoquery --supplements mkpasswd
Last metadata expiration check: 0:07:53 ago on Fri Mar  8 23:51:51 2019.

~~~

So I wonder how I am supposed to know, why DNF is trying to install such
packages.

Vít