DevHeads.net

cannot run apt-get upgrade

Sir/Madam

I am running an Ubuntu 12.04 system

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.4 LTS"

uname -a
3.2.0-60-generic #91-Ubuntu SMP Wed Feb 19 03:54:44 UTC 2014 x86_64
x86_64 x86_64 GNU/Linux

When I try to upgrade the software I keep getting errors

apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
The following packages have been kept back:
duplicity linux-generic linux-headers-generic linux-image-generic nis
The following packages will be upgraded:
apache2 apache2-mpm-prefork apache2-utils apache2.2-bin
apache2.2-common apt apt-transport-https apt-utils bluez bluez-alsa
bluez-cups bluez-gstreamer cups cups-bsd cups-client cups-common
cups-ppdc deja-dup dpkg dpkg-dev firefox firefox-branding
gir1.2-gdkpixbuf-2.0 gnome-control-center gnome-control-center-data
gnome-settings-daemon ifupdown iproute libapt-inst1.4 libapt-pkg4.12
libbluetooth3 libcups2 libcupscgi1 libcupsdriver1 libcupsimage2
libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls libcurl3-nss
libdpkg-perl libgadu3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
libgnome-control-center1 libgnutls26 libjson0 libmysqlclient18
libnm-glib-vpn1 libnm-glib4 libnm-util2 libpurple-bin libpurple0
libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl
libqt4-script libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite
libqt4-svg libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4
libsnmp-base libsnmp15 libssl-dev libssl-doc libssl1.0.0
libsyncdaemon-1.0-1 libtiff4 libxfont1 libxml2 libxml2-dev
libxml2-utils linux-firmware linux-libc-dev mysql-common network-manager
openssh-client openssh-server openssl python-imaging
python-libxml2 python-ubuntuone-client qdbus simple-scan ssh
ssh-askpass-gnome synaptic thunderbird thunderbird-gnome-support tzdata
ubuntuone-client unity-greeter update-manager
update-manager-core usb-creator-common usb-creator-gtk whoopsie
102 to upgrade, 0 to newly install, 0 to remove and 5 not to upgrade.
Need to get 0 B/138 MB of archives.
After this operation, 17.1 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Extract templates from packages: 100%
Preconfiguring packages ...
(Reading database ...
dpkg: warning: files list file for package `gcc-4.4-base' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `libgomp1' missing, assuming
package has no files currently installed.

dpkg: warning: files list file for package `libglib2.0-0' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `gstreamer0.10-tools'
missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libstdc++6' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `network-manager-gnome'
missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `computer-janitor-gtk'
missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libc6' missing, assuming
package has no files currently installed.

dpkg: warning: files list file for package `python-piston-mini-client'
missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libevent-2.0-5' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `libatk1.0-data' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `libreoffice-gtk' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `kerneloops-daemon' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `dconf-gsettings-backend'
missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libgupnp-1.0-4' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `unzip' missing, assuming
package has no files currently installed.

dpkg: warning: files list file for package `wireless-tools' missing,
assuming package has no files currently installed.

dpkg: warning: files list file for package `qdbus' missing, assuming
package has no files currently installed.

dpkg: warning: files list file for package `libheimbase1-heimdal'
missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `python-twisted-core'
missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `jockey-gtk' missing,
assuming package has no files currently installed.
dpkg: unrecoverable fatal error, aborting:
unable to open files list file for package `fonts-tlwg-mono': No such
device or address
E: Sub-process /usr/bin/dpkg returned an error code (2)

I cannot get past this error

So far I have tried

sudo apt-get autoclean
sudo apt-get autoremove
sudo apt-get clean

sudo apt-get update
sudo apt-get upgrade

sudo apt-get dist-upgrade
sudo apt-get -f install
sudo dpkg --configure -a

All to no avail

I also tried to remove package

fonts-tlwg-mono

but I cannot do that either

Any help in resolving this would be sincerely appreciated

Thanking you.

Yours sincerely

Ian Taylor
University of St.Andrews,
School of Physics & Astronomy,
North Haugh,
St.Andrews,
Fife KY16 9SS,
Scotland.

e-Mail :- <a href="mailto:iat@st-and.ac.uk">iat@st-and.ac.uk</a>
Tel :- (0)1334-463141
Fax :- (0)1334-463104

The University of St Andrews
is a charity registered in
Scotland : No SC013532.

Comments

Re: cannot run apt-get upgrade

By Colin Law at 06/20/2014 - 03:18

On 20 June 2014 09:04, Ian A Taylor <iat@st-andrews.ac.uk> wrote:
Googling for the error message suggests that re-installing them may be
a problem (see <a href="http://serverfault.com/questions/430682/dpkg-warning-files-list-file-for-package-x-missing" title="http://serverfault.com/questions/430682/dpkg-warning-files-list-file-for-package-x-missing">http://serverfault.com/questions/430682/dpkg-warning-files-list-file-for...</a>).
The answer there includes a command that will automatically re-install
all the problematic packages, though I cannot personally vouch for it.

Colin

Re: cannot run apt-get upgrade

By maninder singh at 06/20/2014 - 06:14

Sir/Madam,

I am using Ubuntu 14.04 system and unable to install team viewer and Skype
.Some one have any idea

Regards
Maninder

Re: cannot run apt-get upgrade

By =?ISO-8859-1?Q?... at 06/20/2014 - 06:42

2014-06-20 13:14, maninder singh skrev:
Don't kidnap threads! Start a new one.