DevHeads.net

Kworkers, Kworkers

Hi

Again, those pesky kworker threads are taking over my machine. Right now, I'm having 45 of those. The hard disk is working all the time, but this doesn't slow down the system. Probably because I also have an SSD.

Does anyone know, what this is about? Is it a known (kernel) bug? Should I worry? How to get rid of those things ...?

Bye
Volker

Comments

Re: Kworkers, Kworkers

By Teresa e Junior at 05/15/2018 - 08:48

Em 15/05/2018 09:38, Volker Wysk escreveu:
I have 30, never have noticed any problem! Have you tried checking with
iotop what exactly is spinning the disk?

Re: Kworkers, Kworkers

By Volker Wysk at 05/15/2018 - 08:59

Am Dienstag, 15. Mai 2018, 10:48:52 CEST schrieb Teresa e Junior:
I'm new to iotop. At the top of the list are just kworkers, most of the time. Occasionally the top looks something like this:

Total DISK READ : 1010.91 K/s | Total DISK WRITE : 0.00 B/s
Actual DISK READ: 1129.84 K/s | Actual DISK WRITE: 1070.38 K/s
TID PRIO USER DISK READ DISK WRITE SWAPIN IO> COMMAND
6702 be/4 root 0.00 B/s 0.00 B/s 0.00 % 0.64 % [kworker/u16:8]
152 be/4 root 891.98 K/s 0.00 B/s 0.00 % 0.00 % [kworker/6:2]
4553 be/4 root 118.93 K/s 0.00 B/s 0.00 % 0.00 % [kworker/2:0]
1 be/4 root 0.00 B/s 0.00 B/s 0.00 % 0.00 % init splash
2 be/4 root 0.00 B/s 0.00 B/s 0.00 % 0.00 % [kthreadd]
3 be/4 root 0.00 B/s 0.00 B/s 0.00 % 0.00 % [ksoftirqd/0]
5 be/0 root 0.00 B/s 0.00 B/s 0.00 % 0.00 % [kworker/0:0H]

That "init splash" entry comes often...

What does that tell you..? There is no documentation on the "TID" column in the man page.

Greetings
Volker