DevHeads.net

upgrading 12.4 LTS PHP

The 12.04 LTS php is 5.3. I would like to upgrade to the most
current stable version in the repositories.

I did a sudo upgrade but did not see php on the list.

what is the proper way:
to find out what the php release in the repository is?
upgrade that package.

bill

Comments

Re: upgrading 12.4 LTS PHP

By Colin Law at 07/11/2013 - 15:27

On 11 July 2013 16:01, william drescher < ... at techservsys dot com> wrote:
To find out what is the latest version in the repository do
apt-cache policy php5

It should show which version is installed and which is the latest
version. For 12.04 I believe the version is 5.3.10. To make sure
that all packages are up to date run
sudo apt-get update && sudo apt-get dist-upgrade

Colin

Re: upgrading 12.4 LTS PHP

By Erick Ocrospoma Lazo at 07/11/2013 - 11:38

I think that someone else asked that before :-)

<a href="http://askubuntu.com/questions/109404/how-do-i-install-latest-php-in-supported-ubuntu-versions-like-5-4-x-in-ubuntu-1" title="http://askubuntu.com/questions/109404/how-do-i-install-latest-php-in-supported-ubuntu-versions-like-5-4-x-in-ubuntu-1">http://askubuntu.com/questions/109404/how-do-i-install-latest-php-in-sup...</a>

you can do a

sudo apt-cache policy package

in order to get versions of "package", see the one selected to be installed
and ensure yourself that php 5.4.x is going to be installed.

~ Happy install !

Cel : 511-950307809
Blog : <a href="http://piobox.blogspot.com/" title="http://piobox.blogspot.com/">http://piobox.blogspot.com/</a>
LUG : <a href="http://www.utpinux.org" title="http://www.utpinux.org">http://www.utpinux.org</a>
Linux User ID : 549567