DevHeads.net

Postings by Tapas Mishra

Is there an installer for Ubuntu which works on Nokia Lumia

I am looking for an installer like Wubi or some thing similar if there
exists any such
thing by which I can install Ubuntu on my mobile phone (Windows 8 )
Nokia Lumia 800 <a href="http://www.gsmarena.com/nokia_lumia_800-4240.php" title="http://www.gsmarena.com/nokia_lumia_800-4240.php">http://www.gsmarena.com/nokia_lumia_800-4240.php</a>
I looked following links
1) <a href="http://askubuntu.com/questions/235795/can-ubuntu-mobile-be-installed-on-a-nokia-lumnia-800/235819" title="http://askubuntu.com/questions/235795/can-ubuntu-mobile-be-installed-on-a-nokia-lumnia-800/235819">http://askubuntu.com/questions/235795/can-ubuntu-mobile-be-installed-on-...</a>
2) <a href="http://www.ubuntu.com/devices/phone/design" title="http://www.ubuntu.com/devices/phone/design">http://www.ubuntu.com/devices/phone/design</a>
but I did not found any thing useful much.

Let me know if there is some thing or I missed some thing.

ubuntu hangs while shutting down

I am using Ubuntu 11.10 and when I shut it down sudo reboot it hangs
while shutting down.
I observed for more than 30 minutes and it could not still shut down.
What should I check?

errors instaling virt-manager on 11.10

Hi,
I am trying to install virt-manager on 11.10 on 64 bit machine
sudo aptitude install virt-manager

here is where it stopped the install

Processing triggers for python-support ...
Errors were encountered while processing:
libvirt-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up libvirt-bin (0.9.2-4ubuntu15) ...
useradd: cannot lock /etc/passwd; try again later.
adduser: `/usr/sbin/useradd -d /var/lib/libvirt -g kvm -s /bin/false -u 118
libvirt-qemu' returned error code 1.

printer not working

I have a USB printer
Bus 006 Device 002: ID 04a9:2617 Canon, Inc. CAPT Printer
upon firing a print the document shows processing processing............
how ever there is no response from the printer end.
The same thing works well with M$ machine.Every thing seems to be normal
here did I miss some thing?

astrology softwares in repos

Well this link
<a href="https://help.ubuntu.com/community/Astrology" title="https://help.ubuntu.com/community/Astrology">https://help.ubuntu.com/community/Astrology</a>
mentions about astrolog package ,sudo apt-get
I found it missing from repos

<a href="http://packages.ubuntu.com/search?keywords=astrolog&amp;searchon=names&amp;suite=oneiric&amp;section=all" title="http://packages.ubuntu.com/search?keywords=astrolog&amp;searchon=names&amp;suite=oneiric&amp;section=all">http://packages.ubuntu.com/search?keywords=astrolog&amp;searchon=names&amp;suite...</a>

Is compiling from sources the only way or I missed to search some thing
else?

oneiric **: Unable to locate theme engine in module_path: "murrine",

I open some apps like Vmware via command line though the apps open
correctly but I get a warning
like above
**: Unable to locate theme engine in module_path: "murrine",

My OS is oneiric.
Googled a few links and found
<a href="http://ubuntuforums.org/showpost.php?p=1462585&amp;postcount=34" title="http://ubuntuforums.org/showpost.php?p=1462585&amp;postcount=34">http://ubuntuforums.org/showpost.php?p=1462585&amp;postcount=34</a>
it seems that this guy has some working solution but what is he referring
to is it available for oneiric if yes then which package I need?

copied wubi root.disk to another drive what changes should I do in grub

I installed Ubuntu 11.04 by Wubi and then copied the ubuntu folder
from C: to D: drive what changes should I make in grub and where as
the grub folder was empty.

How can I go back to Ubuntu classic from Unity in 11.10.

How can I go back to Ubuntu classic from Unity in 11.10.
I do not want to use Unity and I do not see any option in system settings.

how to add USB drive to Update manager

I want to upgrade 11.04 to 11.10 I have downloaded alternate ISO on a USB.
In update manager GUI---> Add volume while USB is inserted and I click
add volume I get
Please insert a disk in drive.
Why is there a default assumption that some one will Upgrade from a CDROM only.
Can't it be a USB (in my case) and then I get an error
Error scanning the CD
E:Unable to stat the mount point /media/cdrom/ -stat( 2: No such file
or directory), E:Unable to stat the mount point /media/cdrom -stat (2:
No such file or directory),
E: failed to mount the CDROM.

and then I can not proceed.
I have alternate ISO

upgrade to 11.10 is failing

sudo do-release-upgrade is failing
<a href="http://paste.ubuntu.com/709769/" title="http://paste.ubuntu.com/709769/">http://paste.ubuntu.com/709769/</a>

can check above.
I am on 11.04
<a href="http://paste.ubuntu.com/709770/" title="http://paste.ubuntu.com/709770/">http://paste.ubuntu.com/709770/</a>

Courts in India directed to use Ubuntu

Hi,wanted to share this with list.

<a href="http://efytimes.com/e1/70691/fullnews.htm" title="http://efytimes.com/e1/70691/fullnews.htm">http://efytimes.com/e1/70691/fullnews.htm</a>

dependency problem while installing fatrat (download manager)

While installing a download manager fatrat via Synaptics here is an
error I am getting

fatrat: Depends: libboost-date-time1.42.0 (>= 1.42.0-1) but
1.42.0-4ubuntu2 is to be installed
Depends: libboost-system1.42.0 (>= 1.42.0-1) but
1.42.0-4ubuntu2 is to be installed
Depends: libc6 (>= 2.4) but 2.13-0ubuntu13 is to be installed
Depends: libcurl3-gnutls (>= 7.16.2-1) but 7.21.3-1ubuntu1 is
to be installed
Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
Depends: libqt4-dbus (>= 4:4.5.3) but 4:4.7.2-0ubuntu6.2 is to
be installed

calibre (ebook reader) dependencies problem in natty (Ubuntu 11.04 )

I tried installing calibre (via apt-get and synaptics both) got following errors

The following packages have unmet dependencies:

calibre: Depends: python (>= 2.6) but 2.7.1-0ubuntu5 is to be installed
Depends: python-pypdf (>= 1.10) but 1.12-3 is to be installed
Depends: python-cssutils (>= 0.9.7~) but 0.9.7~b2-2 is to be installed
Depends: python-encutils (>= 0.9.5) but 0.9.7~b2-2 is to be installed
Depends: python-cherrypy3 (>= 3.1.1) but 3.1.2-1 is to be installed
Depends: python-qt4 (>= 4.7.3) but 4.8.3-2 is to be installed
Depends:

problem in rendering of hindi fonts on chrome

The problem is with respect to browser Chrome (I use Ubuntu 11.04 )
and in certain cases such as heading etc the font is not rendered
correctly.

Here is the page in problem on Chrome
<a href="https://picasaweb.google.com/mightydreams/HindiFontsProblem#5655127655183416498" title="https://picasaweb.google.com/mightydreams/HindiFontsProblem#5655127655183416498">https://picasaweb.google.com/mightydreams/HindiFontsProblem#565512765518...</a>

A Correctly rendered page should appear like this

<a href="https://picasaweb.google.com/mightydreams/HindiFontsProblem#5655127704627761410" title="https://picasaweb.google.com/mightydreams/HindiFontsProblem#5655127704627761410">https://picasaweb.google.com/mightydreams/HindiFontsProblem#565512770462...</a>

the link which I tried is <a href="http://in.jagran.com" title="http://in.jagran.com">http://in.jagran.com</a> but this problem is
there in many other URLs which I open in chrome,
there is no such problem when I am using Firefox on Ubuntu.

mails from list are coming with warning on gmail

All the mails coming from Ubuntu users mailing list (this one) are
coming to my mail box with a warning from gmail.
The warning is

"This message may not have been sent by: <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a> Learn more
Report phishing "

Where the address <a href="mailto: ... at gmail dot com"> ... at gmail dot com</a> is some one who posted question to the list.
Some one who is moderating this list please have a look.

Tapas

voice call using skype audio/microphone problem at my end

Hi,
list there is a small problem.I use Ubuntu 10.04 64 ,and Skype

lspci output for the audio card is
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD
Audio Controller [8086:293e] (rev 03)
Subsystem: Dell Device [1028:02cf]
Flags: bus master, fast devsel, latency 0, IRQ 21
Memory at f6afc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+
Queue=0/0 Enable-
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00

what codec are required to watch the live stream on following link

At the same time instant I took two different snapshots for a live
streaming link

1) Snapshot on Ubuntu 10.04 64 bit here the stream is not visible
<a href="http://www.flickr.com/photos/48996087@N07/5683379905/in/photostream" title="http://www.flickr.com/photos/48996087@N07/5683379905/in/photostream">http://www.flickr.com/photos/48996087@N07/5683379905/in/photostream</a>

2) and here is a snapshot in Windows XP here you can see the stream
<a href="http://www.flickr.com/photos/48996087@N07/5683389113/in/photostream" title="http://www.flickr.com/photos/48996087@N07/5683389113/in/photostream">http://www.flickr.com/photos/48996087@N07/5683389113/in/photostream</a>

What codec is needed I am using Lucid 64 bit.
The link is <a href="http://www.somnath.org/live-darshan.aspx" title="www.somnath.org/live-darshan.aspx">www.somnath.org/live-darshan.aspx</a>

unable to start apache as process/dameon

One of my machine was shutdown for more than 2 months I today booted
it and found Apache did not started as a process.
ps out put does not have it.I do not see any thing in Apache log what
do I need to check or do?
It is Lucid server.

downgraded to an old version of flash how to trace what changes were made by installer

I was having some problem with flash player version 10.2 so I had to
downgrade it.
Based on instructions here
<a href="http://www.webupd8.org/2011/03/fix-pinkred-youtube-videos-bug-using.html#more" title="http://www.webupd8.org/2011/03/fix-pinkred-youtube-videos-bug-using.html#more">http://www.webupd8.org/2011/03/fix-pinkred-youtube-videos-bug-using.html...</a>
for 64 bit
before doing above I had taken a backup
sudo cp /usr/lib/flashplugin-installer/libflashplayer.so
/usr/lib/flashplugin-installer/libflashplayer.so.old

Now I did
wget <a href="http://archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/flashplugin-installer_10.1.85.3ubuntu1_amd64.deb" title="http://archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/flashplugin-installer_10.1.85.3ubuntu1_amd64.deb">http://archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/f...</a>
sudo dpkg -i flashplugin-installer_10.1.85.3ubuntu1_amd64.deb

I am not able to find out what changes had the above

how to install source code

I need Apache source code which Ubuntu is using so how do I go for
installing the source itself.
Tried some guides but all was in vain.

creating a local mirror at home computer

Hi,
I am trying to debug a problem which necessarily needs a Ubuntu mirror
for install (basically problem in creating guest OS on Xen with
virt-manager).
So I decided to setup a local mirror of Ubuntu in a USB hard disk that
I have of size 1TB.
I do not have such an internet bandwidth at my home computer that I do
an installation
pointing to a mirror from Ubuntu repos.So I decided to download Ubuntu DVD's.
Some where on internet I found it was mentioned this process needs 15
GB of space basically 4 DVDs.
While searching for DVDs I got following link
<a href="http://ftp.acc.umu.se/mirror/cdimage.ubuntu" title="http://ftp.acc.umu.se/mirror/cdimage.ubuntu">http://ftp.acc.umu.se/mirror/cdimage.ubuntu</a>

what plugin is required to watch this link

<a href="http://livetubetv.in/video/OKH25HG7R2SB/JAPAN-TSUNAMI-LIVE-NEWS-FROM-JAPAN" title="http://livetubetv.in/video/OKH25HG7R2SB/JAPAN-TSUNAMI-LIVE-NEWS-FROM-JAPAN">http://livetubetv.in/video/OKH25HG7R2SB/JAPAN-TSUNAMI-LIVE-NEWS-FROM-JAPAN</a>

I can see youtube videos on firefox and chrome on my system but above link
searches for some plugin and then does not play saying microsoft media
protocol it
does not have any suitable plugin.
What command should I use so that I can post all the multimedia plugins
installed on my system here.

service utility with Ubuntu 10.04 does not work properly when used to restart network

Here is a situation when I do
root@tapas:~# service networking restart
restart: Unknown instance:
and when I do
root@tapas:~# service networking stop
stop: Unknown instance:

now if I do

/etc/init.d/networking stop
* Deconfiguring network interfaces... Ignoring unknown
interface eth1=eth1.
[ OK ]
note above I did not used service command and it shows working.

and now if I start it in same way I get a warning.

/etc/init.d/networking start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g.

how to create an http install environment of Ubuntu

Hi,
I am having a situation where I can not use a CD or PxE boot or wubi to
install.
I need to necessarily do an http install of Ubuntu.I am basically trying to
create a guest OS in
a virtualization solution and seems some library of GUI is corrupt due to
which other options other than http are not working.
Here is what I did
1) Download ubuntu 10.04 32 bit ISO
2) Kept it in /var/www (apache2 is running)
3) renamed it to ubuntu.iso

and when I reached a stage where installation begins I gave path
<a href="http://localhost/ubuntu.iso" title="http://localhost/ubuntu.iso">http://localhost/ubuntu.iso</a>
but I got an error saying any installable distribution not found.

4)

how to make symbols used in differential equations and maths etc character map information needed

Hi,
I wanted to know with respect to a link here
<a href="http://random.irb.hr/signup.php" title="http://random.irb.hr/signup.php">http://random.irb.hr/signup.php</a>
if you look at the CAPTCHA section the answer of which it is solution
of a differential equation given.
The answer to the CAPTCHA does not needs any special character map.

But this gave rise to a question in my mind if there is there some
math library to enter such things.
How can I enter such a mathematical thing in a web form.(The above
link is just an example.)

I googled but <a href="http://www.google.co.in/search?sourceid=chrome&amp;client=ubuntu&amp;channel=cs&amp;ie=UTF-8&amp;q=Math+library+for+Ubuntu" title="http://www.google.co.in/search?sourceid=chrome&amp;client=ubuntu&amp;channel=cs&amp;ie=UTF-8&amp;q=Math+library+for+Ubuntu">http://www.google.co.in/search?sourceid=chrome&amp;client=ubuntu&amp;channel=cs&amp;...</a>
the link comes with some C

.screenrc entries to show always the windows in bottom

I added following to my .screenrc
caption always “%H %c | %-w%{=}%n-%t%{-}%+w”

but when I execute screen then only for some initial seconds I can see
the window name and some other details in bottom.
How can I set it to permanently view?
There is one more file .screen
which has
hardstatus alwayslastline

In my .screenrc what should I modify?

how to create a 32 bit PV Lucid guest on pv-ops Dom0 on Lucid 10.04 64 bit

I am running Xen-4.0.1 on Lucid 64 bit using a pv-ops Dom0 kernel 2.6.32.27
from jeremy's tree
git clone -o xen -n
git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git
linux-2.6-xen
and compiled I was able to get xm info (i.e. xen running)
but all the gui I tried has resulted into failure.
The ISO of Ubuntu I have are made to run on bare metal if I understand
correctly.
So in case of the pv-ops Dom0 kernel I need PV guest.
So how can I create a PV guest which is lucid 32 bit on a Ubuntu 10.04
64 desktop which is running Xen with a pv-ops Dom0 kernel.

options to create guest OS in virt-manager are greyed out on Lucid 10.04 64 bit

Hi,
I just installed a pv-ops Dom0 2.6.32.27 Kernel on a 64 bit non VT machine.
Following instructions here
<a href="http://wiki.xensource.com/xenwiki/Xen4.0" title="http://wiki.xensource.com/xenwiki/Xen4.0">http://wiki.xensource.com/xenwiki/Xen4.0</a>
for 64 bit Ubuntu 10.04

apt-get install bcc bin86 gawk bridge-utils iproute libcurl3
libcurl4-openssl-dev bzip2 module-init-tools transfig tgif texinfo
texlive-latex-base texlive-latex-recommended texlive-fonts-extra
texlive-fonts-recommended pciutils-dev mercurial build-essential
make gcc libc6-dev zlib1g-dev python python-dev python-twisted
libncurses5-dev patch libvncserver-dev libsdl-dev libjpeg62-dev iasl
libbz2-dev e2fslibs-dev git-core uui

how to get wireless back on a xen pv-ops dom0 setup on lucid 64 bit

I was trying to set up Xen-4.0.1 on my 64 bit non VT machine.
<a href="http://wiki.xensource.com/xenwiki/XenParavirtOps" title="http://wiki.xensource.com/xenwiki/XenParavirtOps">http://wiki.xensource.com/xenwiki/XenParavirtOps</a>
After I had compiled Xen-4.0.1 successfully (here success refers to no
error during compile)
I did
git clone git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git
linux-2.6-xen
cd linux-2.6-xen
cp /boot/config-2.6.32-24-generic /usr/src/linux-2.6-xen/.config
make menuconfig
make modules_install install
update-initramfs -c -k 2.6.32.27

Then change my grug.cfg to look as follows

menuentry 'Ubuntu, with Xen and Linux 2.6.32.27' --class ubuntu
--class gnu-linux --class gnu --cla

what is menu.lst equivalent for lucid

Hi,
I am doing some experiment with pv-ops Dom0 kernel with Xen as mentioned here
<a href="http://wiki.xensource.com/xenwiki/XenParavirtOps" title="http://wiki.xensource.com/xenwiki/XenParavirtOps">http://wiki.xensource.com/xenwiki/XenParavirtOps</a>
so I have basically compiled a few kernels which are many in number.
I remember long time back using menu.lst for grub menu.
Before I go to boot my system I searched for menu.lst file but I could
not find it any where.
I am using lucid 64 bit.
Can any one suggest me what should I be doing.I would prefer to do
manually than update-grub sort of thing.