DevHeads.net

Postings by =?UTF-8?Q?Fran=C3=A7ois_Cami?=

orphaning all my packages

Hello,

I'll orphan all my packages at 2PM UTC+2 tomorrow.

rpms/bats -- Bash Automated Testing System ( master f24 f23 f22 epel7 el6 )
rpms/djview4 -- DjVu viewer ( epel7 )
rpms/djvulibre -- DjVu viewers, encoders, and utilities ( master f24
f23 f22 epel7 el6 )
rpms/enet -- Thin, simple and robust network layer on top of UDP (
master f24 f23 f22 epel7 )
rpms/gpsd -- Service daemon for mediating access to a GPS ( epel7 )
rpms/pdf2djvu -- PDF to DjVu converter ( master f24 f23 f22 epel7 )
rpms/pngcrush -- Optimizer for PNG (Portable Network Graphics) files (
master f24 f23 f22 el6 )
rpms/pylibl

osgaudio packaging (bundles/provides openalpp)

Hi,

I'd like to package osgaudio, which is an OpenSceneGraph-like frontend
to OpenAL.
It is currently maintained by OpenSceneGraph's main author at:
<a href="https://github.com/robertosfield/osgaudio/" title="https://github.com/robertosfield/osgaudio/">https://github.com/robertosfield/osgaudio/</a>

It requires and contains openalpp, a C++ frontend for OpenAL.
We haven't shipped openalpp since Fedora 7.
The original project for openalpp hasn't been updated since 2005 or so.
I've searched for a better fork of openalpp and haven't found any.

My proposal is to install openalpp alongside osgaudio, in separate
subpackages with appropriate Requires.

gcc6 / arm rebuild issue

Hi,

openal-soft fails to build on arm / f24, probably due to a toolchain change:
"
/usr/lib/gcc/armv7hl-redhat-linux-gnueabi/6.0.0/include/arm_neon.h:9013:1:
error: inlining failed in call to always_inline 'vld1q_f32': target
specific option mismatch
"

The complete build log is located at:
<a href="https://kojipkgs.fedoraproject.org//work/tasks/4281/12854281/build.log" title="https://kojipkgs.fedoraproject.org//work/tasks/4281/12854281/build.log">https://kojipkgs.fedoraproject.org//work/tasks/4281/12854281/build.log</a>

Could anyone involved with gcc take a look?

Regards,
François

unresponsive maintainer: landgraf

Greetings,

I'm starting the unresponsive maintainer policy for Pavel Zhukov
(landgraf), as mupdf hasn't been updated in a while:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1148319" title="https://bugzilla.redhat.com/show_bug.cgi?id=1148319">https://bugzilla.redhat.com/show_bug.cgi?id=1148319</a>
which leads to interesting bugs:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1122539" title="https://bugzilla.redhat.com/show_bug.cgi?id=1122539">https://bugzilla.redhat.com/show_bug.cgi?id=1122539</a>
and blocks the zathura-pdf-mupdf plugin:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1095455" title="https://bugzilla.redhat.com/show_bug.cgi?id=1095455">https://bugzilla.redhat.com/show_bug.cgi?id=1095455</a>

If you have a way to contact Pavel, please let him know that we'd
appreciate him to update his packages, or hand them over.

Thanks,
François

orphaning a few packages

Hello,

I'm orphaning a few packages as I do not use them anymore.
* scons
* jed
* greylistd
* and the zathura stack: girara, zathura, zathura-cb, zathura-djvu,
zathura-pdf-poppler, zathura-ps (maintained by contyk)

Regards,
François

ocl-icd: update to 2.2.3 in a week

Hi,

I'll update ocl-icd to the latest release (2.2.3) in a week.

Dependencies: LuxRender, clinfo, clpeak, pocl, mesa.

Updated SPEC and SRPM available at:
<a href="https://fcami.fedorapeople.org/srpms/ocl-icd.spec" title="https://fcami.fedorapeople.org/srpms/ocl-icd.spec">https://fcami.fedorapeople.org/srpms/ocl-icd.spec</a>
<a href="https://fcami.fedorapeople.org/srpms/ocl-icd-2.2.3-1.git20141005.7cd0c2f.fc21.src.rpm" title="https://fcami.fedorapeople.org/srpms/ocl-icd-2.2.3-1.git20141005.7cd0c2f.fc21.src.rpm">https://fcami.fedorapeople.org/srpms/ocl-icd-2.2.3-1.git20141005.7cd0c2f...</a>

Scratch build:
<a href="http://koji.fedoraproject.org/koji/taskinfo?taskID=8539755" title="http://koji.fedoraproject.org/koji/taskinfo?taskID=8539755">http://koji.fedoraproject.org/koji/taskinfo?taskID=8539755</a>

Please let us know of any problem at ocl-icd-owner@.

François

djvulibre/epel6 is no longer an orphan

Hi,
I've taken over djvulibre/epel6 to avoid retiring the package.
Co-maintainers are welcome.
François

Exception procedure: nonresponsive package maintainer

Hello,

I 'd like an up-to-date disper build for EPEL6 and EPEL7.
There are no EPEL branches for disper and the package is outdated (by
~18 months) in rawhide.

I've opened a bug mentioning I can help maintaining the package with
an updated srpm:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1143055" title="https://bugzilla.redhat.com/show_bug.cgi?id=1143055">https://bugzilla.redhat.com/show_bug.cgi?id=1143055</a>
& asked for commit access in pkgdb.
Unfortunately there hasn't been any answer yet.
I've checked koji - marionline hasn't built anything for a year or so.

Note that I only really want to create and maintain the EPEL6/EPEL7
branches at the moment, so I'd like to use the exception procedure
instead of

tinyxml2 API/ABI change

Hello,

I will update tinyxml2 in a week in rawhide.
cppcheck, dvblinkremote and libmediainfo will need to be rebuilt
afterwards. As far as I can tell no change will be needed to rebuild
at least the last two.
A scratch build is available at:
<a href="http://koji.fedoraproject.org/koji/taskinfo?taskID=6859866" title="http://koji.fedoraproject.org/koji/taskinfo?taskID=6859866">http://koji.fedoraproject.org/koji/taskinfo?taskID=6859866</a>

François

orphaning ntop

Hello,

I've orphaned ntop in pkdg.

Cheers

orphaning licq

Hello,

I've orphaned licq in pkdg as I do not use it anymore.

Cheers

orphaning cal3d, freeimage, libosip2, linphone, opencv, osgal

Hello,

I'm orphaning some packages:

cal3d -- Skeletal based 3-D character animation library
freeimage -- Multi-format image decoder library
libosip2 -- oSIP is an implementation of SIP
linphone -- Phone anywhere in the whole world by using the Internet
opencv -- Collection of algorithms for computer vision
osgal -- Adapts OpenSceneGraph to use OpenAL++

Feel free to take ownership.

François