DevHeads.net

Postings by Dave Stevens

who maintains mailman 2.1 for ubuntu 18.04.1?

I installed webmin-virtualmin-mailman and mailman in that order. I
have a problem with the installation and asked on the mailman list and
was referred to the maintainer of the distribution's version. I don't
know a) who that is or b) how to find out (apart from asking here).

Anyone?

Dave

evolution error on first start

I've installed evolution and on first running it, from a terminal, I
get:

(evolution:3870): e-data-server-WARNING **: e_module_load_all_in_directory: Error opening directory '/usr/lib/evolution-data-server/credential-modules': No such file or directory

I've looked in /usr/lib/evolution-data-server/ and sure enough there
isn't a file or directory called credential-modules. I'm not surprised
in a way because I haven't provided any credentials. My understanding
is that a first run wizard will start up to solicit such information
but this has not happened. Ideas?

Dave

help with serial i/o from a device?

I've got a Plantower PMS5003 particle counter that reports
over a serial (RS-232) cable. Inline to my USB port is a uart, acting
as a level shifter. Node.js has a module that allows me to read
successfully from the device (or, strictly speaking, from the USB port).
It is, however, a bit large and clumsy, a lot of overhead to just copy
serial data (at a low rate, about 200 bits per second, into a file.

cron issue

I've set up a cron job to run logwatch at night.

Output from command /usr/sbin/logwatch --mailto=....

gives:

/var/cache/logwatch No such file or directory at /usr/sbin/logwatch
line 634.

and line 634 is:

opendir(TMPDIR, $Config{'tmpdir'}) or die "$Config{'tmpdir'} $!";

I don't understand what file is missing. I can confirm
that /var/cache/logwatch doesn't exist. Should I just arbitrarily make
one? Is it an install error? I've just installed the system, U18.04, up
to date.

Ideas welcome.

d

OT?

I've got an Acer laptop that came with Windows 10 installed and I'd
like to make it dual boot with Ubuntu, don't much care what version.
I've prepared a bootable usb stick. It boots fine with other computers
but not on the Acer. I've disabled secure boot in the BIOS and have no
option to change the boot order, Windows Boot Manager is the only
choice.

Can anyone point me to an information source for this issue? Off-list
is fine.

TIA,

Dave

module issue?

I want to configure nat and I get this:

sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE -v
iptables v1.6.0: can't initialize iptables table `nat': Table does not
exist (do you need to insmod?) Perhaps iptables or your kernel needs to
be upgraded.

uname -r
4.9.80+

and

ls -l /lib/modules
total 8
drwxr-xr-x 3 root root 4096 May 24 03:32 4.14.34+
drwxr-xr-x 3 root root 4096 May 24 03:32 4.14.34-v7+

I think I understand that /lib/modules will need to have an entry for
4.9.80+ but doesn't.
I've run sudo apt upgrade so I don't think that's a problem .But I
don't see how to proceed.

OT?: break up an incoming data stream into fixed length lines? in bash?

I'm using U16.04 to read data from a sensor. The incoming serial data
stream has no newlines, just continuous bytes. In the datastream the
letters B and M occur together at the start of every 24 byte
subsequence. I'm reading the data using getserial with appropriate
speed and parity parms. I don't see a simple way to break it up into
lines with each line having 24 bytes. Does anyone care to suggest a
method? I'd use a bash function if there is one.

TIA,

Dave

firefox quantum saved logins export import??

I'm changing laptops and need to export saved logins (several hundred)
from the old one to the new one, both firefox 58. I can't find an
add-on to do this and it seems (although this is not really clear) that
there isn't one. Anyone have experience (especially successful) with
this?

Dave

export wifi logins?

I'm switching laptops and would like to have a simple way to export or
otherwise copy my wifi logins to the new computer, anyone know a way?

D

secondary screen only works until login

Hi,

I'm using 16.04 on a Toshiba laptop. I want to use a secondary display,
a Samsung SyncMaster 712n. I have it connected to the Toshiba's
external VGA port. The display powered up and showed system activity
right up until the automatic user login took place. I had the system
configured to log me in without asking for a password. When the login
took place the secondary display went blank. The system control panel
shows an unknown secondary display.

In an attempt to see where the problem lies I made a new (second) user
with a password and required a credential check at login.

root only on newly initialized sata drive?

I have booted a live 16.04 and used gparted to remove the partition
then recreate it and format it to ext4. Fine so far. When trying to
save to the the drive I can't unless I use sudo. The permissions show
the drive's only partition is owned by root. How do I change this? I
know how to chown but don't see why it's created as root-owned by
default.

Dave

lossless compression of still images - recommendations?

I'm making a long series of exposures of a landscape where there will be
only very small (but potentially significant) changes from frame to
frame.

OT: nextcloud for ubuntu?

I'm curious to try nextcloud, which describes itself as an owncloud
fork. They don't have a ubuntu desktop client on their site. Does
anyone know of plans to include a desktop client in the ubuntu repos?

D

cp only files without errors

I recently had to copy an NTFS volume from a dead Windows laptop. I
mounted it and copied (using cp) about 250K files to an external
volume. There were several files for which errors were present and for
each I had to answer "skip" at a prompt. I would much rather specify
something like "skip on error" just once at the beginning but don't
see how. Anyone?

Dave

"Error splicing file: File too large"

I made a zip file of 14.1 GB and copied it to a new 16GB usb flash
drive and got this message at about the 99% mark. I didn't know there
was a file size limit and the drive properties showed enough space
beforehand.

Does anyone have a suggestion where I can look for more information
(and a solution?)

2GB RAM, lots of space on /dev/sda1, /dev/sdb1 (the flash drive) is
FAT32, is that an issue?

Dave

make a time lapse movie using gpu and 14.04?

I expect to have a lot of still frames and would like to make a movie
from a specified sequence reasonably quickly. I'm currently using
ffmpeg which works fine and is flexible but fairly slow. Does anyone
know of a method that could use the GPU to speed up the process? 14.04.
I haven't yet set up the final system so I could get any card in
principle if there's one that's preferred.

Dave

Convert archive.org page to original flat html page?

So the server backups were unusable, but archive.org has a good copy
of the flat html (non-do) page. I can save and edit the page to
restore the original, but does anyone know of a better routine or
facility for doing this? It must happen a lot. Using 14.04.3

Dave

little radio driver needed

I was given a teeny usb radio for wifi but no docs or drivers, want to
use it with ubuntu. I think it works, the donor says it is unused.

stop postfix on U14.04?

I want to stop postfix on my U14.04 system. I can "sudo service
postfix stop" and that works fine. But a problem is that AC power is
flaky. I'm working on that separately but in the meantime postfix
restarts when power cycles. I've looked for and found ways to remove
postfix but that's overkill - all I want is to prevent it from running
even through power cycles until explicitly restarted.

Can anyone refer me to a man page or tutorial on that?

TIA!

Dave

wifi driver query

In reading about kernel 4.3 I see that the driver for the Realtek
8192e wifi radio is to be updated. I have one of these now using
kernel 3.16.0 as part of U14.04. Where can I ask if the updated driver
will be present in 16.04? I've been thinking of updating to that in
the Spring when it becomes available. I don't understand where I can
find out. Anyone?

Dave

kernel errors I don't understand

Running logwatch give this message in part, I don't understand its
significance

EXT4-fs (sda1): re-mounted. Opts:
usrquota,grpquota,errors=remount-ro ...: 2 Time(s)

Ideas?

backlight utility?

I've got a samsung n220 netbook into which I recently installed a ssd.
I took advantage of the install to do a clean fresh install of U14.04.
It went well except that I can no longer adjust my backlight. The
function keys that used to do this appear to work - I get a little
slider display on-screen - but there isn't any actual difference in
screen brightness. Anyone have an idea about this one? I tried the
software centre under acpi and backlight but the hits don't seem
relevant.

Dave

desktop config questions - U14.04

I have a laptop with U14.04.2 and am using Gnome Flashback (Metacity)
desktop and have several knowledge gaps.

On the top of the screen is a panel showing on the left the Apps and
Places menu headers, then various program icons as single click launchers
and on the right a wifi and language icon and then the bluetooth,
battery charge and so on icons.

Somehow (accidentally) I've got a document icon on the top panel. It
points to a file that has now been erased from the usb key that it
points to, which is itself absent.

lenovo hangs on boot when usb drive is connected

I'm using 14.04.2 on a lenovo that I remotely administer. I have an
external drive attached for backups - has .tar.gz files no OS not
bootable. Nonetheless it hangs on boot if the external unit is
connected. I unplug the drive, boots normally, plug in and mount the
drive, things work ok, can do backups etc. The BIOS settings don't seem
to involve a problematic boot setting, just to boot off the primary SATA
drive. Problem is I have to go onsite to reboot and that's awkward, as
is leaving the kernel unpatched.

Ideas appreciated.

Dave

can't mount an LVM volume inCentos 5.10

I have a degraded raid array (originally raid-10, now only two drives)
that contains an LVM volume. I can see in the appended text that the
Xen domains are there but I don't see how to mount them. No doubt this
is just ignorance on my part but I wonder if anyone would care to
direct me? I want to be able to retrieve dom-0 and one of the dom-Us
to do data recovery, the others are of no interest.

Suggestions?

odd error installing claws addons

I'm using Ubuntu 14.04 software centre to istall a tnef attachment
handler add-on and get an unmet dependency error with details as
follows:

"The following packages have unmet dependencies:

claws-mail-tnef-parser:i386: Depends: claws-mail (= 3.9.3-1ubuntu1)
but 3.9.3-1ubuntu1 is to be installed"

This doesn't make sense to me, does anyone know what the issue is or
what to do? It happens with some other add-ons too.

Dave

one apache virtual domain won't start

I have a Ubuntu 14.04 box with 8 domains. At first they all worked but
yesterday one stopped serving pages, browser says "-- Server not
found" the config looks ok, domain-specific configs are in
sites-enabled, there are access errors, all of the type, "file not
found"

I don't know where to look with this. Suggestions?

sw raid issue with C5.10-xen

My raid array won't boot, gives a kernel panic - attempt to kill init
message and goes into endless reboots.

MB is a supermicro 2P with opteron 2376 4-core cpus, centos sw raid,
installed C5.3, updated as possible, currently c5.10. 5 seagate 750GB
drives as raid-10 and hot spare.

problem with Brother MFC7460DN

Recently a new installation of Ubuntu 12.04.5 and updates made it
necessary to redo the drivers for this printer/scanner. Plugging in
the usb connecting cable gave immediate recognition that the device
was there, even the serial number was shown in dmesg. Brother's driver
download and install did a successful test print.

The scanner driver that was part of that install has given a situation
where I can not insert (in LO) an image from the device - just blows
up. Likewise xsane doesn't find the device.

WARNING: No module xenblk found for kernel

ran routine updates on the lernel this morning and got this:

WARNING: No module xenblk found for kernel 2.6.18-400.1.1.el5,
continuing anyway

The only references I can find are a year or so old. Anyone able to
comment? or refer me? Have not rebooted.

uname -a
Linux bulkley.bvserver.ca 2.6.18-400.el5xen #1 SMP Thu Dec 4 13:29:23
EST 2014 x86_64 x86_64 x86_64 GNU/Linux

Thanks,

Dave