DevHeads.net

Postings by Gregory P. Ennis

Centos 7.5 - Gnome3 - KVM - Keypad numeric failure

Everyone,

I have a problem with the numeric keypad while using a Centos 7.5 new
installation with kvm.

When I login to the host machine using gnome3 or classic gnome the
numeric keypad does not function. If I activate another 7.5 guest
machine with gnome3 the numeric keypad on the guest does not work
either.

kvm & keypad on Centos 7.5

Everyone,

I have a lab computer I am using to test kvm. It was difficult to
install with NetworkManager running. After I turned nm off I got the
bridge to work and to stay in place. NetworkManager kept chaning
things.

I have several things I would like to learn and to tweak with KVM and
virtal machines.

The first small tweak is how to turn on the keypad on a keyboard. I
have tried two logitech keyboards and both fail to allow the use of the
keypad on the guest. On the host it works fine.

kvm & permission denied

Everyone,

I am trying to install KVM on a desktop unit as a lab project with the
hope of being able to use kvm on one of our office servers after I
learn how. So far I am very low on the learning curve.

I have used the guide to make the installation :

<a href="https://www.linuxtechi.com/install-kvm-hypervisor-on-centos-7-and-rhel-" title="https://www.linuxtechi.com/install-kvm-hypervisor-on-centos-7-and-rhel-">https://www.linuxtechi.com/install-kvm-hypervisor-on-centos-7-and-rhel-</a>
7/

The installation seemed to go well, but when I tried to add Fedora 27
with virt-manager I have continued to get file permission errors.

Centos 7.5 and Courier 10 Pitch fonts in Libreoffice

Everyone,

With the update to Centos 7.5 it is apparent that we lost the Courier
10 Pitch fonts that were in "xorg-x11-fonts-Type1". Does anyone know
how to get this back.

Greg Ennis

VGA connectors fail to work with i915 & 3.10.0-693.21.1.el7.x86_64 kernel

Everyone,

A while back I reported problems with the Intell i915 video driver in
an ASUS mother board. I never found a solution, but did find a work
around.

Ubiquiti Model UAP-AC-PRO

Everyone,

Have any of you installed ubiguiti wireless routers on your network?

It looks like the setup requires the use of software; they have some
packages that are ready made for Ubuntu and Debian, but not RedHat

<a href="https://www.ubnt.com/download/unifi/unifi-ap-ac-pro" title="https://www.ubnt.com/download/unifi/unifi-ap-ac-pro">https://www.ubnt.com/download/unifi/unifi-ap-ac-pro</a>

Have any of you tried or succeeded in installation this on Centos 7.4?

Greg Ennis

Bug in gnome-control-center and network edit module in Centos 7.4

Everyone,

I have been having a problem in setting up gateway/routers with Centos
7.4 machine and finally figured out the problem today. I am not sure
if this bug occurred first in 7.3 but it is definitely in 7.4.

Broadcom BCM4360

Everyone,

I just purchased a new wfi card that is identified as using lspci as :
Broadcom Limited BCM4360 802.11ac Wireless Network Adapter (rev 03)

I have not been able to get it to work Centos 7.4 machine. Some of the
centos user posts had indicated the nux repsitory had a Centos 7 kmod-
wl, but it is not present when I tried to search or or install it at
this time.

Has anyone had any success in making the Broadcom BCM4360 chip work for
Centos 7.4

Greg

Logitech Brio 4K Ultra HD Webcam - 960-001105

Everyone,

I was hoping to be able to plug the Logitech Brio in and have it work,
but it did not. I can have it connect to a Windows 10 laptop and have
it function, so I know the camera works.  

The Centos 7.4 is recognizing it when I plug in the usb 3.0 cable.

Problems with kernel-3.10.0-693.5.2.el7.x86_64

Everyone,

I have two desktop units with : Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz
that do not allow the login screen to appear after the update of :
kernel-3.10.0-693.5.2.el7.x86_64 and kernel-3.10.0-693.2.2.el7.x86_64

Both of these units worked properly with
kernel.x86_64 3.10.0-514.26.2.el7

I am not sufficiently familiar with grub to know if the problem is
related to grub or related to the kernel.

perl-ExtUtils-ParseXS-3.18-3.el7.noarch: [Errno 256] No more mirrors to try

Everyone,

I have had some continued difficulties in getting yum update to
download and update perl-ExtUtils-ParseXS-3.18-3.el7.noarch after the
update from 7.3 to 7.4 on several machines.

denyhosts-2.9-4.el7 not resync'ing

Everyone,

It is apparent that the epel version of denyhosts on Centos 7 which is
denyhosts-2.9-4.el7.noarch does not resynch with :

SYNC_SERVER = <a href="http://xmlrpc.denyhosts.net:9911" title="http://xmlrpc.denyhosts.net:9911">http://xmlrpc.denyhosts.net:9911</a>

According to :

<a href="https://www.centos.org/forums/viewtopic.php?f=51&amp;t=56989" title="https://www.centos.org/forums/viewtopic.php?f=51&amp;t=56989">https://www.centos.org/forums/viewtopic.php?f=51&amp;t=56989</a>

the problem is related to a version update problem in the epel
repositories.

I submitted a bugzilla report :

<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1502251" title="https://bugzilla.redhat.com/show_bug.cgi?id=1502251">https://bugzilla.redhat.com/show_bug.cgi?id=1502251</a>

Greg Ennis

Centos 7.4.1708 dependency problems

Everyone,

I had four Centos 7.4 machines of which I did a manual yum update and
ended up having the same problems on each machine.

It looks like the packages below have dependency problems with the
recent update to : CentOS Linux release 7.4.1708 (Core)

Packages skipped because of dependency problems:
gvfs-1.30.4-3.el7.x86_64 from base
gvfs-afc-1.30.4-3.el7.x86_64 from base
gvfs-afp-1.30.4-3.el7.x86_64 from base
gvfs-archive-1.30.4-3.el7.x86_64 from base
gvfs-client-1.30.4-3.el7.x86_64 from base
gvfs-devel-1.30.4-3.el7.x86_64 from base
gvfs-fuse-1.30.4-3.el7.x86_

selinux denial of cgi script with httpd using ssl

Everyone,

I am trying to use a cgi perl script for a CentOs 7 website that works
fine with selinux in permissive mode but fails with selinux in enforcing
mode.

The problem I have is that I can not find where the selinux error
message is being recorded.

It does not appear to be in the /var/log/messages
or /var/log/audit/audit.log. I do not get
any /var/log/httpd/ssl_error_log entries.

SCSI drives and Centos 7

Everyone,

about 4 years ago, I tried to install CentOS 6 on a Supermicro server
with SCSI drives using a LSI raid system. I could never figure out or
find a way to make the installation disc of Centos 6 identify the SCSI
drives. The installation disc for Centos 5 identified the SCSI drives
without a problem. I finally gave up on Centos 6 and installed Centos 5
and the system has worked very well for the last 4 years

Now that Centos 5 has been retired, I would like to install Centos 7 on
this server. Does the install disc for Centos 7 have the same issues
with SCSI drives as Centos 6?

usb drives & Orico ORICO 9548U3-BK

Everyone,

Is there a way to manually assign usb drives to a specified device
label. Is there a way to force two usb drives to be labeled as
/dev/sdc and /dev/sdd?

I decided to build an archive server for the purpose of backing up
other fedora/centos desktops at the office. I built a machine and have
installed Centos 7.3 on it with all updates current. I also purchased
a 3.0 usb sata drive cabinet (Orico ORICO 9548U3-BK) and installed two
5T black WD drives. There was no problem installing the usb cabinet
or the drives.

dicom viewer for Centos 7 and pacs servers

Everyone,

Have any of you had any luck getting aeskulap to work with Centos7. We
have just migrated some desktops from Fedora 20 to Centos. but aeskulap
is not in the centos 7 repos.

aeskulap was a decent dicom viewer and was able to connect to our pacs
server. If there are other viewers that any of you have used I would be
interested in the dialog of what you have used and any difficulties
related to the installation process and use.

Thanks,

Greg Ennis

Centos 7 dhcpd failure to allow a 2nd network over same interal nic

Everyone,

I am trying to set up a second internal network (192.168.0.0/24) and
have not been able to get dhcp to start when I have the following in my
dhcpd.conf file :

subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.110 192.168.0.130;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option routers 192.168.0.1;
option domain-name-servers 192.168.0.1;
}

When i remove the above from dhcpd.conf dhcpd works perfectly

I have my internal nic card set with two ip addresses one of which is
192.168.0.1.

gmail.com rejection of e-mail on a Centos 6 sendmail server related to reverse ipv6 lookups

Everyone,

I have been working on a gmail.com rejection of mail problem related to
one of our CentOS 6 mail servers, that was not present on our Centos 7
mail server. At first I just routed the transfer of mail to the Centos
7 sever and the problem was solved, but continued working on the Centos
6 sendmail problem when I had time available.

I finally had some time to debug the problem and found some interesting
things that I thought of which others may benefit.

cron job failures with a perl script containing Astro::Time

Everyone,

I am building a gateway server with a new : CentOS Linux release
7.3.1611 (Core)  with 3.10.0-514.2.2.el7.x86_64 kernel.

Everything was going find, but I was not able to get a particular
cronjob to function properly that contained a perl script with
Astro::Time as an include file.

Problem with yum on CentOS Linux release 7.2.1511 (Core) with 3.10.0-327.36.3.el7.x86_64 kernel

Everyone,

I am at a loss on this problem would appreciate some guidance as to
where to start to fix it.

I noticed that my home gateway server was not being updated with the
new kernel and other software, and when I ran yum it aborted with the
following notices. I tried a yum clean all, but this did not fix the
problem. I thought the problem may be related to one of the repos, but
I have other machines in the same network that update properly.

Centos 7.2.1511 with sendmail and a problem with clamav

Everyone,

I am putting together a new CentOS 7 mail server for our organization
and am having some difficulty getting clamav to work with the clamav-
milter for sendmail.

I have set /etc/clamd.d/scan.conf to use clamscan as the user as well
as root as the user and the status command of systemctl results in the
same error messages :

● ... at scan dot service - Generic clamav scanner daemon
   Loaded: loaded (/usr/lib/systemd/system/ ... at scan dot service; enabled;
vendor preset: disabled)
   Active: failed (Result: start-limit) since Thu 2016-09-29 17:53:11
CDT; 1min 38s ago
  Process: 1891 ExecStar

how to force outbound ssh through one network card

Everyone,

I am putting together a new gateway machine that controls all of the
traffic in and out of one of our offices.  We we have a machine with
CentOS Linux release 7.2.1511 (Core)  with 3.10.0-327.10.1.el7.x86_64
kernel which is now equipped with three nic cards.   We decided to
change our internet providers, but unfortunately Comcast would not
allow us to drop there service without some penalties so management
decided to keep the line and not put up a fight.

cups-1.3.7-32.el5_11.x86_64 may have a problem

Everyone,

I have a problem I have been chasing for about three weeks and only
occurred after cups was updated with cups-1.6.3-22.el7. I would be
interested as to whether any one else has had this problem, and would
entertain suggestions as to how I can debug the problem.

My Centos 5 server is a gateway as well as a cups print server that has
been in place for 8 years and has continued to perform exceptionally
well.

My Centos 7 server is a mail server and archive file server that is in
the same network as my Centos 5 server described above.

sendmail tls and oppenssl

Everyone,

Looks like the new version of oppenssl has broken my sendmail's use of
tls. Has anyone else had this problem or seen a fix?

Greg Ennis

Access Problem after update to CentOS 7.1

Everyone,

This morning I did a manual yum update on our a mail server to 7.1
without any incident or problems. A new kernel was installed, and I
rebooted after the update.

When I rebooted the machine I could not gain ssh access to it from an
external ip address. I was able to ssh to this mail server through a
different machine on the local network.

At first I thought the problem was related to the firewall. I stopped
firewalld, and fail2ban, and clear all firewall rules without being able
to gain access.

I disabled firewalld, and fail2ban.

Centos 7.0 and mismatched swap file

Everyone,

I am putting together a new mail server for our firm using a SuperMicro
with Centos 7.0. When performed the install of the os, I put 16 gigs of
memory in the wrong slots on the mother board which caused the
SuperMicro to recognize 8 gigs instead of 16 gigs. When I installed
Centos 7.0, this error made the swap file 8070 megs instead of what I
would have expected to be a over 16000 megs.

I am using the default xfs file system on the other partitions. Is
there a way to expand the swap file?

Centos 7.0 and mismatched swap file

Everyone,

I am putting together a new mail server for our firm using a SuperMicro
with Centos 7.0. When performed the install of the os, I put 16 gigs of
memory in the wrong slots on the mother board which caused the
SuperMicro to recognize 8 gigs instead of 16 gigs. When I installed
Centos 7.0, this error made the swap file 8070 megs instead of what I
would have expected to be a over 16000 megs.

I am using the default xfs file system on the other partitions. Is
there a way to expand the swap file?

CentOs 7.0 and reboot failure

Everyone,

I have installed Centos 7.0 on my homework machine in order to take a
test drive with it, and am low on the learning curve with it at this
point. I have a small Gateway SX2855-UB12P.

I have a critical hurdle in that when I try a reboot or when I do a
'shutdown now -r' command the system will start a reboot process but
hangs right after the os choices are presented.

My install process started with the server version, and I added the
gnome desktop latter. I also changed the boot level to 5.

Mail Merge data to a pdf file by overlaying the data on the image

Everyone,

I am looking for a utility that I can use to do a mail merge of data to
a pdf image file. The image file does not have any active fields, but
will be just an image file. I would like to overlay names addresses
etc.

We currently do this with a pcl file by just overlaying the data with
pcl print positions. However, in order to get the pcl file from an
original pdf file we have to use gimp to convert the pdf to pcl file,
and we always lose a little resolution.