DevHeads.net

Postings by Paul Gardiner

gitweb permission problems with new install

openSUSE Leap 42.3, Apache 2.4.23:
I have gitweb working just fine.

openSUSE Leap 15.0, Apache 2.4.33:
gitweb cannot access my git repository
Shows error: "gitweb.cgi: Can't opendir(/export/git): Permission
denied: /usr/share/gitweb/gitweb.cgi"

I've searched through the apache config and can find no differences,
other than on 42.3 user wwwrun has group www, whereas on 15.0 it has
group wwwrun and is also a member of www. /export/git has group www.
I've tried changing it to wwwrun.

.php3 files recognised but .php files not

I have just installed openSUSE Leap 15.0 on a server including Apache
2.4.33 and php 7.2.5.

If I attempt to access .php files, I'm offered them as downloads,
although renaming them to .php3 makes them work fine.

I've done something that's causing email to be thrown away.

Hi,

I've been running postfix under SuSE now for several years. I keep
up to date with SuSE by every now and then moving everything across
to a newly installed machine (git repository for config, and rsync
for data). This time something has gone wrong which prevents
fetchmail sending to postfix.