DevHeads.net

Postings by =?ISO-8859-1?Q?V=EDt_Ondruch?=

Vagrant dependencies updated in Rawhide

Hi Vagrant users,

If you are using Vagrant together with libvirt backend (default on
Fedora), please be warned that today, I have updated fog-libvirt
(dependency of vagrant-libvrit) and its dependencies in Rawhide. Because
fog upstream is currently a bit of a mess, where some major
sub-components are not compatible between each other, it might be that I
missed something and Vagrant might not work for you anymore.

fedora-package purpose and future

Hi,

I am wondering what is the purpose of fedora-packager package and what
is its future? It seems to be abandoned upstream as well as in Fedora
[1, 2, 3, 4]. This is a bit unfortunate considering this is package
every Fedora packager has to have installed. Is there a chance to give
that package a bit of love?

Unannounced soname bump in libevent

It appears that yesterday build of libevent bumped its soname. That
means that, at minimum, Memcahed is broken now.

BTW it is well possible, that the packager did not noticed the soname
bump, since the libraries are included into package by wildcards in
files section [1].

rubygem-file-tail license change

rubygem-file-tail-1.2.0-1.fc28 changed license from:

GPLv2

to:

ASL 2.0

Vít

Which Fedora/EPEL is targeted by packaging guidelines?

Hi all,

Reading logs from yesterdays FPC meeting [1], I think we should discuss
what is actually purpose of packaging guidelines and which version of
Fedora/EPEL/RHEL they actually targets.

Apparently, there are two camps of packagers in Fedora/EPEL. Those who want:

1) single version of .spec file to cover the whole Red Hat ecosystem.

2) clean .spec file following the latest and greatest packaging practices.

I personally belong to the group (2) and that is for several reasons:

a) I use Rawhide on daily basis and I develop only for Rawhide.

Orphaning rubygem-logging

Hi all,

I don't have any use for rubygem-logging, so I orphaned the package.

Vít

Returned mail: see transcript for details

The original message was received at Thu, 20 Jul 2017 14:08:41 +0800
from redhat.com [134.0.186.81]

< ... at lists dot fedoraproject.org>

Returned mail: see transcript for details

The original message was received at Thu, 20 Jul 2017 14:08:41 +0800
from redhat.com [134.0.186.81]

< ... at lists dot fedoraproject.org>

Returned mail: see transcript for details

The original message was received at Thu, 20 Jul 2017 14:08:41 +0800
from redhat.com [134.0.186.81]

< ... at lists dot fedoraproject.org>

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

Orphaning rubygem-haml-rails

Hi all,

I don't have any use for rubygem-haml-rails, so I orphaned the package.

Vít

un-retire rubygem-factory_girl

Hi,

rubygem-factory_girl was retired during march since it was orphaned for
some while. I did not picked it up at that time, since nothing was using
it. Now I discovered that it would be handy to have it in Fedora to be
able to execute test suite of rubygem-cucumber-rails. Hence I inted to
un-retire it. Here is the re-review request:

<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1470580" title="https://bugzilla.redhat.com/show_bug.cgi?id=1470580">https://bugzilla.redhat.com/show_bug.cgi?id=1470580</a>

Thx

Vít

rubygem-trollop license changed to "MIT"

rubygem-trollop-2.1.2-1.fc27 changed its license from "same terms as
Ruby" to "MIT"

<a href="https://github.com/ManageIQ/trollop/issues/47" title="https://github.com/ManageIQ/trollop/issues/47">https://github.com/ManageIQ/trollop/issues/47</a>

Vít

Orphaning rubygem-ruby-ole

Hi all,

I don't have any use for rubygem-ruby-ole, so I orphaned the package.

Vít

Orphaning rubygem-configuration

Hi all,

I have orphaned rubygem-configuration in F26+.

This package was previously required by rubygem-launchy, but it is not
needed anymore. Therefore I orphaned F26+, but keep the F2{4,5} till
their EOL. Feel free to pick the package if you have any use for it or
let it be garbage collected, since the upstream seems to be abandoned
anyway.

Vít

fprintd-pam update vs "authconfig --update"

Hi,

Please be careful with fprintd-pam update.

Please test Vagrant 1.9.1

Hi everybody,

I spent last few days updating Vagrant in Rawhide.

Orphaning rubygem-logging

Hi,

I just updated and fixed rubygem-logging, but since I have no use for
this package, I just orphaned it in PkgDb. Feel free to pick it up or
let it go away ...

Vít

Orphaning rubygem-linode

Hi,

I just updated and fixed rubygem-linode, but since I have no use for
this package, I just orphaned it in PkgDb. Feel free to pick it up or
let it go away ...

Vít

rubygem-diff-lcs license changed to GPLv2+ or Artistic or MIT

rubygem-diff-lcs-1.3-1.fc26 simplified its license to GPLv2+ or Artistic
or MIT.

Vít

Ruby packages free to grap

Hi all,

Michal Fojtík recently orphaned all his packages due to lack of the
resources to maintain them properly (thans to taking care of them).

mutter broken in Rawhide

To all Rawhide users, be careful with update of mutter. It seems that
mutter-3.23.2-2.fc26 is broken [1], which prevents you from log in to
your system. Downgrade to mutter-3.23.1-2.fc26.x86_64 workarounded the
issues for me.

Vít

[1] <a href="https://bugzilla.redhat.com/show_bug.cgi?id=1401317" title="https://bugzilla.redhat.com/show_bug.cgi?id=1401317">https://bugzilla.redhat.com/show_bug.cgi?id=1401317</a>

rubygem-hashery license changed to BSD

rubygem-hashery-2.1.2-1.fc26 changed it's license from MIT to BSD.

Vít

rubygem-launchy license change to ISC

rubygem-launchy-2.4.3-1.fc26 changed it's license from BSD to ISC.

Vít

rpm vs --compress-debug-sections=zlib

Hi,

Recently, there have started to appear weird messages in the build
output of development snapshot of Ruby [1]:

```

... snip ...

+ /usr/lib/rpm/find-debuginfo.sh --strict-build-id -m --run-dwz
--dwz-low-mem-die-limit 10000000 --dwz-max-die-limit 110000000
/builddir/build/BUILD/ruby-2.4.0-r56693

...

Orphaning rubygem-heroku{,-api}

Hi,

I am orphaning rubygem-heroku{,-api} since I was never really user of
these. Moreover, there packages are deprecated already and Heroku is
going to sunset the Heroku v2 API as well as these packages on April 15,
2017 [1].

Vít

[1] <a href="https://devcenter.heroku.com/changelog-items/862" title="https://devcenter.heroku.com/changelog-items/862">https://devcenter.heroku.com/changelog-items/862</a>

vim plugins don't need %post{,un} scriptlets anymore

Hi,

Just a short note to all vim plugins maintainers. Yesterday, I added
%transfiletriggerin and %transfiletriggerpostun triggers into vim
package [1, 2], therefore you can safely remove your %post{,un}
scriptlets, which you used to refresh the documentation.

Bodhi For Rawhide?

Hi all,

I am thinking, why we don't have enabled Bodhi for Rawhide? I know that
you might think now that I went nut and it is bureaucracy, but let me
explain.

If I understand it correctly, during several past years, our build
process was more streamlined and we are trying to do the Rawhide
composes in a similar fashion we are doing stable releases. But for some
reason, we are still not using Bodhi for Rawhide and I see no reasons
not to use it.

rubygem-fog license corrected

In F26, the rubygem-fog license declaration was changed from "MIT" to
"MIT or ASL 2.0".

Vít

jQuery

Hi,

Is there chance that somebody more familiar with JS than me would update
jQuery in Fedora? It would be nice to have jQuery 3.x as well. Or should
I do the update myself?

I am asking since I need to update rubygem-jquery-rails, which requires
the recent versions of jQuery (and it will require jQuery3 pretty soon).
Or should I bundle again? That would make my life a lot easier ...

Vít

Unannounced soname bump - userspace-rcu

It seems there was unannounced soname bump in userspace-rcu. Not sure
what everything needs to get rebuild, but it seems that lttng-ust at
minimum (and there is already rhbz#1348895).

Vít