DevHeads.net

Postings by Mat Booth

ICU4J License Change notification

ICU4J is now covered by the Unicode License (with MIT and BSD licensed
contributed parts.)

The Unicode license is very similar to the previous MIT-style ICU license.

License change notification for Eclipse Plugins

Some Eclipse Foundation plug-ins have already made the switch from EPL to
EPL-2.0 and I have updated the licence field in the corresponding Rawhide
RPMs where I am aware of the change.

I expect that most plug-ins from the Foundation and the Eclipse Platform
itself will make the switch over the coming year. I don't plan to announce
each change individually so if you are interested in Eclipse Platform or
plug-in licensing, please pay special attention going forward.

Thanks

Intent to retire recordmydesktop

Hi all,

The venerable "recordmydesktop" application does not work with Wayland and
stopped working out-of-the-box when Wayland was made default.

Project is long since abandoned upstream, is riddled with crash bugs, and
my own personal use of this project ceased when gnome-shell grew good
built-in screencast recording functionality.

I plan to retire this package from Fedora shortly.

mchange-commons and c3p0 licence change notification

The mchange-commons and c3p0 packages have changed from:

LGPLv2

to a dual licence:

LGPLv2 or EPL

libservicelog-0:1.0.1-3.fc12 in Rawhide

The package libservicelog looks like it has not been built since Fedora 12:

<a href="http://koji.fedoraproject.org/koji/packageinfo?packageID=7900" title="http://koji.fedoraproject.org/koji/packageinfo?packageID=7900">http://koji.fedoraproject.org/koji/packageinfo?packageID=7900</a>

Yet it is still included in rawhide:

[mbooth@10-2-5-11 repo_test_area]$ repoquery --repoid=rawhide libservicelog\*
libservicelog-0:1.0.1-3.fc12.i686
libservicelog-0:1.0.1-3.fc12.x86_64
libservicelog-devel-0:1.0.1-3.fc12.i686
libservicelog-devel-0:1.0.1-3.fc12.x86_64

Looking at source control:
<a href="http://pkgs.fedoraproject.org/cgit/libservicelog.git/log/" title="http://pkgs.fedoraproject.org/cgit/libservicelog.git/log/">http://pkgs.fedoraproject.org/cgit/libservicelog.git/log/</a>

It looks like it should have been a part of the last few mass
rebuilds, but it doesn't appear that a buil

Problem with Bodhi not pushing to stable F15 after 7 days

Hi,

I've just tried to push an update to F15 stable that has been in
testing for more than 7 days, and it doesn't seem to work. You can see
the time released versus the time in the top right of this screenshot:

<a href="http://mbooth.fedorapeople.org/bodhi.png" title="http://mbooth.fedorapeople.org/bodhi.png">http://mbooth.fedorapeople.org/bodhi.png</a>

I clicked "mark as stable" and received that error message. Am I doing
something wrong?

Mat

Java Bindings for libnotify

Hi all,

I can't find the Java bindings for libnotify -- I thought they would
be in libgnome-java, but I guess not.

So a couple of questions for the Gnome Desktop team:

And are there plans to package java-gnome?

If not and I were to package it myself, should java-gnome obsolete
libgnome-java?

libgnome-java entirely.

Thanks for any insight.
Mat

POSTUN scriptlet failure in rpm package cyrus-sasl

Saw this in today's updates:

Cleanup : cyrus-sasl-2.1.23-4.fc12.i686
195/254
groupdel: group 'saslauth' does not exist
Non-fatal POSTUN scriptlet failure in rpm package cyrus-sasl
warning: %postun(cyrus-sasl-2.1.23-4.fc12.i686) scriptlet failed, exit status 6

This looks benign, but I suppose it could check if the group exists
before attempting to delete it.

F11 Bind Updates

Updating my F11 box today and found this in the console:

Cleanup : 32:bind-libs-9.6.1-3.fc11.x86_64
27/28
/sbin/ldconfig: relative path `1' used to build cache
Non-fatal POSTUN scriptlet failure in rpm package b
Cleanup : gvfs-gphoto2-1.2.3-7.fc11.x86_64
28/28
warning: %postun(bind-libs-32:9.6.1-3.fc11.x86_64) scriptlet failed,
exit status 1

Will this have broken anything and do I need to perform any steps to
recover from this error? It looks benign, but I'd like to make sure.

3Dsee.net java applet crashes firefox

I get an intermittant segfault in Firefox [1] when viewing the items
in the gallery over at <a href="http://3dsee.net/Gallery" title="http://3dsee.net/Gallery">http://3dsee.net/Gallery</a> (once even trashing
the display and locking the machine up solid).

Should I report this against Firefox or Java?

I have the following installed:

java-1.5.0-gcj.x86_64 1.5.0.0-28.fc11
java-1.6.0-openjdk.x86_64 1:1.6.0.0-22.b16.fc11
java-1.6.0-openjdk-plugin.x86_64 1:1.6.0.0-22.b16.fc11
firefox.x86_64 3.5-1.fc11

[1] Running firefox from the t

Segfault connecting to a VPN through NetworkManager

Hi,

I got this segfault trying to connect to the Microsoft VPN at work. [1]

What should I raise a ticket against? NetworkManager, kernel, pptp,
none of the above?

[1] <a href="http://mbooth.fedorapeople.org/vpn-bug.txt" title="http://mbooth.fedorapeople.org/vpn-bug.txt">http://mbooth.fedorapeople.org/vpn-bug.txt</a>

Audio profile configuration from pavucontrol

Hi all,

Remember the configuration tab from the old pavucontrol?

<a href="http://mbooth.fedorapeople.org/misc/pavucontrol.png" title="http://mbooth.fedorapeople.org/misc/pavucontrol.png">http://mbooth.fedorapeople.org/misc/pavucontrol.png</a>

I use it to switch to digital output on my sound blaster card. Now
that we don't install pavucontrol by default, is there anywhere else I
can enable digital output from? Or is it a case of yum install
pavucontrol until this gets integrated into the new gnome sound
preferences dialog?

Thanks,
Mat

Adobe Releases 64bit Flash Plugin for Linux

FYI

<a href="http://blogs.adobe.com/penguin.swf/2008/11/now_supporting_16_exabytes.html" title="http://blogs.adobe.com/penguin.swf/2008/11/now_supporting_16_exabytes.html">http://blogs.adobe.com/penguin.swf/2008/11/now_supporting_16_exabytes.html</a>