DevHeads.net

Postings by Julian Sikorski

how to track downstream these days

Hi list,

how does one track downstream packages these days?

referenced in section, defined in discarded section linking failure

Hi list,

latest F28 mame build [1] has failed at the linking stage on x86_64 only
with the following error:

`_ZSt20__replacement_assertPKciS0_S0__end' referenced in section
`.gnu.build.attributes' of
../../../../linux_gcc/bin/x64/Release/mame_mame/libsega.a(model1.o):
defined in discarded section
`.text._ZSt20__replacement_assertPKciS0_S0_[_ZSt20__replacement_assertPKciS0_S0_]'
of ../../../../linux_gcc/bin/x64/Release/mame_mame/libsega.a(model1.o)

Strangely enough, the same build has succeeded on rawhide [2].

mame build OOMs on f24 and f25 i686, succeeds on other arches and branches

Hi list,

I have updated mame packages to 0.186 yesterday. The package built fine
on rawhide [1] and f26 [2], as well as on non-i686 on f25 and f24.

packaging work is becoming increasingly cumbersome

Hi list,

I have been co-maintaining goffice and gnumeric for a while now. It has
been unfortunately becoming increasingly difficult over time, given the
fact that the two often need to be chain-built and tools needed to do
this have been slowly becoming more time-consuming to use, in addition
to some other issues. For example:

- requesting buildroot overrides via commandline has been broken for
over than a year now and will not be fixed until f26 [1].

failed to load external entity "http://www.oasis-open.org/docbook/xmlcharent/0.3/iso-pub.ent"

Hi list,

the latest gnumeric seems to require internet access to build its
documentation. I am getting the following error [1] [2]:

failed to load external entity
"http://www.oasis-open.org/docbook/xmlcharent/0.3/iso-pub.ent

The build works fine in mock, but it is probably because mock has access
to internet while koji does not. Has anybody experienced something like
this, respectively knows how this can be fixed?

gcc-4.8: error: invalid use of undefined type

Hi,

I am having issues building mplayer using gcc-4.8. An updated srpm [1]
builds fine in mock for fedora-18-x86_64-rpmfusion_free target (when
chain-built with ffmpeg-1.1.1), but on
fedora-rawhide-x86_64-rpmfusion_free, it fails with the following error:

libvo/vo_png.c: In function 'config':
libvo/vo_png.c:135:9: error: invalid use of undefined type 'enum
AVPixelFormat'
avctx->pix_fmt = imgfmt2pixfmt(format);
^

Full build log is attached. How do I fix this issue?

rpm handling of new library symbols

Hi list,

a bug was recently filed against gnumeric [1], in which the program
refused to run due to user not having updated his whole package set and
a symbol being missing in the older libgsf he had installed.
How are such issues supposed to be handled? Surely, manually introducing
a versioned dependency for every library is going to be painful. Given
that soname bump is required only for symbols removal/change, is it that
if someone cherry-picks updates, then he/she keeps all the pieces in
case something breaks?

pulseaudio maintainership status

Dear list, Dear Lennart,

a week ago I have submitted a pulseaudio bug alongside with the patch
[1]. There was no response so far.
Knowing that Lennart is busy with systemd these days, I proceeded to
check the pkgdb status of pulseaudio. The only other maintainer with
commit access is lkundrak, who has been declared non-responsive a while
ago himself, plus 3 request pending.
To have such a critical subsystem barely maintained does not seem
sustainable. I have already stepped up to co-maintain pavucontrol and
paprefs, but PA proper is a whole other level.

monitoring the memory usage of a build process

Hi,

I was wondering if it was possible to monitor the maximum and/or average
memory usage of a mock build process. I am trying to investigate why a
package takes less 2 hours to build on F16/F17, 24 hours on F18 and 7
hours on rawhide:
<a href="https://bugzilla.rpmfusion.org/show_bug.cgi?id=2554" title="https://bugzilla.rpmfusion.org/show_bug.cgi?id=2554">https://bugzilla.rpmfusion.org/show_bug.cgi?id=2554</a>

Regards,
Julian

Nonresponsive maintainer: bogado

Hi list,

I have been unsuccessful in trying to contact Victor Bogado:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=770887" title="https://bugzilla.redhat.com/show_bug.cgi?id=770887">https://bugzilla.redhat.com/show_bug.cgi?id=770887</a>
Old raw-thumbnailer is not only non-functional, but also blocks
goffice/gnumeric/gnome-chemistry-utils progress.

Best regards,
Julian

replacing folders with symlinks leads to rpm cpio rename errors

Hi list,

one of the updates I am preparing is supposed to replace some of the
folders with symlinks. Unfortunately, this leads to rpm cpio: rename
errors upon an update attempt. Is there a standard way of dealing with this?

Regards,
Julian

Heads-up: Twisted-12.2.0 landing in rawhide; pseudo-orphaning the package

Dear all,

I have just submitted python-twisted* 12.2.0 builds for rawhide. Please
check if everything still works as intended.
Having said that, with this update I will no longer be co-maintaning the
stack.

Heads-up: Twisted-12.1.0 landing in rawhide

Dear all,

I have just submitted python-twisted* 12.1.0 builds for rawhide. Please
check if everything still works as intended.

Regards,
Julian

Does anyone know what is up with nushio?

Hello,

nushio, the rabbitvcs maintainer has not been answering one of his bug
reports [1]. I have prepared an updated package that works with the new
nautilus, but is still has not been committed.
Does anyone know what the deal is? Has nushio left the project and
should his packages thus be orphaned? Or is he just busy with real life
and then I would kindly ask one of the provenpackagers to commit my changes.

Regards,
Julian

[1] <a href="https://bugzilla.redhat.com/show_bug.cgi?id=760682" title="https://bugzilla.redhat.com/show_bug.cgi?id=760682">https://bugzilla.redhat.com/show_bug.cgi?id=760682</a>

mouse ceased to work for an F-17 VM guest

Hi,

I am running an F-17 x86_64 guest on an F-16 x86_64 host here. I have
realised that mouse input is not working anymore since a few days.
I have tried
# yum downgrade xorg-x11-*
in the guest so far, but this did not help. Any ideas where to look
next, or how to take a more educated approach to the problem? Thanks for
the info in advance.

Cheers,
Julian

JPEG_LIB_VERSION in libjpeg-turbo

Dear fellow Fedora packagers

I was trying to get MAME [1] to use system libjpeg [2]. The problem is
that MAME needs jpeg_mem_src, which is only defined if libjpeg-turbo
compiled with --with-jpeg8 switch, which is not the case for the Fedora
package.
Would such change be feasible to introduce? If not, I assume that I have
no other choice as to use the bundled copy (not really relevant here
since MAME is an RPM Fusion package). Thank you for the input in advance.

Regards,
Julian

[1] <a href="http://mamedev.org/" title="http://mamedev.org/">http://mamedev.org/</a>
[2] <a href="http://forums.bannister.org/ubbthreads.php?ubb=showflat&amp;Number=77445" title="http://forums.bannister.org/ubbthreads.php?ubb=showflat&amp;Number=77445">http://forums.bannister.org/ubbthreads.php?ubb=showflat&amp;Number=77445</a>

Heads-up: Twisted-12.0.0 landing in rawhide

Dear all,

I have just built python-twisted* 12.0.0 for rawhide. Please check if
everything still works as intended.

Regards,
Julian

gcc-4.7 linking failure: undefined reference to foo

Hi,

I was trying to build mame (an rpmfusion package) with gcc-4.7.

telepathy sunshine

Dear list,

I would like to announce that I will be orphaning, and possibly
retiring, telepathy-sunshine.

updating goffice to 0.9.0

Dear Fedorians,

goffice-0.9.0 was released recently, along with new gnumeric [1,2]. What
is your opinion on pushing the update to rawhide ASAP? To the best of my
knowledge stable goffice 0.10 and gnumeric 1.12 should be out by the
time Fedora 17 ships, so putting this into rawhide now would allow for
plenty of time to iron out any potential problems.

Twisted 11.1.0 about to hit rawhide

Hi,

I have just kicked off a build of twisted 11.1.0. Please check if
everything still works as expected. Should that not be the case, there
is plenty of time until Fedora 17 release to iron things out.

Regards,
Julian

evolution-ews rpm package

Dear all,

I have a working package of evolution-ews (Exchange Web Services client
for evolution). If there is demand, I can put it up for review, but
co-maintainers are welcome.

Regards,
Julian

review swap

Hi,

I would be willing to swap a review of gmtk [1] in rpmfusion for another
review, be it RPM Fusion or Fedora, preferably not something overly
complex. Feel free to contact me if you are interested.

Cheers,
Julian

[1] <a href="https://bugzilla.rpmfusion.org/show_bug.cgi?id=1958" title="https://bugzilla.rpmfusion.org/show_bug.cgi?id=1958">https://bugzilla.rpmfusion.org/show_bug.cgi?id=1958</a>

rpaths strike again, please add checker to koji/mock

Hi,

currently the existence of RPATHS is only checked when one does a local
rpm build. mock and koji still let it slide.

updating twisted to 11.0.0

Hi list,

I will try to update python-twisted stack to 11.0.0 over easter, rawhide
only. This should leave plenty of time to deal with fallout, if any.

Cheers,
Julian

packages moving from gconf to gsettings

Dear List,

I was just trying to update gnome-mplayer (not in fedora, but that is
irrelevant) which migrated from gconf to gsettings. The problem is, that
the standard scriptlets [1] do not run on upgrades, leaving the package
in a not working state (not running even).
I think it would be good to establish some guidelines to handle such
cases, since packages moving from gconf to gsettings are likely to
become more and more common.

Cheers,
Julian

[1]
<a href="http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#GSettings_Schema" title="http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#GSettings_Schema">http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#GSettings_Schema</a>

gcc 4.6 for package monkeys

Hi,

I have just run into an issue with gcc-4.6, namely RPM Fusion's mame
failed to compile [1]. I was told that #include <stddef.h> was missing.
So I have two questions: why did including this header directly became
necessary (code builds fine with 4.5) and are there any other issues we
package monkeys might run into with a new compiler?
Thanks in advance.

Cheers,
Julian

Updating twisted to 10.2.0

Dear all,

I am about to update the twisted stack to 10.2.0 so that any potential
issues can be ironed out by Fedora 15 release. Please test if your
packages still function as expected.
Release notes are available here:
<a href="http://twistedmatrix.com/trac/browser/tags/releases/twisted-10.2.0/NEWS?format=raw" title="http://twistedmatrix.com/trac/browser/tags/releases/twisted-10.2.0/NEWS?format=raw">http://twistedmatrix.com/trac/browser/tags/releases/twisted-10.2.0/NEWS?...</a>

Cheers,
Julian

proventester needed: libgsf-1.14.18-1.fc13

Dear proventesters,

please add karma to
<a href="https://admin.fedoraproject.org/updates/libgsf-1.14.18-1.fc13" title="https://admin.fedoraproject.org/updates/libgsf-1.14.18-1.fc13">https://admin.fedoraproject.org/updates/libgsf-1.14.18-1.fc13</a>
This should be relatively harmless, as there was only one fix in the
upstream code since 1.14.17: fix of writing compressed files.

Julian

proventester needed: libgsf-1.14.18-1.fc13

Dear proventesters,

please add karma to
<a href="https://admin.fedoraproject.org/updates/libgsf-1.14.18-1.fc13" title="https://admin.fedoraproject.org/updates/libgsf-1.14.18-1.fc13">https://admin.fedoraproject.org/updates/libgsf-1.14.18-1.fc13</a>
This should be relatively harmless, as there was only one fix in the
upstream code since 1.14.17: fix of writing compressed files.

Julian