DevHeads.net

Postings by TASAKA Mamoru

Unexpected libldb soname bump resulting in Fedora 31 live breakage

So it seems that all of a sudden libldb was upgraded to 2.0.5 on
rawhide and F-31 yesterday which includes soname bump:

<a href="https://koji.fedoraproject.org/koji/buildinfo?buildID=1364218" title="https://koji.fedoraproject.org/koji/buildinfo?buildID=1364218">https://koji.fedoraproject.org/koji/buildinfo?buildID=1364218</a>

and as a result _all_ F-31 live image of Fedora-31-20190827.n.0 failed to
be created due to sssd dependency breakage (like Fedora Workstation Live:

<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=37307774" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=37307774">https://koji.fedoraproject.org/koji/taskinfo?taskID=37307774</a>

Then we are now under Beta Freeze...

oniguruma 6.8.1 will hit rawhide and F-28 with soname bump

Hello, all:

I am going to update oniguruma to 6.8.1 on rawhide and F-28.

Request for review swap

Hello, all:

I have one review request for a package for LXDE:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1409243" title="https://bugzilla.redhat.com/show_bug.cgi?id=1409243">https://bugzilla.redhat.com/show_bug.cgi?id=1409243</a> lxhotkey

Review swap is appreciated.

Regards,
Mamoru

oniguruma 6.1.1 push on rawhide, with soname bump

I will upgrade oniguruma to 6.1.1.

oniguruma 6 push on rawhide, with soname bump

I will upgrade oniguruma to 6.0.0. This includes libonig.so soname bump.

Packages known to be affected by the above soname bump are:

jq-1.5-3.fc25
kitutuki-0.9.6-11.fc24
lua-rex-2.7.2-10.fc23
mfiler3-4.4.9-10.fc24
mfiler4-1.3.1-5.fc24
ochusha-0.6.0.1-0.14.cvs20100817T0000.fc24.1.4
oniguruma-5.9.6-3.fc24
saphire-3.6.5-8.fc24
slang-2.3.0-5.fc24
xyzsh-1.5.8-5.fc24

I will submit rebuild for all the above packages even if some packages
are known to fail to build already due to other issues not related to
oniguruma.

Regards,
Mamoru

review swap request

I want to bring back cairo-dock back to Fedora, which was removed on
Feb 2009 from Fedora and need re-review:

<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1178911" title="https://bugzilla.redhat.com/show_bug.cgi?id=1178911">https://bugzilla.redhat.com/show_bug.cgi?id=1178911</a> cairo-dock
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1178912" title="https://bugzilla.redhat.com/show_bug.cgi?id=1178912">https://bugzilla.redhat.com/show_bug.cgi?id=1178912</a> cairo-dock-plug-ins
cairo-dock-plug-ins depends on cairo-dock.

I am happy to review packages in exchange, thank you.

Mamoru

RE: Replies tearing threads apart [Was: %ifarch note]

No, currently I (have to) use a web mail service. When I am back
I can use thunderbird.

Regards,
Mamoru

RE: Koji failure in f19: : tag requiresadmin permission

I guess your build was hit by F-19 alpha change freeze:
<a href="http://lists.fedoraproject.org/pipermail/devel/2013-April/180922.html" title="http://lists.fedoraproject.org/pipermail/devel/2013-April/180922.html">http://lists.fedoraproject.org/pipermail/devel/2013-April/180922.html</a>

You may try tagging your build as f19-candidate.

Review swaps

Hello, all:

I have 6 rubygems related review requests which need reviewers

rubygem-unf_ext - Unicode Normalization Form support
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=892314" title="https://bugzilla.redhat.com/show_bug.cgi?id=892314">https://bugzilla.redhat.com/show_bug.cgi?id=892314</a>

rubygem-unf Wrapper library to bring Unicode Normalization Form support to Ruby/JRuby
(needs rubygem-unf_ext)
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=904639" title="https://bugzilla.redhat.com/show_bug.cgi?id=904639">https://bugzilla.redhat.com/show_bug.cgi?id=904639</a>

rubygem-domain_name - Domain Name manipulation library for Ruby (needs rubygem-unf)
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=904640" title="https://bugzilla.redhat.com/show_bug.cgi?id=904640">https://bugzilla.redhat.com/show_bug.cgi?id=904640</a>

rubygem-gdk3 - Ruby binding of GDK-3.x
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=912960" title="https://bugzilla.redhat.com/show_bug.cgi?id=912960">https://bugzilla.redhat.com/show_bug.cgi?id=912960</a>

rubygem-gtk3 - Ruby binding o

RE: Re: 64-bit stat (or not) in 32-bit Fedora binaries

Well, actually all files except for one file which use stat series include

Newrepo for F-19 hanging?

Can someone investigate F-19 newrepo below?
<a href="http://koji.fedoraproject.org/koji/taskinfo?taskID=4939667" title="http://koji.fedoraproject.org/koji/taskinfo?taskID=4939667">http://koji.fedoraproject.org/koji/taskinfo?taskID=4939667</a>
It seems that this task was created at Fri, 08 Feb 2013 21:00:33 UTC
(more than 17 hours ago) and has not completed yet.

Regards,
Mamoru

review swap: rubygems related packages

Hello, all:

I have some packages related to rubygems ready for review
and I would like to swap reviews.

rubygems 1.8.5 hits rawhide with license change

Hello, all:

Now rawhide buildtree sees rubygems 1.8.5. The license changed from
(Ruby or GPL+) to (Ruby or MIT).

If you see any issues with new rubygems please feel free to report them,
thank you.

Regards,
Mamoru