DevHeads.net

Postings by Robin 'cheese' Lee

iniparser SONAME bump in rawhide

iniparser SONAME version bump from 0 to 1 since 4.1.

All packages depends on iniparser should be rebuilt:
- cava
- spindown
- ubridge

robin

global and global-ctags license tags revised

License tag of global changed from 'GPLv2+ and BSD' to 'GPLv3+ and LGPLv2+
and BSD and GPLv2+ and MIT'

License tag of global-ctags changed from 'GPLv2+ and BSD' to 'GPLv3+'

-robin

python-shadowsocks license changed

python-shadowsocks 2.8.2 license changed from 'MIT' to 'ASL 2.0'

-robin

License of python-nltk-3.0.0 specified to 'ASL 2.0 and GPLv2+ with exceptions'

License of python-nltk-3.0.0 specified from 'ASL 2.0' to 'ASL 2.0 and
GPLv2+ with exceptions'.

-robin

vmpk 0.6.0 license changed to 'GPLv3+'

vmpk 0.6.0 license changed from 'GPLv3+ and (LGPLv2 with exception or
GPLv3)' to 'GPLv3+'.

Cheers
-robin

stardict-3.0.5-1 license revised from 'GPLv3' to 'GPLv3+ and GPLv2+ and CPL'

stardict-3.0.5-1 license revised from 'GPLv3' to 'GPLv3+ and GPLv2+ and CPL'

-robin

cherrytree-0.30.5 license changed from GPLv2+ to GPLv3+

Hi,

cherrytree-0.30.5 license changed from GPLv2+ to GPLv3+

-robin

fcitx-unikey-0.2.2 license tag corrected from GPLv2+ to GPLv3+

The previous version 0.1.1 is already under GPLv3+.

-robin

perl-Net-ARP-1.0.8 license change

perl-Net-ARP-1.0.8 license is changed from 'GPL+ or Artistic' to 'GPLv2'.

-robin

lonote-2.2.1 license changed from 'GPLv3 and ASL 2.0' to 'ASL 2.0'

lonote-2.2.1 license has changed from 'GPLv3 and ASL 2.0' to 'ASL 2.0'.

Cheers
-robin

perl-File-Next 1.12 license corrected to 'Artistic 2.0'

Upstream has mis-matched licensing in Makefile.PL and in the source code. I
corrected the License in specfile following the source code.

robin

'newpackager' is not in FAS, or How to co-maintain a package before getting sponsored

Hi, all

I want to follow the route [1] to bring up a new packager. But when I try
to approve commit privilege for him, pkgdb says:
"... must be in one of these groups: ('cvsadmin', 'packager',
'provenpackager', 'newpackager') to hold the commit acl"

I think he should join the 'newpackager' FAS group first, but the group is
not existing in FAS.

Or candidate packager would not get commit privilege until actually
sponsored?

[1]
<a href="https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group#Become_a_co-maintainer" title="https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group#Become_a_co-maintainer">https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_gr...</a>

Cheers,
robin

Shutter license changed to GPLv3+

Shutter license changed to GPLv3+

Review swap for a simple Perl module required by Shutter update

Hi.

The link is : <a href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=832353perl-Net-Dropbox-API" title="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=832353perl-Net-Dropbox-API">https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=832353perl-Net-Drop...</a>

I can review a package in C/C++, Perl or Python.

robin

Unretired pcmanx-gtk2 is blocked

Hello!

I just have pcmanx-gtk2 unretired, but Koji says it is blocked for the
unretired f17 branch and newly created f16 branch:

Building pcmanx-gtk2-1.0-1.fc17 for f17-candidate
Created task: 3649895
Task info: <a href="http://koji.fedoraproject.org/koji/taskinfo?taskID=3649895" title="http://koji.fedoraproject.org/koji/taskinfo?taskID=3649895">http://koji.fedoraproject.org/koji/taskinfo?taskID=3649895</a>

...........

0 free 1 open 1 done 0 failed
3649895 build (f17-candidate,
/pcmanx-gtk2:d1762747b55dfd3607e30858da1691284d2025b6): open (
x86-04.phx2.fedoraproject.org) -> FAILED: BuildError: package pcmanx-gtk2
is blocked for tag f17
0 free 0 open 1 done 1 failed

3649895 build (f17-candidate,
/pcmanx-gtk2:d1762747

ack license changed from 'GPL+ or Artistic' to 'Artistic 2.0'

License was actually changed at upstream 1.90 release.

robin

kde-partitionmanager orphaned

kde-partitionmanager doesn't build with parted 3.0. And upstream seems far
away from a new release.

Sincerely,
robin

Orphaned python-alsa

Not required by any package other than alsa-tools.

Cheers
Robin