DevHeads.net

Postings by Athmane Madjoudj

Orphaning python-sysv_ipc

Hi

I've orphaned python-sysv_ipc since I'm not using it anymore.

Best regards.

- Athmane

HEADS-UP: [rawhide] Fabric API change

Hello,

I've updated Fabric to 2.0 in rawhide which finally bring python3
compatibility, however the APi has been heavily changed, so any
application that depended on Fabric need porting (only Avocado
Framework atm).

Fabric 2 has been provided in different namespace, in order to keep
Fabric 1.x-compatible fork "Fabric3" as default provider, this will
change once the dependencies are ported.

Best regards.

- Athmane

Orphening ncftp

Hello,

I'm planing to orphan ncftp, since the new version did not include
IPv6 support (patch from OpenBSD) [1], plus I'm not using it anymore.

NB. scripts using ncftp for mirroring can be switched to lftp, which
includes similar features and more.

Best regards.

[1] <a href="http://openbsd-archive.7691.n7.nabble.com/Update-net-ncftp-3-2-6-drop-IPv6-patch-td319222.html" title="http://openbsd-archive.7691.n7.nabble.com/Update-net-ncftp-3-2-6-drop-IPv6-patch-td319222.html">http://openbsd-archive.7691.n7.nabble.com/Update-net-ncftp-3-2-6-drop-IP...</a>

HEADS-UP: mod_security_crs (Core Rule Set) updated to 3.0.0 (rawhide)

Hi All,

Please note that mod_security_crs (Core Rule Set, now from OWASP) has
been updated to 3.0.0 in rawhide, the update should be smooth for most
standard setup.

Copr repo athmane/mod_security[1] has been updated as well, note that
EL7 is broken atm due to RHBZ #1444652 [2]

[1] <a href="https://copr.fedorainfracloud.org/coprs/athmane/mod_security/" title="https://copr.fedorainfracloud.org/coprs/athmane/mod_security/">https://copr.fedorainfracloud.org/coprs/athmane/mod_security/</a>

[2] <a href="https://bugzilla.redhat.com/show_bug.cgi?id=1444652" title="https://bugzilla.redhat.com/show_bug.cgi?id=1444652">https://bugzilla.redhat.com/show_bug.cgi?id=1444652</a>

Best regards.

- Athmane

Orphaning some packages

Hello,

I'm orphaning the following packages:

rpms/python-ctypesgen ==> Unmaintained upstream
rpms/python-foolscap ==> Nothing depends on it
rpms/s3ql ==> EL6 branch
rpms/sticky-notes ==> EL branches, Unmaintained upstream, also Fedora
Infra moved away from it

Best regards.

- Athmane

Package retired by was taken (by me)

Hello Till,

It seems that s3ql package was retired today however I took the
package on 2016-05-16 and update it week later, see BZ #1249301

[1] <a href="https://bugzilla.redhat.com/show_bug.cgi?id=1249301" title="https://bugzilla.redhat.com/show_bug.cgi?id=1249301">https://bugzilla.redhat.com/show_bug.cgi?id=1249301</a>

Best regards.

- Athmane

Orphaning thttpd

Hi,

I'm orphaning thttpd since it didn't receive any updates for years,
plus upstream does not accept patches.

Other distros already switched for some forks [1].

[1] <a href="https://blogs.gentoo.org/blueness/2014/10/03/sthttpd-a-very-tiny-and-very-fast-http-server-with-a-mature-codebase/" title="https://blogs.gentoo.org/blueness/2014/10/03/sthttpd-a-very-tiny-and-very-fast-http-server-with-a-mature-codebase/">https://blogs.gentoo.org/blueness/2014/10/03/sthttpd-a-very-tiny-and-ver...</a>

Best regards.

- Athmane

Orphaning nmon

Hello,

I'm orphaning nmon since I'm not using it anymore.

Best regards.

- Athmane

Orphaning greybird

Hello

I'm orphaning greybird[1] theme suite for Xfce due to lack of free time.

<a href="https://admin.fedoraproject.org/pkgdb/acls/name/greybird" title="https://admin.fedoraproject.org/pkgdb/acls/name/greybird">https://admin.fedoraproject.org/pkgdb/acls/name/greybird</a>

Thanks.

-- Athmane

Hydra license change

Hi

Hydra license has changed from 'GPLv3 with exceptions' to 'AGPLv3 with
exceptions'.

Thanks.

-- Athmane

Looking for reasons why mod_security pkg was orphaned/retired

Hi,

I'm (co-/) maintainer of mod_security, I noticed that the owner
orphaned
it and then retired it, obviously I can't take it over. [1]

I'm kindly asking for the reasons ?

I'm maintaining this package (on fedora and epel) lately so it safe
to assign to me if it's possible.

CCing the former and new owners.

[1] <a href="https://admin.fedoraproject.org/pkgdb/acls/name/mod_security" title="https://admin.fedoraproject.org/pkgdb/acls/name/mod_security">https://admin.fedoraproject.org/pkgdb/acls/name/mod_security</a>

Thanks.

-- Athmane

Orphaning ncpfs

Hi,

I've orphaned ncpfs because it's a dead upstream (access to
source/tarballs is not possible).

I took it in the first place because I had a package that depends on
ncpfs-devel but it's no longer the case.

Regards.

--Athmane

Self introduction

Hi,

I'm Athmane Madjoudj (FAS/IRC: athmane), I work as a sysadmin (RHCE) and
I've been using fedora since Fedora Core 6 (or so), I'm also member of
Fedora Quality Assurance and Infrastructure teams.

I would like to start contributing to fedora packaging, and I'm looking
for a sponsor (I'm familiar with rpm and I did some commenting on review
requests in the past).

Here's my packages that need a review:

<a href="https://bugzilla.redhat.com/show_bug.cgi?id=769056" title="https://bugzilla.redhat.com/show_bug.cgi?id=769056">https://bugzilla.redhat.com/show_bug.cgi?id=769056</a>
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=769919" title="https://bugzilla.redhat.com/show_bug.cgi?id=769919">https://bugzilla.redhat.com/show_bug.cgi?id=769919</a>

Thanks and happy holidays.

- Athmane

Test result for CentOS-6 LiveCD

Hello,

I ran some tests on CentOS-6 LiveCD using Patrice's livecd-creator rpms
and Fedora's one, also I'll be very glad if someone can approve my qaweb
account (username: athmane) so I'll be able to update LiveCD ticket
instead of posting here.

Kickstart:
<a href="https://projects.centos.org/trac/livecd/browser/trunk/CentOS6/rhel6beta-livecd-minimal.ks" title="https://projects.centos.org/trac/livecd/browser/trunk/CentOS6/rhel6beta-livecd-minimal.ks">https://projects.centos.org/trac/livecd/browser/trunk/CentOS6/rhel6beta-...</a>

Tests 1:

Live CD compose on fedora 15 host : PASSED
ISO size < 700M : PASSED
Booting with the composed ISO : FAILED | unable to mount root fs
Live image installation : N/A
Booting the installed system : N

Xfce/LXDE wiki page seems outdated

Hello,

Sorry for posting this here, I'm not subscribed to Xfce and LXDE lists.

As of Fedora 15, Xfce/LXDE are included in DVD (I checked on x86_64
DVD), but wiki pages [1] and [2] still mention about not being available
in DVD and the requirement of Internet connection.

[1] <a href="http://fedoraproject.org/wiki/Xfce" title="http://fedoraproject.org/wiki/Xfce">http://fedoraproject.org/wiki/Xfce</a>
[2] <a href="http://fedoraproject.org/wiki/LXDE" title="http://fedoraproject.org/wiki/LXDE">http://fedoraproject.org/wiki/LXDE</a>