DevHeads.net

Postings by =?ISO-8859-1?Q?S=E9rgio?= Basto

Re: scratch build of python-kivy fails on rawhide

+ Exit 1,
Child return code was: 1

Sent from my AndroidEm 26/05/2018 5:24 da tarde, Martin Gansser <martin. ... at gmail dot com> escreveu:

notifications@fedoraproject.org

Hi,

I have a suggestion. After some confusions that I have made related
with notifications with a big delay .

Please add the date of notification on the notification .

Thanks,

branched compose never end

Hi,
ATM, Fedora-28-20180303.n.1 , Fedora-28-20180304.n.0 and Fedora-28-
20180305.n.0 still running ,

I found one notification in Fedora-28-20180303.n.1 [1] that may explain
why [2] is waiting for a commit sign for 22 hours.

Cheers,

[1]
<a href="https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180303" title="https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180303">https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180303</a>.
n.1/logs/global/notifications/notification-2018-03-05_02-36-29.log

[2]
2018-03-05 02:36:30.394652: Commit not signed yet, waiting
(...)
2018-03-05 23:11:20.314618: Commit not signed yet, waiting

Re: [HEADS UP] Removal of systemd-units

Btw this scriptlenting doesn't break epel 7 i.e. I had received reports that systemd doesn't reload daemons correctly in epel 7 , I'm talking about clamav

Sent from my Android
Em 31/01/2018 3:51 da manhã, Nathanael Noblet < ... at fedoraproject dot org> escreveu:

cflag ffast-math

Hi,
Question about gcc cflag ffast-math .
Should I enable cflag ffast-math on opencv build explicitly
( -DENABLE_FAST_MATH=ON ) ? and I keep disable cflag ffast-math in mlt
build [1] ?

Thanks,

[1]
<a href="https://src.fedoraproject.org/rpms/mlt/blob/master/f/mlt.spec#_127" title="https://src.fedoraproject.org/rpms/mlt/blob/master/f/mlt.spec#_127">https://src.fedoraproject.org/rpms/mlt/blob/master/f/mlt.spec#_127</a>

How_do_I_request_commit_access_to_a_dist-git_repo where I'm admin ?

Hello

I'm the admin of <a href="https://src.fedoraproject.org/rpms/clamav/" title="https://src.fedoraproject.org/rpms/clamav/">https://src.fedoraproject.org/rpms/clamav/</a> but I
haven't commit permissions for brancn epel 7 , what I need to do ? to
have permission to commit on epel7 .

Best regards,

opencv 3.3.1 is going to rawhide

Hello.
I'm going submit opencv 3.1 in rawhide to fix a lots of CVE(s) [1] and
new feature also have a new module with compatibly with mlt
TBH I though/expect someone from RedHat take care of it .

mlt moved to SDL2 in rawhide

Hi,

My advise is rebuild packages that depend on MLT for that we need a
provenpackager, running repoqueries [1] and [2] I got these packages to
rebuild 

synfig-1.2.1-1.fc28.src.rpm rawhide
synfigstudio-1.2.1-1.fc28.src.rpm rawhide
webvfx-0.4.5-0.2.20160823gite918ce4.fc28.src.rpm rawhide

[1]
dnf repoquery --disablerepo=* --enablerepo=rawhide \
--enablerepo=rpmfusion-{non,}free-rawhide  \
--available --whatrequires "mlt*" --alldeps --quiet \
--qf "%{sourcerpm} %{repoid}" --refresh 

[2]
dnf repoquery --disablerepo=* --enablerepo=rawhide \
--enablerepo=rpmfusion-{non,}free-rawhide  \
--avail

soundtouch soname bump

Hi, 
Build of soundtouch-2.0.0-1.fc28 is completed, we need a provenpackager
to rebuild [1] :
Io-language
ardour2
audacity
gstreamer-plugins-bad-free
gstreamer1-plugins-bad-free

After that, may we also update F27 ? we need one provenpackager take
care of it ...

freeze time ?

Hello,
Unfortunately I don't have time to follow many of Fedora
related activities. AFAIK freezes in f27 changed. 
First are we in freeze time ? until when ?
May you announce when we enter in freeze time. And the date of last
push before start freezing ? and when we may update f27 branch again
? if not to much work .

Thanks ,

one concrete ideas for fedora

Do a stable release do Fedora 25.1 or 26.1

install a live disk and have 2 bg of updates is a joke,
you may take double of the time but do something that we can call it
stable .

giflib or libgif is 5 years old

Hello,
Since 2012-06-20 giflib-5.0.0 is available [1] but rawhide still have
version 4.1.6-17.fc27 , can we update it ?
I usually could ask for ACLs but ENOTIME ...

Thanks,

[1]
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=822844" title="https://bugzilla.redhat.com/show_bug.cgi?id=822844">https://bugzilla.redhat.com/show_bug.cgi?id=822844</a>

repoview source fedorahosted and rpm groups again

Hi,
anyone knows where is the source code of 
<a href="http://fedorahosted.org/repoview/" title="http://fedorahosted.org/repoview/">http://fedorahosted.org/repoview/</a> ?

Have we any better tool ? (to view packages in web )

repoview still rely on group tag of rpm spec , but Fedora Packaging
Guidelines says that group tag is obsolete .

retiring libaudclient

Hi, 
libaudclient was no longer used by any package, so it is a good time to
retire it for F26 . As usual who may want it,  can take it . 

Cheers
-- 
Sérgio M. B.

yet anothers things to do: Appstream, comps and remix

Hello, 

Adam Williamson wrote today in reply of one question (made by me) : 
"Hmm, actually, maybe it currently doesn't, but it definitely has
before:

<a href="http://download1.rpmfusion.org/free/fedora/updates/testing/20/x86_64/comps.xml" title="http://download1.rpmfusion.org/free/fedora/updates/testing/20/x86_64/comps.xml">http://download1.rpmfusion.org/free/fedora/updates/testing/20/x86_64/com...</a>

But basically, any repo can have comps data and dnf will respect it;
you can set up an external repo with comps data that lists some package
from that repo as being in the `standard` group, for instance, and when
it installs the `standard` group, dnf will include that package. AFAIK
this has always been intended to work. I'm not sure how often it gets
tested.

what happened with rawhide/i386

Hi, 
I'm getting errors when build in i386 of rawhide and check that master
and mirror haven't i386 [1] had I missing something ? , this is a bug
or a feature ? 

[1] https://mirrors.kernel.org/fedora/development/rawhide/Everything/

Thanks

Can I request update of mock with fedora-25 configurations ?

Hello, 
After Fedora 25 Mass Branching , should be mock update with fedora-25
configurations  ? 
Other question where I should ask it ? bugzilla ? 

Thanks,

kernel 4.7 on stable ?

Hi,
From list of koji builds [1] rawhide and F25 uses pre 4.8. My question
is kernel-4.7.0-2 doesn't land on F24 and F23 ? , since kernel 4.6
already have a short live and 4.7 fix my cpu-freq kernel ooops , I vote
in have kernel-4.7 in stable releases :).

[1] http://koji.fedoraproject.org/koji/packageinfo?packageID=8 

Thanks, 

update after microcode_ctl-2.1-10.fc23.x86_64 with big problems

Hi, 
after read the notes on 
<a href="https://bodhi.fedoraproject.org/updates/FEDORA-2016-784d5526d8" title="https://bodhi.fedoraproject.org/updates/FEDORA-2016-784d5526d8">https://bodhi.fedoraproject.org/updates/FEDORA-2016-784d5526d8</a>

For those with Skylake CPUs, please note that there may be instability
with a recent microcode update.

how is create or how I recreate /etc/sysconfig/kernel

Hi, 
Today after round and round and since begging of Fedora with grub2.

pngquant license change to GPLv3+

pngquant-2.7.0-1 changed license from BSD with advertising to GPLv3+ .

why libcdaudio is in critpath and how I remove from there ?

Hello, sometime ago I took libcdaudio , because though that was
important to keep it, nowadays almost all packages that need cdaudio,
use libcdio and libcdio-paranoia [1], so I think the correct is remove
libcdaudio from critpath , how we do that ? 

Thanks, 

[1]
dnf repoquery --whatrequires libcdaudio --alldeps --qf="%{sourcerpm} %{name} %{repoid}"
(...)
gstreamer-plugins-bad-free-0.10.23-28.fc23.src.rpm gstreamer-plugins-bad-free-extras fedora
gstreamer-plugins-bad-free-0.10.23-29.fc23.src.rpm gstreamer-plugins-bad-free-extras @System
gstreamer-plugins-bad-free-0.10.23-29.fc23.src.rpm gstre

Heads up: libprojectM soname bump in F24 an rawhide

Hello , finally libprojectM have been update from 2.0.1 to 2.1.0 in
rawhide and F24 

dnf repoquery --enablerepo=updates-testing --whatrequires libprojectM --alldeps
dnf repoquery --enablerepo=updates-testing --whatrequires projectM-jack --alldeps
dnf repoquery --enablerepo=updates-testing --whatrequires projectM-pulseaudio --alldeps
dnf repoquery --enablerepo=updates-testing --whatrequires projectM-libvisual --alldeps

give me clementine and qmmp needs to be rebuild

Best regards,

packages not signed in F24 are breaking corp builds

Hello ,

Packages not signed in F24 are breaking copr builds , but I need copr
to test packages for F24 ...

What should we do ? to workaround this problem.

Thanks,

Couldn't find DIE referenced by DW_OP_GNU_implicit_pointer

Hello,
What $subject means ? , should I be worried ? 

Only happens in rawhide , I think is GCC6 warning.  
Thanks,

Non-responsive package maintainer process - libprojectM

Hello 
I wrote in https://bugzilla.redhat.com/show_bug.cgi?id=827397 more than
a month 
I'd like update to last version 2.1 that have 3 years,
now the we got a FTBFS , https://bugzilla.redhat.com/show_bug.cgi?id=13
07730

Best regards, 

Advertised OpenGL version clarification (with some typos fixed)

Hi, 
Some people have been asking for Opengl 3+ on Fedora 23

https://ask.fedoraproject.org/en/question/8311/why-fedora-do-not-ship-opengl-30-even-disable-it-for-intel-hw/ 

<a href="https://ask.fedoraproject.org/en/question/80679/supertuxkart-not-working-after-fedora-23/?answer=80681#post-id-80681" title="https://ask.fedoraproject.org/en/question/80679/supertuxkart-not-working-after-fedora-23/?answer=80681#post-id-80681">https://ask.fedoraproject.org/en/question/80679/supertuxkart-not-working...</a>

Red Hat response (March 2013) : <a href="http://lists.fedoraproject.org/pipermail/test/2013-March/114161.html" title="http://lists.fedoraproject.org/pipermail/test/2013-March/114161.html">http://lists.fedoraproject.org/pipermail/test/2013-March/114161.html</a>

Advertised OpenGL version clarification

Hi, 
Some people have been asking for opengl 3 + 

<a href="https://ask.fedoraproject.org/en/question/8311/why-fedora-do-not-ship-o" title="https://ask.fedoraproject.org/en/question/8311/why-fedora-do-not-ship-o">https://ask.fedoraproject.org/en/question/8311/why-fedora-do-not-ship-o</a>
pengl-30-even-disable-it-for-intel-hw/ 

<a href="https://ask.fedoraproject.org/en/question/80679/supertuxkart-not-workin" title="https://ask.fedoraproject.org/en/question/80679/supertuxkart-not-workin">https://ask.fedoraproject.org/en/question/80679/supertuxkart-not-workin</a>
g-after-fedora-23/?answer=80681#post-id-80681

Red Hat response (March 2013) : <a href="http://lists.fedoraproject.org/pipermai" title="http://lists.fedoraproject.org/pipermai">http://lists.fedoraproject.org/pipermai</a>
l/test/2013-March/114161.html

where is mariadb-10.0.21-1.fc23 ?

Hi,

Where is mariadb-10.0.21-1.fc23 ? [1] says that have been push to stable
but upgrading my system, mariadb is downgraded from mariadb-10.0.21 to
mariadb-10.0.20 !

To someone with power to push packages on Fedora 21

Hi,
We detect migration problem from bodhi 1 to 2 [1]

Can someone workaround and push to stable, because they reached the
stable karma threshold:

<a href="https://bodhi.fedoraproject.org/updates/FEDORA-2015-11787" title="https://bodhi.fedoraproject.org/updates/FEDORA-2015-11787">https://bodhi.fedoraproject.org/updates/FEDORA-2015-11787</a>
<a href="https://bodhi.fedoraproject.org/updates/FEDORA-2015-4638" title="https://bodhi.fedoraproject.org/updates/FEDORA-2015-4638">https://bodhi.fedoraproject.org/updates/FEDORA-2015-4638</a>

This doesn't reached the stable karma threshold but should also be
pushed, because packages shouldn't stay in update testing forever ...