DevHeads.net

Postings by Phil Dobbin

Super Key no longer shows Apps

Hi all.

I noticed this morning that when pressing the Super (Windows) key the
applications are missing: "Sorry there is nothing matching your search".

It finds files, images, music etc but no apps. Has anybody else seen this?

Cheers,

Phil

Software Updater messages

Hi all.

I'm getting a stream of messages from Software Updater's terminal read
out when I use it. They're mainly Perl errors but there's too many of
them & they travel too fast to be able to figure out what they mean.

I've looked in about every log file for any trace of the read-out but to
no avail. Does anybody know where I might look so I can act on the errors?

Any help appreciated.

Cheers,

Phil.

MD5SUMS

Hi all.

Very basic question but it's stumped me: when I try to download the
MD5SUMS file from <a href="http://releases.ubuntu.com" title="http://releases.ubuntu.com">http://releases.ubuntu.com</a> all I can do is bring up
the contents in a different tab.

Can anybody enlighten me of any method that allows me to download said
file. wget maybe? or curl would do. http is fine also.

Many thanks,

Cheers,

Phil.

CVE-2017-1000117 git: Command injection via malicious ssh URLs

Hi all.

I've just seen this security update (from RedHat):

'CVE-2017-1000117 git: Command injection via malicious ssh URLs'

& wondered if anybody knew when it will arrive in Apt?

Cheers,

Phil.

HP Elitebook 8460p

Hi, all.

I'm intending to install CentOS 7 on a HP Elitebook 8460p. Does anybody
have any experience of this?

Many thanks for any help.

Cheers,

Phil...

HP Elitebook 8460p

Hi, all.

I'm looking to install CentOS 7 to my HP Elitebook 8460p (Intel i5, 4gig
of RAM, 250 HD). Has anybody had any experience with this laptop &
CentOS 7?

Many thanks for any help.

Regards,

Phil...

Mouse problems - 13.10

Hi, all.

I'm experiencing a strange issue with the mouse on 13.10.

After a while, even though I can still move it, the mouse loses its
clickability on both right & left click. A reboot resolves the situation
& the keyboard functions normally throughout.

I Googled the subject & got several answers but nothing that resolved
the problem & a lot of stuff didn't really make sense.

Has anybody suffered this?

Any help appreciated.

Cheers,

Phil...

Non working Chrome in 13.04

Hi, all.

I just upgraded from 12.10 to 13.04 & now Google Chrome no longer works.
Firefox is fine (as far as it goes) but Chrome just swells for a bit &
then doesn't launch at all.

Has anybody else seen this?

Cheers,

Phil...

EPEL problem

Hi, all.

I'm trying to install the EPEL repo on a fully up to date CentOS 6.4.
I'm using wget to download from my usual source but after I install it
via `sudo rpm -ivh epel-xxxxx` it's not actually there in
`/etc/yum.repos.d`.

Trying to install it again, Yum just tells me it's already installed.

I've no idea where it is installed if it is (which I don't think it is)
so I'm stumped.

Any help appreciated.

Cheers,

Phil...

reconfigure keyboard

Hi, all.

Last night I upgraded a 13.04 machine to 13.10 & it all went well apart
from the upgrade seems to have reconfigured my keyboard for me.

The tilde key is now the pipe & tilde is now located at shift-backtick.
That I can live with but unfortunately the hash key has disappeared
completely which makes say, writing a bash script or commenting out
stuff kind of difficult.

What's the best way to reset the keyboard back to where it was
previously (qwerty UK English).

Any help appreciated.

Cheers,

Phil...

Thunderbird 24 on 13.04

Hi, all.

I'm experiencing a problem with Thunderbird 24 on 13.04 x86_64.

Several times in the past couple of days it's froze the machine
completely (mouse, keyboard) & I've just about managed to drop into a
console via ctrl-alt-f2 & killed it or `sudo shutdown -r now` on one
occasion.

I've got TB running on OS X without issue (I don't bother on the other
distros as most are servers) but OS X is only running version 17.0.8 of it.

Has anybody else seen this or is a trip to the Mozilla boards on the cards?

Any help appreciated.

Cheers,

Phil...

Weird netinstall issue

Hi.

The other day I burnt a copy of a CentOS 6.4 64 bit netinstall disc,
verified the disc which passed & about a third of the way through the
install it informed me that there was no CD in the drive & refused to
carry on.

So I burnt another & the same thing happened. So using the same disk
burner & the same batch of disks, I burnt a copy of a Debian 7.1
netinstall & it installed perfectly.

Any thoughts gladly welcome (the CentOS disc was downloaded from the
CentOS repos).

Cheers,

Phil...

erase disk

Hi.

I have a CentOS server (a Dell 860) with two drives in it.

One is running CentOS 6.4 which I want to keep & the bigger 400GB drive
has Debian 7 on it which I want to erase & use for backups.

Which is the best way to go about achieving my intended goal? The Debian
drive is not mounted when Centos is booted.

Any help appreciated.

Cheers,

Phil...

Ananconda

Hi, all.

I was wondering as to why Ananconda has no facility to overwrite a
distro already present on the target machine. I've studied it & apart
from destroying the existing partition with GParted there seems to be no
other way (this happens on 18 & 19).

Most painful it is.

If anybody can show me a workaround I'd be most grateful.

Cheers, Phil...

desktop switcher 13.04

Hi, all.

I've just upgraded to 13.04 (Unity) & ctrl-alt-arrows no longer works to
switch desktops. Is there a new key combination or has the feature been
eradicated?

Any help appreciated.

Cheers,

Phil...

yum problem

Hi, all.

I'm experiencing a problem with Yum. When I call 'sudo yum update' it
tells me that it can't find any mirrors & after doing a 'sudo yum clean
all' it just informs me it can't find any base repo & quits.

This is on a brand new installation of CentOS 6.2 x86_64.

Resize boot partition

Hi, all.

Ubuntu 13.04 (Gnome) is telling me that my /boot partition on
(/dev/sda1) is 96% full.

Is the best option to boot from Knoppix & resize the partition or is it
safe to delete all the old kernels to free up the space? If I can safely
delete the kernels, what's the best way to go about it?

Any help appreciated,

Cheers,

Phil...

Mirror failure

Hi, all.

I was getting:

`http://mirror01.th.ifl.net/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd181a84ca684bba1a1df1c612702c7c6760a04645-filelists.sqlite.bz2:
[Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirror01.th.ifl.net'"
Trying other mirror.
<a href="ftp://ftp.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd181a84ca684bba1a1df1c612702c7c6760a04645-filelists.sqlite.bz2:" title="ftp://ftp.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd181a84ca684bba1a1df1c612702c7c6760a04645-filelists.sqlite.bz2:">ftp://ftp.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/6/x86_64...</a>
[Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'ftp.mirrorservice.org'"
Trying other mirror.
<a href="ftp://ftp.fedora.is/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd18" title="ftp://ftp.fedora.is/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd18">ftp://ftp.fedora.is/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd18</a>

Mirror problem

Hi, all.

I was getting:

`http://mirror01.th.ifl.net/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd181a84ca684bba1a1df1c612702c7c6760a04645-filelists.sqlite.bz2:
[Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirror01.th.ifl.net'"
Trying other mirror.
<a href="ftp://ftp.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd181a84ca684bba1a1df1c612702c7c6760a04645-filelists.sqlite.bz2:" title="ftp://ftp.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd181a84ca684bba1a1df1c612702c7c6760a04645-filelists.sqlite.bz2:">ftp://ftp.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/6/x86_64...</a>
[Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'ftp.mirrorservice.org'"
Trying other mirror.
<a href="ftp://ftp.fedora.is/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd18" title="ftp://ftp.fedora.is/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd18">ftp://ftp.fedora.is/pub/epel/6/x86_64/repodata/c60f7c3ee6f9a4902d5ce9dd18</a>

mysql upgrade error

Hi, all.

I ran software upgrade this morning & got this message:

'installing new version of config file /etc/init/mysql.conf ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.5 (--configure):
subprocess installed post-installation script returned error exit
status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
Package mysql-server-5.5 is not configured dpkg: error
processing mysql-server (--configure): dependency problems

CentOS 5 netinstall problem

Hi, all.

I'm attempting to install CentOS 5 via netinstall from
<mirror.centos.org/centos/5/os/i386> & it gets as far as formatting the
disk but when it gets to:

'Starting install process.
This may take take several minutes...'

it hangs forever (well, a couple of hours).

Dropping down in a console I see it's telling me:

'Preparing to install'

then nothing.

Raring updates

Hi, all.

I'm seeing some odd behaviour on a 13.04 box.

For the last six days not a single update has come down the pipe from
Ubuntu. I've changed the update servers from the UK to the main servers
but nada.

I've checked sources.list & all looks OK so has anybody else seen this?

This box (the only one I have at present running Raring) was a daily
that was released a couple of days before the GM went live & updated
fine until 5d 20h ago (or so byobu is telling me).

It must be something to do with sources.list but I can't see it.

Any help appreciated.

Cheers,

Phil...

Rhythmbox/Apport fail

Hi, all.

32-bit Ubuntu 12.04.2 trying to import (or extract) a Audio CD into
Rhythmbox. It crashes. Crash reporter comes up, it crashes too.

Try again, exactly the same thing happens.

It's done this before which means I have to rip it to iTunes on my
Macbook Pro & the copy it across via Samba which is not ideal.

Any advice appreciated.

ubuntu-adk-admins repo

Hi, all.

Does anybody know what's happened to the ubuntu-adk-admins repo at
<http://ppa.launchpad.net>?

Was working fine 'til yesterday but has now vanished without trace. I
checked it on the web & it's gone & apt is moaning. No big deal, I just
commented it out but I'd be interested to know.

Cheers,

Phil...

alsamixer: lock levels

Hi, all.

I'm hoping somebody's going to take pity on me here...

My three kids all have Ubuntu machines (2 off 12.04 & 1 off 12.10) &
boy, do they love You Tube. Which, in itself, is no big thing but, kids
being kids, the volume levels can get ear shattering when all three are
at it together.

Is there anyway I can ssh into each machine (ssh & ssh keys are already
set up) & lock alsamixer's output levels to say, 25%? Or, indeed, any
other way to tame the output levels. They're using You Tube in Firefox
if that's any help.

Any help appreciated.

Cheers,

Phil...

ddclient

Hi, all.

I have to admit, I'm really struggling trying to get ddclient to work at
all.

I started off with a full '/etc/ddclient.conf' file but was plagued by
this dreaded error message:

'WARNING: file/var/cache/ddclient/ddclient.cache, line 3: Invalid Value
for keyword 'ip' = '''

along several lines (lines 3, 4 & 12)

Upon inspection of said file, nothing glaringly obvious stood out but
every time I ran:

'sudo ddclient -use=ip -ip=1.2.3.4 -daemon=0'

it failed & rm'ing the offending cache file didn't work either: still
got the same error message & the file reappeared with the same obtuse

Rhythmbox directory permissions problems

Hi, all.

I've just tried to rip an audio CD to Rhythmbox on 12.04 & I kept
getting "Error creating directory permission denied". Why it's denying
me access to the Music folder in my Home directory is a mystery.

nanosudo?

Hi, all.

I've just spun up a 12.04 remote virtual machine & when I ran the visudo
command, it plonked me into nano. Whilst this is easy to fix (sudo
update-alternatives --config editor), I'm puzzled as to when this happened.

I know it happened on some of the Red Hat clones but it was duly
reported upstream as a bug & upstream confirmed it was bug.

Is it a bug on Ubuntu or is this behaviour now the default?

Cheers,

Phil...

ATI Radeon 7000

Hi, all.

I'm contemplating installing 64 bit Ubuntu on a Poweredge 1850.

I booted from the 12.04 Live CD & it ran pretty well.